Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    jamba
    Bom dia galera blz?

    Montei um formulario que submetido ira gravar num banco MySQL.
    O problema eh que qdo puxo os registros do banco, tudo que tem Ç e acentos(^~´`) na tela aparece uma de codigo loko, como quadrado, interrogacao inverso entre outros mas no banco esta tudo certinho.

    Gostria de um auxilio do pq isso acontece e como resolver.
    A principio vejo isso como a nao compatibilizacao dos browsers, mas tem hr que funfa e temhr que nao funfa.

    Valeu

  2. isso eh o tipo do idioma do campo no banco, ele tem q estar como latin-1 pra ter suporte a isso, por exemplo no meu:

    ALTER TABLE `mensagens` CHANGE `msg` `msg` LONGTEXT CHARACTER SET latin1 COLLATE latin1_swedish_ci NOT NULL



  3. #3
    jamba
    Esta LATIN1

  4. eh php?

    se vc fizer:

    echo "ç~^!'";

    ele mostra os caracteres normalmente?
    alias tentou visualizar isso em outra maquina soh pra garantir que nao eh a visualizacao do navegador?



  5. #5
    jamba
    Citação Postado originalmente por 1c3_m4n
    eh php?

    se vc fizer:

    echo "ç~^!'";

    ele mostra os caracteres normalmente?
    alias tentou visualizar isso em outra maquina soh pra garantir que nao eh a visualizacao do navegador?
    Imprime codigos...entao ja vi que eh o navegador, uso o IE 6.0 do XP e o FireFox1.0.2 que atualizei ontem...os 2 estao com padrao ISO-8859-1.

    Em outros aqui do trampo rola normal, porem o meu que eh igual nao.






Tópicos Similares

  1. Onde coloco o arquivo de registro do Kylix ?
    Por ricardodru no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 18-11-2003, 08:34
  2. Retorno de mensagens
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 31-07-2003, 17:46
  3. Retorno de e-mails
    Por PcGuy no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-02-2003, 13:27
  4. Retorno de erro smtp;554 5.6.1!
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-11-2002, 17:38
  5. Retorno de erro para domínio específico
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-11-2002, 18:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L