+ Responder ao Tópico



  1. #1
    jamba
    Visitante

    Padrão retorno de registros

    Bom dia galera blz?

    Montei um formulario que submetido ira gravar num banco MySQL.
    O problema eh que qdo puxo os registros do banco, tudo que tem Ç e acentos(^~´`) na tela aparece uma de codigo loko, como quadrado, interrogacao inverso entre outros mas no banco esta tudo certinho.

    Gostria de um auxilio do pq isso acontece e como resolver.
    A principio vejo isso como a nao compatibilizacao dos browsers, mas tem hr que funfa e temhr que nao funfa.

    Valeu

  2. #2

    Padrão retorno de registros

    isso eh o tipo do idioma do campo no banco, ele tem q estar como latin-1 pra ter suporte a isso, por exemplo no meu:

    ALTER TABLE `mensagens` CHANGE `msg` `msg` LONGTEXT CHARACTER SET latin1 COLLATE latin1_swedish_ci NOT NULL



  3. #3
    jamba
    Visitante

    Padrão retorno de registros

    Esta LATIN1

  4. #4

    Padrão retorno de registros

    eh php?

    se vc fizer:

    echo "ç~^!'";

    ele mostra os caracteres normalmente?
    alias tentou visualizar isso em outra maquina soh pra garantir que nao eh a visualizacao do navegador?



  5. #5
    jamba
    Visitante

    Padrão retorno de registros

    Citação Postado originalmente por 1c3_m4n
    eh php?

    se vc fizer:

    echo "ç~^!'";

    ele mostra os caracteres normalmente?
    alias tentou visualizar isso em outra maquina soh pra garantir que nao eh a visualizacao do navegador?
    Imprime codigos...entao ja vi que eh o navegador, uso o IE 6.0 do XP e o FireFox1.0.2 que atualizei ontem...os 2 estao com padrao ISO-8859-1.

    Em outros aqui do trampo rola normal, porem o meu que eh igual nao.

  6. #6

    Padrão retorno de registros

    se no mesmo navegador outros funfam normal nao eh o navegador nao, deve ser o php mesmo, o servidor q ta rodando essa tua aplicacao eh o mesmo onde tem os outros da sua empresa?