Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Caros colegas,


    Estou tentando compila do Bandwidth mais esta dando erro, gostaria de sabe si alguem tem alguma sugestão.

    ERRO:
    bandwidthd-2.0.1]# ./configure
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for bison... bison -y
    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for executable suffix...
    checking for object suffix... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for a BSD compatible install... /usr/bin/install -c
    checking for flex... flex
    checking for yywrap in -lfl... yes
    checking lex output file root... lex.yy
    checking whether yytext is a pointer... yes
    checking how to run the C preprocessor... gcc -E
    checking for X... no
    checking for /sw/lib... no
    checking for /sw/include... no
    checking for /usr/pkg/lib... no
    checking for /usr/pkg/include... no
    checking for connect in -lsocket... no
    checking for gethostbyname in -lnsl... yes
    checking for inet_aton in -lresolv... yes
    checking for pow in -lm... yes
    checking for libiconv_open in -liconv... no
    checking for png_read_info in -lpng... no
    configure: error: Bandwidthd requires but cannot libpng

  2. #2
    wrochal
    Caro,

    Basta instalar esta biblioteca

    http://www.libpng.org/pub/png/libpng.html

    Falou,



  3. #3
    if u think u got libpng there (like i did), try this one:
    LDFLAGS="-lz" ./configure

  4. Citação Postado originalmente por Anonymous
    if u think u got libpng there (like i did), try this one:
    LDFLAGS="-lz" ./configure
    olha q interessante, alguem que le a pergunta em portugues, entende o erro mas responde em ingles..... :toim:



  5. #5
    E o melhor eh que a resposta resolve o problema.... :-)






Tópicos Similares

  1. Erro ao compilar o links-2.1pre13
    Por Francisco14 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 09-07-2004, 12:14
  2. Erro ao compilar mysql++
    Por NeoRamza no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-05-2004, 23:33
  3. Erro ao compilar o module-init-tool
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 2
    Último Post: 01-03-2004, 23:00
  4. erro ao compilar o samba
    Por APS no fórum Servidores de Rede
    Respostas: 0
    Último Post: 03-10-2003, 11:27
  5. Erro ao compilar o Kernel
    Por fsales no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-04-2003, 02:50

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L