+ Responder ao Tópico



  1. #1

    Padrão dúvidas em instalação na mão

    Caros colegas do under,


    Uso as distros Red Hat, Fedora e Trustix e às vezes, quando vou instalar algum programa que não seja via rpm, na etapa do ./configure, tenho algumas mensagens insuportáveis dizendo que falta "tal biblioteca ou arquivo" para que aquele programa possa ser instalado. Qual a maneira mais fácil de localizar essas bibliotecas e instalá-las? Existe algum padrão para a localização dessas?

    Obrigado.

  2. #2

    Padrão dúvidas em instalação na mão

    nao existe um padrao...

    a maneira d encontra eh soh usando o google e os sites d softwares como o sourceforge ou o freshmeat..

    tem um projeto q quer melhorar isso.. eh o autopackage
    https://under-linux.org/modules.php?...rder=0&thold=0

    []'s



  3. #3
    maverick_cba
    Visitante

    Padrão dúvidas em instalação na mão

    Seguinte roggy, as bibliotecas são conjunto de ferramentas, compiladores e scripts que são necessários durante a compilação e instalação de programas que estão em código fonte.

    Para que você não fique tendo mais dor de cabeça com essas bibliotecas, o recomendado é que durante a instalação do seu sistema linux, você inclua todas as bibliotecas disponíveis pela sua distro e instale elas.

    As mais comuns são gcc, make, autoconf, libgcc e assim por diante.

    Caso já tenha instalado o sistema operacional, você pode adicionar essas bibliotecas digitando o comando setup no prompt (somente sistemas baseados em Red Hat como fedora).

    Código :
    # setup

    Dai na seção de pacotes (packages) você pode adicionar ou remover pacotes. Lembre-se de ter em mão o cd de instalação caso vá adicionar pacotes.

  4. #4

    Padrão dúvidas em instalação na mão

    se vc quer resolucao de dependencia automatica volte a usar rpm.........
    se vc instala via fonte, vc tb vai ter que instalar as deps via fonte...

    quase sempre a lib q ele fala q falta eh o nome do pacote pela, por exemplo
    suponha q ele nao encontre a libncurses.so (vc vai ter q instalar o pacote ncurses...)