Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    aluisiogouveia
    Ola Comunidade,

    Ja faz um tempo que estou tentando configurar a autenticacao de usuarios no squid, ja li diversos artigos mesmo assim ainda nao consegui, para tentar entender o problema eu instalei o squid-2.5.STABLE8-1.FC3.1.i386.rpm em uma maquina com Fedora Core 3, mantive o squid.conf com as regras padrao, apendas adicionei algumas linhas para exigir a autenticacao, verifiquei o retorno do arquivo ncsa_auth esta ok e esta:

    [root@astem squid]# /usr/lib/squid/ncsa_auth /etc/squid/pwd-squid
    aluisio 123mudar
    OK


    Mas mesmo assim nao consigo autenticar, estou usando Firefox 1.0.2, se eu criar alguma regra de filtro ou bloqueio ele obedece todas, menos a autenticacao, segue me squid.conf se alguem puder me ajudar ficarei muito grato:

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY

    auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/pwd-squid
    auth_param basic children 5
    auth_param basic realm Squid proxy-caching web server
    auth_param basic credentialsttl 2 hours
    auth_param basic casesensitive off

    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320

    acl rede_interna src 192.168.1.0/24
    acl rede_interna proxy_auth REQUIRED
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access allow rede_interna
    http_access deny all

    http_reply_access allow all
    icp_access allow all
    coredump_dir /var/spool/squid

  2. [quote="aluisiogouveia"]Ola Comunidade,

    Ja faz um tempo que estou tentando configurar a autenticacao de usuarios no squid, ja li diversos artigos mesmo assim ainda nao consegui, para tentar entender o problema eu instalei o squid-2.5.STABLE8-1.FC3.1.i386.rpm em uma maquina com Fedora Core 3, mantive o squid.conf com as regras padrao, apendas adicionei algumas linhas para exigir a autenticacao, verifiquei o retorno do arquivo ncsa_auth esta ok e esta:

    [root@astem squid]# /usr/lib/squid/ncsa_auth /etc/squid/pwd-squid
    aluisio 123mudar
    OK


    Mas mesmo assim nao consigo autenticar, estou usando Firefox 1.0.2, se eu criar alguma regra de filtro ou bloqueio ele obedece todas, menos a autenticacao, segue me squid.conf se alguem puder me ajudar ficarei muito grato:

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY

    auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/pwd-squid
    auth_param basic children 5
    auth_param basic realm Squid proxy-caching web server
    auth_param basic credentialsttl 2 hours
    auth_param basic casesensitive off

    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320


    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    acl rede_interna src 192.168.1.0/24
    acl password proxy_auth REQUIRED

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow password
    http_access allow rede_interna
    http_access deny all

    http_reply_access allow all
    icp_access allow all
    coredump_dir /var/spool/squid

    E claro que deve ter mais coisa errada mas vai postando ai!!!



  3. #3
    aluisio
    Blz, esta dica realmente resolveu o problema... mas a minha intensao e fazer os usuarios autenticarem no samba, entao alterei o programa de altenticacao que agora ficou assim:

    auth_param basic program /usr/lib/squid/smb_auth -W MEUDOMINIO -U 192.168.1.2

    qdo testo funciona:

    [root@zender squid]# /usr/lib/squid/smb_auth -W REZENDESISTEMAS -d
    aluisio 123mudar
    Domain name: MEUDOMINIO
    Pass-through authentication: no
    Query address options:
    Domain controller IP address: 192.168.1.2
    Domain controller NETBIOS name: LISA
    Contents of //LISA/NETLOGON/proxyauth: allow
    OK

    Mas qdo entro com usuario e senha do browser ele nao sai da tela de autenticacao e fica assim no log do squid


    1112896611.623 916 192.168.1.91 TCP_DENIED/407 1771 GET http://www.google.com.br/ aluisio NONE/- text/html


    se puder me dar mais alguma dica, agradeco muito.

  4. #4
    netricardo
    No meu resolvi mudando o dono do arquivo de password
    para squid.



  5. #5
    ?asdfasdfds






Tópicos Similares

  1. autenticacao no squid parent
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 02-01-2004, 12:47
  2. autenticacao no squid
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-09-2003, 08:09
  3. Autenticação no Squid de Usuário PDC Windows NT
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 3
    Último Post: 24-07-2003, 14:20
  4. Autenticação no Squid
    Por marmota_uou no fórum Servidores de Rede
    Respostas: 7
    Último Post: 15-04-2003, 17:09
  5. Liberar indereço sem pedir autenticação no squid
    Por AndrewAmorimdaSilva no fórum Servidores de Rede
    Respostas: 3
    Último Post: 02-11-2002, 16:06

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L