+ Responder ao Tópico



  1. #1

    Padrão Módulo GD trabalhando corretamete com o GD

    Pessoal!

    Estou encontrando o seguinte problema, atualmente estou trabalhando com a distro RH9 e preciso fazer rolar o módulo GD para trabalhar juntamente com o PHP.
    Baixei o GD 1.6.2.rpm, instalei mas estou precisando da versão acima de 2.0; baixei o versão 2.0 e quando vou instalar dá o erro abaixo (falha de dependências):
    error: Failed dependencies:
    libc.so.6 (GLIBC_2.3.4) is need by gd-2.0.33-1
    liggd.so.1.8 is needed by (installed) php-4.2.2-17
    libgd.so.1.8 is needed by (installed) webalizer-2.01_10-11

    Como eu faço para resolver o problema acima?
    Como eu faço para colocar a libc.so.1.8 no server para parar a dependência.

    Para eu atualiza a versão do meu php p/ 4.3 é somente eu baixar o rpm e dar um #rpm -Uvh <pacote> ??

    Agradeço todas as dicas.
    Abraços.

  2. #2

    Padrão Módulo GD trabalhando corretamete com o GD

    libc.so.6 (GLIBC_2.3.4) is need by gd-2.0.33-1

    issu eh tudo oq vc precisa



  3. #3

    Padrão Módulo GD trabalhando corretamete com o GD

    sim.....eu sei, mas como colocar esta biblioteca para o linux ler a mesma corretamente e não dar mais a sua falta?

    Grato.

  4. #4

    Padrão Módulo GD trabalhando corretamete com o GD

    Citação Postado originalmente por Wal
    sim.....eu sei, mas como colocar esta biblioteca para o linux ler a mesma corretamente e não dar mais a sua falta?

    Grato.
    instale a libc.so.6 (GLIBC_2.3.4)

    no caso, atualize-a, pq ela jah existe

    []'s



  5. #5

    Padrão Módulo GD trabalhando corretamete com o GD

    Vai no "supositorio" da RedHat e procura por updates de pacotes do RH9, ai tu baixa o glibc e roda um rpm -Uvh :P

  6. #6

    Padrão Módulo GD trabalhando corretamete com o GD

    Citação Postado originalmente por DropALL
    Vai no "supositorio" da RedHat e procura por updates de pacotes do RH9, ai tu baixa o glibc e roda um rpm -Uvh :P
    hauhauhaua

    busca no rpm.pbone.net e no rpmfind hehhee

    []'s



  7. #7

    Padrão Módulo GD trabalhando corretamete com o GD

    ok..vou fazer os testes e depois posto as novis aqui.

    Abraços.

  8. #8

    Padrão Módulo GD trabalhando corretamete com o GD

    Pessoal!

    Ao invés de eu atualizar o meu php e também o mysql, resolvi instalar o FC4, pois está tudo bem atualizado (tanto o php como o mysql tb).
    Verifiquei através de umas leituras que o módulo gd já vem imbutido juntamente com o php apartir da versão 4.3 (a versão do FC4 é a 5.0.3), porém por padrão ele vem compilado com o parâmetro '--without-gd' , e desta forma o gd ainda não está habilitado para funcionar juntamente com o php.
    Como eu faço para compilar o meu php com a opção "--with-gd[=DIR]" ??
    Não sei por onde começar...Help-me.

    Agradeço todas as dicas.
    Abraços.



  9. #9

    Padrão Módulo GD trabalhando corretamete com o GD

    Pessoal!

    Como muitos costumam fazer (resolver o problema e não postar a solução), e tenho certeza que jamais vou fazer isto, então vamos lá.

    Depois de algumas leituras sobre gd, php4 e apache resolvi o problema da seguinte maneira:
    1) Instalei o FC3, somente com os serviços de server Web;
    2) Subi os serviços de Apache (httpd), Mysql (mysqld);
    3) Instalei o módulo php-gd (peguei este rpm no site www.rpmfind.net);

    Pronto!
    O módulo que instalei faz o php4.3 conversar diretinho com o gd-2.0.

    Bom é isto aí, mais um resolvido.
    Agradeço todas as dicas!
    E agora vou estudar um pouquinho sobre como compilar as coisinhas no linux (FC e Debian) diretamente com o arquivo binário.

    Abraços.

  10. #10
    Visitante

    Padrão Re: Módulo GD trabalhando corretamete com o GD

    Citação Postado originalmente por Wal
    Pessoal!

    Estou encontrando o seguinte problema, atualmente estou trabalhando com a distro RH9 e preciso fazer rolar o módulo GD para trabalhar juntamente com o PHP.
    Baixei o GD 1.6.2.rpm, instalei mas estou precisando da versão acima de 2.0; baixei o versão 2.0 e quando vou instalar dá o erro abaixo (falha de dependências):
    error: Failed dependencies:
    libc.so.6 (GLIBC_2.3.4) is need by gd-2.0.33-1
    liggd.so.1.8 is needed by (installed) php-4.2.2-17
    libgd.so.1.8 is needed by (installed) webalizer-2.01_10-11

    Como eu faço para resolver o problema acima?
    Como eu faço para colocar a libc.so.1.8 no server para parar a dependência.

    Para eu atualiza a versão do meu php p/ 4.3 é somente eu baixar o rpm e dar um #rpm -Uvh <pacote> ??

    Agradeço todas as dicas.
    Abraços.