+ Responder ao Tópico



  1. #1
    acelmo
    Visitante

    Padrão Acentuação no SAMBA...

    Galera tou precisando de um help...

    Estou com um problema de acentuação no Samba... já procurei em vários fóruns e nada...

    Seguinte... acessando meu servidor Samba com uma máquina que tenha Windows eu consigo criar e visualizar as acentuações perfeitamente... tanto de arquivos como de pastas... e as vejo normalmente em qual m´qauina com Windows...

    Porem se eu acessar este mesmo servidor com uma máquina com linux... babou a parada toda... fica tudo "inilegivel" (eheheheh)... porem se eu criar, acentuar apartir do linux fica tudo perfeito em qualquer maquina com linux... acontece ao contrário... as com windows não visualizam os caracteres... fica tudo bagunçado...

    Algém pode me dar um help????

    Já tentei...

    client code page = 850
    character set = ISO8859-1
    e continuo na mesma... alguém passou por isso e consegui resolver o problema???

    o detalhe é que se eu utilizo o Konqueror SMB:/<nome-da_maquina> para acessar um compartilhamento em uma máquina windows... nada disso acontece... acentuo e visualizo normalmente em qualquer máquina... sem erros...

  2. #2



  3. #3
    acelmo
    Visitante

    Padrão Acentuação no SAMBA...

    não adiantou de nada!!!!

  4. #4
    ZEDjjs
    Visitante

    Padrão Acentuação no SAMBA...

    Acelmo qual a versão do seu Samba?



  5. #5

    Padrão Acentuação no SAMBA...

    Cara, eu tenho esse mesmo problema, vc coneguiu resolver ?? Eu uso o samba 3 .... qualquer acentuação windows ele converte os acentos pra código saca... eu consigo acessar os arquivos normalmente, mas fica ridiculo... e não descobri como alterar isso.... eu uso pra bkp essa makina linux com samba.... e ta me dando nos nervos.... Poxa se alguem consegue acessar de boa compartilhamentos windows com arquivos acentuados, por favor, de um help ai...

    flw!

  6. #6
    Visitante

    Padrão Acentuação no SAMBA...

    Eu tive este mesmo problema por um bom tempo, tem a ver com a versão do samba, na versão 3 deve-se usar o seguinte:

    unix charset = iso8859-1
    display charset = cp850


    Cuidado também para que, na hora de montar o diretório com o samba, se for usar o /etc/fstab, por exemplo, ou pela linha de comando, não passar nenhum parâmetro errado; foi o que aconteceu comigo, eu tinha adicionado aquelas linhas mas na hora de montar o diretório apresentava problemas, descobri que estava tinha digitado na linha de comando a palavra "users" ao invés de "user", por causa deste "s" errado tive um problemão. Abaixo como monto meu diretório por linha de comando:

    mount -t smbfs -o username=usuario,password=senha,fmask=777,codepage=cp850 //Maquina/Compartilhamento /mnt/diretorioOndeVaiSerMontado



  7. #7

    Padrão Acentuação no SAMBA...

    Puta valeu cara... a merca q eu estava fazendo é q eu estava colocando apenas codepage=850 ao inves de cp850 !

    Brigadão !!!!