+ Responder ao Tópico



  1. #1
    thelinux
    Visitante

    Padrão up eth1

    Pessoal estou com o Conectiva 10 com a instalação mínima em modo texto. Tenho duas placas de rede. A eth0 sob normalmente mas a eth1 não. Ai eu faço o seguinte para a eth1 subir:

    1. insmod /lib/...via-rhine*
    2. modprobe via-rhine
    3. ifconfig eth1 up
    4. ifconfig eth1 192.168.0.1 mask 255.255.255.0

    Mas tenho que fazer isso manualmente. O que queria, era que a placa subisse automa´tica ser precisar da minha intervenção. Sei que é possível colocar algum comando dentro de um arquivo de inicialização, mas não sei aonde. Se alguém puder me ajudar, desde já agradeço a todos.

  2. #2

    Padrão up eth1

    estranho porque isso deveria ser automático ... mais tenta colocar dentro de /etc/rc.d/rc.local ....ou então cria um arquivo e coloca ele dentro de /etc/rc.d/init.d ... testa e me fala no qual deu certo



  3. #3

    Padrão up eth1

    coloca o modulo dela no /etc/modules.conf

  4. #4

    Padrão up eth1

    Insira esses comandos no arquivo que inicializa o sistema que eh o: /etc/rc.d/rc.local :good:



  5. #5

    Padrão up eth1

    Citação Postado originalmente por theu2000
    Insira esses comandos no arquivo que inicializa o sistema que eh o: /etc/rc.d/rc.local :good:
    issu funciona, mas soh eh recomendado utilizar essa saida caso o sistema nao seja capaz de utilizar suas ferramentas proprias...
    no caso do amigo a rede nao sobe pq o modulo não to subindo, colocando o modulo como eu falei, a placa sera reconhecida no boot e as configuracoes dela serão ativas sem precisar ficar dando outros comandos

  6. #6
    thelinux
    Visitante

    Padrão eth1 up

    em rc.local eu coloco quais comandos?

    Obrigado.



  7. #7

    Padrão up eth1

    acabei de falar que nao precisa disso..........

  8. #8

    Padrão up eth1

    Citação Postado originalmente por 1c3_m4n
    coloca o modulo dela no /etc/modules.conf
    alias eth1 via-rhine



  9. #9
    thelinux
    Visitante

    Padrão consegui

    Obrigado a todos pela a ajuda.

    Fiz assim:

    1. no rc.local coloquei o comando: ifconfig eth1 up
    2. no modprobe.conf coloquei o alias.

    Funcionou. Mais uma vez obrigado a todos.

    Tenho uma dúvida:

    como faço para descobrir no conectiva quando tento instalar algum pacote e é pedido alguma arquivo específico? Gostaria de saber a qual pacote pertence este arquivo.

    Obrigado a todos

  10. #10

    Padrão up eth1

    rpm -qf arquivo (se nao me falha memoria, faz maisde 1 ano que numuso rpm)
    mostra qual eh o pacote que temaquele arquivo, mas isso soh funciona pra pacotes instalados no sistema
    se vc quer descobrir qual eh o arquivo que falta pra instalar recomento vc usar o apt

    apt-get update
    apt-get install pacote

    se tiver faltando alguma coisa ele jah vai instalar pra vc



  11. #11
    thelinux
    Visitante

    Padrão valeu

    Obrigado a todos e sucesso.

  12. #12

    Padrão up eth1

    Conectiva.. humm se eu me lembro bem... bom vamos lá:

    /etc/sysconfig/ifup-eth1

    ou algo nesse estilo ou sysconfig/network ou /etc/network* da uma procura por esses arquivos... é so criar esse arquivo com os parametros necessario que ele levanta a ethX no boot, sem essa parafernalhada de rc.local ... (vem bem a acalhar qdo nao se sabe onde estao as confs todas da distro... no debian nao tem um rc.local hehe as x eu sinto falta)



  13. #13
    fbfsp
    Visitante

    Padrão up eth1

    Você pode colocar os mesmos comandos que usa manualmente dentro do /etc/rc.d/rc.local ou tentar rodar o kudzu para reconhecer e configurar a sua segunda placa.
    Em último caso remova a placa rode o kudzu, confirme a remoção da configuração da sua placa e desligue o micro, re-instale a placa e rode novamente o kudzu ele reconhecer sua placa e poderá configura-la.

    Ps: Estou falando do kudzu pois uso Red-Hat e Fedora e ele é o responsável pelo reconhecimento de novos hardwares.