+ Responder ao Tópico



  1. #1
    estudante
    Visitante

    Padrão erro na compilacao do maildrop-1.6.3

    Senhores

    Estou com o Mandrake 9.1 instalado e tentando instalar o Postfix fielmente conforme o tutorial do Marco A. S. Máximo sem mudar sequer as versões dos programas.

    O problema que estou tendo é na metade do caminho, ou seja, na compilaćão do maildrop-1.6.3. Já tentei em outro micro com o mesmo linux instalado mas o erro é o mesmo.

    Logo abaixo apresento a parte final do resultado da compilacão seguida após o comando:

    [[email protected] maildrop-1.6.3]# ./configure \
    --prefix=/usr \
    --sysconfdir=/etc/maildrop \
    --enable-maildrop-uid=108 \
    --enable-maildrop-gid=108 \
    --enable-syslog=1 \
    --enable-maildropmysql \
    --enable-maildirquota

    Resultado:

    checking for maildrop config file... "/etc/maildropldap.config"
    checking for maildrop config file... "/etc/maildropmysql.config"
    checking for socket in -lsocket... no
    checking for socket in -lsocket... (cached) no
    checking for connect in -lsocket... no
    checking for connect in -lsocket... (cached) no
    checking for ldap_memfree... no
    ./configure: line 1: mysql_config: command not found
    configure: error: Unable to run mysql_config
    configure: error: /bin/sh './configure' failed for maildrop
    [[email protected] maildrop-1.6.3]#


    com isso tenho erro também no proximo comando (make) e no checkinstall -R, neste não consigo prosseguir.

    Alguém poderia me dar uma luz?

  2. #2
    estudante
    Visitante

    Padrão erro na compilacao do maildrop-1.6.3

    Senhores

    Desculpe-me cometi a tolice de não ler também os comentários do tutorial onde está comentado a solução para o referido problema porém sugiu outro que é com o link indicado para a solução que não existe mais portanto preciso que alguém me dê outra idéia.

    A propósito a solução dada para o referido é:

    o mysql_config eh um sh q fica no /usr/bin/
    nao sei pq, mas tem versoes do mysql nao vem com ele
    mas pode pegar ele em http://debian.maniacs.com.br/mysql_config

    Este link não existe mais e não sei como obter este arquivo.

    Será que posso instalar outro mysql que tenha este arquivo e copia-lo para o meu mysql ( /usr/bin)? se sim não haverá conflito de versão?



  3. #3

    Padrão erro na compilacao do maildrop-1.6.3

    verifica quais pacotes do mysql tem instalado, deve faltar instalar soh o mysql-devel