Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    oi galera.

    preciso de um squid.conf que funcione, ou uma maneira mais simples de configurar o squid.

    Obrigado desde já

  2. #2

    Padrão preciso de um squid.conf que funcione

    cara jah te passamos vários links de exemplos,artigos e documentações, não tem uma receitinha de bolo pronta, isso muda de máquina pra máquina...

    E PARE DE USAR LETRAS MAIUSCULAS NOS TITULOS,
    to ficando cansao de arrumar... :@:



  3. #3
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    acontece q ja fiz o q podia pra essa porcaria de squid funcionar e nada. :@:

    nao e receitinha de bolo, achei q com a configuracao minima ele tinha q funcionar, nao vi um parametro q variasse conforme a maquina, alem do q define tamanho de cache e memoria usada. o restante parece igualmente confuso.

    mas tudo bem, agradeço a sua ajuda. ja fiz muita coisa sozinho e nao vai ser agora q nao vou conseguir obrigado.

  4. #4

    Padrão preciso de um squid.conf que funcione

    eh mto mais facil vc conseguir ajuda mostrando os erros to que pedindo uma configuração pronta.....

    e muda de maquina pra maquina:
    ip
    interface
    dominio
    etc,etc,etc

    PROXY TRANSPARENTE: https://under-linux.org/noticia4379.html


    soh copie as configurações dai



  5. #5
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    ai é q tá!~tenho um squid.conf padraozao mesmo. botei pra rodar e nao funciona a internet nas maquinas. esse eh o ponto.

    tento reconfigurar e nada. antes do proy transparente, ele nao deveria funcionar como proxy normal?

  6. #6

    Padrão preciso de um squid.conf que funcione

    se vc nao fizer as regras de redirecinamento no iptables e colocar akelas conf o transparente nao vai funfar nao, mas se vc configurou, e setou no clientes o proxy era pra funcionar...

    90% dos casos acontece o pau dele nao reconhecer o dominio ai vc precisa colocar

    visible_hostname dominio.com.br

    PS: pra iniciar o squid pela primeira vez tem q rodar squid -z pra ele criar o cache

    e olhe no arquivo de log dele pra ver se tem algum erro



  7. #7
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    Interessante. usei o squid -z e ele criou o cache. ae fui olhar nos logs e nao aparenta ter erros.
    Ready to serve requests.
    .
    .
    .
    A ultima frase foi
    Completede Validation Procedure.

    nao ha mensagens de erro.

  8. #8

    Padrão preciso de um squid.conf que funcione

    intaum aparenta estar rodando...
    da um telnet na porta 3128 e ve se responde, se responder jah pode botar o proxy nos clientes



  9. #9
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    esqueci de mencionar: fiz o lance do telnet e naum funfou.
    tentei um ftp tbm e nada. isso q me deixou p. da vida da outra vez e acabei desistindo do squid, ateh porque tinha outras coisas pra fazer.

    parece estranho.

    em visible_hostname dominio.com.br

    dominio.com.br seria o q? pode ser por exemplo um dominio tipo terra?

  10. #10

    Padrão preciso de um squid.conf que funcione

    qq coisa, isso eh soh pra ele identificar o nome da maquina sem ter q recorrer a dns

    nao tem nada nos logs mesmo?



  11. #11
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    o access.log ta 100% vazio

    o squid instalei viu um rpm

    o store.log tem varias coisas sobre gif e jpgs

    nao sei mais o q pode ser. o telnet localhost 3128 da time out

  12. #12

    Padrão preciso de um squid.conf que funcione

    access_log vazio...
    hmmm ou ta com problema de permissao ou tem algum erro na conf

    para ele se tiver rodando e inicia em modo debug pra ver oq acontece qdo tentam acessar ele:

    squid -d 6



  13. #13

    Padrão preciso de um squid.conf que funcione

    Cara da o ip da maquina e a senha do ssh que eu dou uma olhada !!!hehehehehehe

  14. #14
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    o modo debug nao se altera. fica igual. alterei as permissoes e nada feito.



  15. #15

    Padrão preciso de um squid.conf que funcione

    po entaum ele ta rodando.... vai ver q ele soh ta respondendo em uma interface...

    posta sua conf ai, mas soh as variaveis que nao tem "#", se nao fica mto grande :P

  16. #16
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    ta ae o meu squid.conf inteiro. hehe
    vo taca fogo nesse bicho!

    valew pelo apoio!

    http_port 3128
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access allow all
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access deny all
    icp_access allow all

    visible_hostname dominio.com.br



  17. #17

    Padrão preciso de um squid.conf que funcione

    pronto ta ai problema :P
    vc nao criou a acl que compartilha pra tua rede

    cria ai

    acl minharede src 192.168.0.0/255.255.255.0

    e depois coloca os http_access assim:
    http_access allow manager localhost
    http_access allow all
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access allow minharede
    http_access deny all

    Isso tava nos artigos hein :P

  18. #18

    Padrão preciso de um squid.conf que funcione

    aff, sem comentarios....



  19. #19
    mestre_dos_magos
    Visitante

    Padrão preciso de um squid.conf que funcione

    Colocando no forum os paramentos do squid.conf fica mais facil pra ver o erro...so mais um coisa... vc ja rodou o squid -NCd1 pra ver o que ele responde ? te mais

  20. #20
    mestre_dos_magos
    Visitante

    Padrão preciso de um squid.conf que funcione

    pessoal posta rapido aqui..postei atrasado