+ Responder ao Tópico



  1. #1
    vfsmount
    Visitante

    Padrão Gente, eu realmente preciso de ajuda.

    Ola amigos, tenho um serio problema que nao consigo resolver sem ajuda.

    Entao vamos por partes:

    Tenho uma rede, um modem adsl, um servidor slackware, e alguns terminais windows98se.

    Modem Parks 670R -- Ip atribuido pelo provedor=200.xxx.xxx.xxx
    - Ip para a rede=192.168.1.1

    Servidor slackware -- eth0=192.168.1.60 com gateway apontando para 192.168.1.1=funcionando.
    -- eth1=10.1.1.1/8 compartilhanto conexao para a rede atraves de iptables=funcionando.

    Terminais Windows -- 10.1.1.x/8 com gateway apontando para 10.1.1.1=funcionando. (Nao existe nenhum programa firewall, nada alem de windows98se atualizado)

    Os terminais navegam trankuilo, messenger, www, ftp e tudo mais.

    minhas regras de iptables:

    iptables -t nat -P POSTROUTING DROP
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Uma coisa me chamou e muito a atencao. Quando eu estou em um terminal windows 98se(10.1.1.3) , eu mando um ping 10.1.1.1 e ele responde direitinho, porem se eu for no teclado do servidor, e dar um ping no terminal 10.1.1.3 ele nao funciona, responde:
    ping: sent 64 octets to 10.1.1.3, ret=-1
    sendto: Operation not permitted
    No entanto a internet funciona direito, os pacotes passam pelo servidor em direcao ao hub que distribui para a rede.

    eu troquei o enderecamento da eth1 -- para 192.168.40.1/24 e mudei em todos os terminais tambem, com gateway apontando para 192.168.40.1 e tudo ficou perfeito, a navegação e tudo mais. Porem o problema no servidor persiste, eu nao consigo pingar nenhuma das maquinas atravez do teclado do servidor.

    Gente, hehe, o que pode estar acontecendo?
    será que é o iptables? minhas regras sao soh akelas duas. se alguem puder me ajudar.


    :toim:


    Obrigado
    Rodolpho

  2. #2

    Padrão Gente, eu realmente preciso de ajuda.

    pra q isso????: >>>>>>>>
    iptables -t nat -P POSTROUTING DROP



  3. #3
    vfsmount
    Visitante

    Padrão hmmmm

    vou tirar, eu nao entendo muito bem de iptables, na verdade eu nem entendo muito bem de linux, mas eu gosto de usa-lo.
    ja ja eu dou uma resposta pra saber se eh isso mesmo.....

  4. #4
    vfsmount
    Visitante

    Padrão muito bom.....

    Agradeco a ajuda e ja posso dizer que esta tudo funcionando agora, o meu samba os pings, realmente eu nao imaginava que poderia ser isso
    .
    obrigado
    Rodolpho



  5. #5

    Padrão Gente, eu realmente preciso de ajuda.


  6. #6

    Padrão Re: Gente, eu realmente preciso de ajuda.

    # Carrega os modulos
    modprobe iptables
    modprobe iptable_nat

    # Compartilha a conexão
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward

    # Abre para a rede local
    iptables -A INPUT -p tcp --syn -s 192.168.0.0/255.255.255.0 -j ACCEPT

    # Fecha o resto
    iptables -A INPUT -p tcp --syn -j DROP

    Roda essas regras ai pra ver se funciona, ao inves das duas que vc ta rodando!!!

    Qualquer coisa posta ai !!!



  7. #7
    vfsmount
    Visitante

    Padrão o galerinha, fui ajudado

    opa, realmente voces me ajudaram, deu certo remover akela regra que tava dropando os pacotes, agora tudo esta funcionando direito.
    Soh tenho mais uma duvida:
    eu coloquei um topico como fixo no SAMBA/SMB falando a respeito disso, que tudo funcionava direito mas o samba nao, tem como eu tirar ele de la, vai ficar atrapalhando.

    Obrigado
    Rodolpho

  8. #8

    Padrão Re: o galerinha, fui ajudado

    Cara explica melhor o q quer pra gente poder te ajudar!!!



  9. #9

    Padrão Re: o galerinha, fui ajudado

    Citação Postado originalmente por gatoseco
    Cara explica melhor o q quer pra gente poder te ajudar!!!
    :toim: :toim: :toim: :toim:

    jah resolveu o problem faz tempo.......

    era a pregra de postrouting com drop

  10. #10

    Padrão Re: o galerinha, fui ajudado

    Soh tenho mais uma duvida:
    eu coloquei um topico como fixo no SAMBA/SMB falando a respeito disso, que tudo funcionava direito mas o samba nao, tem como eu tirar ele de la, vai ficar atrapalhando



  11. #11

    Padrão Gente, eu realmente preciso de ajuda.

    eu tiro, vc nao vai ter acesso