+ Responder ao Tópico



  1. #1
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    bom dia.

    Estou tentando criar um usuário em uma maquina minha, mas estou tendo um problema inédito.
    Eu crio o usuário numa boa, mas quando vou logar com esse usuário ele nao tem permissão pra entrar na propria pasta dele e nem executar o bash.

    Q q eu faço??!??!?! rs! uso slack 10.1

    criei o user normalmente, pelos dois meios:

    # adduser nome_user

    e

    # useradd nome_user
    # passwd nome_user


    valeu!!!!!!!!!
    =)

  2. #2

    Padrão Criação de Usuários. PROBLEMA

    Fala replicante,

    Então, passei por isso uma vez, usando o Debian.
    Fui criar um usuário com USERADD normal, e ele não deixou eu logar e nem entrar em nada.
    depois fui e criei com ADDUSER, que é diferente, pois é um script que cria diretorio, bash., tudo...ao contrario do USERADD que tem que fazer tudo na mão.
    o que eu fiz, foi deletar tudo sobre o usuário que estava dando erro, e recriar a conta somente com o ADDUSER.
    Ai funfou normalmente.

    blz.

    Abraços

    Jeff



  3. #3
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    nao funcionou cara...
    =(

    nao sei mais o q fazer..

    valeu

  4. #4

    Padrão Criação de Usuários. PROBLEMA

    no slack por padrao a pasta home do usuario nao eh criada, vc tem q especificar isso na hora de criação da conta, e aproveita e especifica a shell

    useradd user -g grupo -d /home/user -s /bin/bash

    se vc criou o home do usuario na mao chown usuario.grupo /home/user

    e olha no passwd se a shell dele nao ta como /bin/false, se tiver eh por isso q ele nao loga



  5. #5
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    Código :
    # useradd tiago -g users -d /home/tiago -s /bin/bash
     
    # passwd tiago
     
    # mkdir /home/tiago/
     
    # cd /home
     
    # chown tiago:users tiago/
     
    # su - tiago
    Unable to cd to "/home/tiago"

    q q eu faço? suicidio?
    =)

    valeu

  6. #6
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    vc ja viu com esta o seu sitema de permissão do home,
    outra coisa de uma olhada no seu umask e ve se ta 0022, ok[/b]



  7. #7
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    umask = 0022

    diretorio /home

    drwxr-x-r-x root root

    =(

    mais alguma ideia??????
    =)

    valeu

  8. #8
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    ninguem tem mais nenhuma ideia de como solucionar isso?
    sera q vou ter q re-instalar o linux?

    valeu



  9. #9

    Padrão Criação de Usuários. PROBLEMA

    Faz como c falou em cima, suicidio :P

    dah um
    # ls -la no /home

    depois q vc seguir os passos de cima, e cola aq a saida....

  10. #10
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    Código :
    total 16
    drwxr-xr-x   4 root  root  4096 2005-04-18 09:25 ./
    drwxr-x---  18 root  root  4096 2005-04-01 18:52 ../
    drwxr-xr-x   2 root  root  4096 2004-09-03 16:16 ftp/
    drwxr-xr-x   2 tiago users 4096 2005-04-18 09:25 tiago/

    suicidio? ou tem chance?

    hehe

    valeu!



  11. #11

    Padrão conf

    Cara.. posta ae a sua linha do passwd,

    Código :
    cat /etc/passwd | grep tiago

    e posta ae,


    flws

    :toim: :toim: :toim: :toim: :toim: :toim: :toim: :toim: :toim: :toim: :toim:

  12. #12
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    o problema nao ta na criação de usuário, pq eu fui tentar usar um user padrão (nobody) pra iniciar o squid e nao rolou.
    acho q ele nao esta deixando rolar nenhum usuário, só root...
    =(

    alguem ?

    :toim: :toim: :cry: :cry:

    valeu!



  13. #13

    Padrão Criação de Usuários. PROBLEMA

    Me tira uma duvida...se vc der:

    # cd /home/tiago

    ele entra? ou seja, so dah erro quando se usa o "su" ?

  14. #14
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    ele da erro qdo uso o "su", quando tento logar normalmente e tb qdo tento executar alguma funcao q vai usar o usuário (qquer usuário comum).

    to ficando loko... rsrs

    valeu



  15. #15
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    pasmem,

    reiniciei o server e voltou a funcionar...
    estou me sentindo mal por isso.. reiniciar é coisa de M$....

    :cry: :cry:

    valeu!

  16. #16

    Padrão Criação de Usuários. PROBLEMA

    Citação Postado originalmente por replicante
    pasmem,

    reiniciei o server e voltou a funcionar...
    estou me sentindo mal por isso.. reiniciar é coisa de M$....

    :cry: :cry:

    valeu!

    ahheheeeh acho q entaum soh um logoff resolveria, pq reiniciar realmente eh coisa de m$ ou intaum pra instalar hardware :P



  17. #17
    replicante
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    com logoff nao rolou...
    teve q reiniciar mesmo...

    mas vamos colocar uma pedra em cima disso! hehehhe

    =)

    falow!

  18. #18
    alesandro
    Visitante

    Padrão Criação de Usuários. PROBLEMA

    as vezes acontece comigo, crio o usuario e dou o comando:
    #id user
    depois
    #chown -R uid.grupo pasta



  19. #19

    Padrão Criação de Usuários. PROBLEMA

    Citação Postado originalmente por replicante
    reiniciar é coisa de M$....
    com certeza
    qq porcaria q vc faz tem q reiniciar o pc

  20. #20

    Padrão Criação de Usuários. PROBLEMA

    Aew,

    Hahaha... hahahahaa... afe...

    Reiniciar e resolveu!

    pootz,

    flws,