Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    capgaiotto
    Olá pessoal!

    Instalei o Squid no Conectiva 10 (utilizei o squid disponível no próprio CD da distro), a rede já estava configurada.

    #apt-get install squid*

    Configurei meu "squid.conf" e para não ter problemas com permissão, apliquei chmod 777 nas pastas de cache e log.

    Quando vou levantar o serviço do squid ele mostra carregando e depois de alguns segundo aparece a mensagem:

    [FALHOU]
    abortando após 10 segundos

    O que será que acontece ??

    aqui está meu squid.conf:

    visible_hostname proxyserver
    http_port 3128
    hierarchy_stoplist cgi-bin ?
    cache_mem 64 MB
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 10000 KB
    minimum_object_size 0 KB
    maximum_object_size_in_memory 8 KB
    cache_dir ufs /var/cache/squid 100 16 256
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log
    pid_filename /var/run/squid.pid
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    http_access allow all manager localhost
    http_reply_access allow all
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_single_host off
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    coredump_dir /var/cache/squid

    Obrigado pela ajuda pessoal!

    Gaiotto

  2. #2
    capgaiotto
    Quando executo o IPTABLES, não aparece erro nenhum, minha tabela de regras para NAT está assim:

    ## NAT table ##
    echo 'NAT table...'

    $IPT -t nat -A POSTROUTING -o $INET_IFACE -j SNAT --to-source
    $INET_ADDRESS

    $IPT -t nat -A PREROUTING -d $INET_ADDRESS -p tcp --dport 3389 -j DNAT --to $SERV_2K

    $IPT -t nat -A PREROUTING -s $LOCAL_NET -p tcp --dport 80 -j REDIRECT --to-port 3128

    Valeu!



  3. inicia ele com
    squid -d 6
    e veja oq ele vai mostrar

  4. #4
    capgaiotto
    Aparece o seguinte:

    2005/04/20 16:37:57| Starting Squid Cache version 2.5.STABLE5 for i686-pc-linux-gnu...
    2005/04/20 16:37:57| Process ID 2027
    2005/04/20 16:37:57| With 1024 file descriptors available
    2005/04/20 16:37:57| Performing DNS Tests...
    FATAL: ipcache_init: DNS name lookup tests failed.

    Meu resolv.conf está assim:

    nameserver 200.204.0.10
    nameserver 200.204.0.138

    DNS da Telefonica



  5. #5
    capgaiotto
    Dando uma olhada no arquivo /var/log/squid/cache.log aparece várias vezes esse DNS error, parece que DNS é o problema...

    Como devo editar o resolv.conf ? Existe outro lugar para definir servidores DNS ?

    Obrigado!






Tópicos Similares

  1. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-10-2004, 17:14
  2. Compilação Squid - Não inicia !!!
    Por Beto no fórum Servidores de Rede
    Respostas: 6
    Último Post: 01-06-2004, 20:35
  3. Squid não inicia
    Por guardian_metal no fórum Servidores de Rede
    Respostas: 17
    Último Post: 29-09-2003, 16:11
  4. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 11-06-2003, 14:02
  5. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-06-2003, 12:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L