Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão .:Cliente VPN não conecta:.

    No servidor ocorre a seguinte mensagem no console:

    /usr/sbin/pppd: The remote system is required to authenticate itself
    /usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
    /usr/sbin/pppd: (None of the available passwords would let it use an IP address.)

    Na estação Windows XP SP2 ocorre a seguinte mensagem:

    Erro: 651 o modem(ou outro dispositivo de conexão) reportou um erro.

    O que será que pode está acontecendo? Fico muito grato ao colega que puder ajudar.

  2. #2

    Padrão .:Cliente VPN não conecta:.

    cara,

    Qual a conf do seu pptpd e do pppd???

    [] dotta



  3. #3

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    cara,

    Qual a conf do seu pptpd e do pppd???

    [] dotta
    O pptpd:

    speed 115200
    option /etc/ppp/options.pptpd
    debug
    localip 192.168.0.234-238,192.168.0.245
    remoteip 192.168.1.234-238,192.168.1.245

    Qual a extensão do pppd que você gostaria de ver? Poís não editei esse arquivo.

    Valeu...

  4. #4

    Padrão .:Cliente VPN não conecta:.

    ???



  5. #5

    Padrão .:Cliente VPN não conecta:.

    car usa assim

    pptpd.conf
    Código :
    ppp /usr/sbin/pppd
    logwtmp
    option /etc/ppp/pptpd-options
    bcrelay eth3
    localip 192.168.0.234
    remoteip 192.168.1.234-238,192.168.1.245

    /etc/ppp/pptpd-options
    Código :
    proxyarp
    auth
    require-mschap-v2
    refuse-pap
    refuse-chap
    refuse-mschap
    nodefaultroute

    vc nao precisa colocar varios ip no localip... pode ser 1 so... ai todos as conecxoe vao usar este ip...

    [] Dotta :twisted:

  6. #6

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    car usa assim

    pptpd.conf
    Código :
    ppp /usr/sbin/pppd
    logwtmp
    option /etc/ppp/pptpd-options
    bcrelay eth3
    localip 192.168.0.234
    remoteip 192.168.1.234-238,192.168.1.245

    /etc/ppp/pptpd-options
    Código :
    proxyarp
    auth
    require-mschap-v2
    refuse-pap
    refuse-chap
    refuse-mschap
    nodefaultroute

    vc nao precisa colocar varios ip no localip... pode ser 1 so... ai todos as conecxoe vao usar este ip...

    [] Dotta :twisted:

    Beleza! Mas me tira um dúvida.
    Esse endereço de IP, que tenho que definir no LOCALIP, é o IP do meu servidor na minha rede ou é o meu IP com a internet?
    Por que você me aconcelha a mudar as definições dos arquivos PPTPD.CONF e PPTPD.OPTIONS? elas estão erradas ou estão incompletas?

    Obrigado por sua valiosa atenção.



  7. #7

    Padrão .:Cliente VPN não conecta:.

    aprendiz_ce,


    O LOCALIP eh um ip da sua rede interna... nao da internet... quanto a mundacao pso parametros do seu pptp e ppp eu acosenho pq estao incompletas e da forma q te passei funciona melhor. Lembrado q a cofn q te passei a unica coisa q eh criptografada e os passwards e nao se esqueca de adiooar os user no /etc/ppp/chap-sercrets na seguinte forma
    user * senha *

    use tabs...

    ahh no windows... vc deve usar opcoes de seguranca -> avancado -> criptografia opcional e habilitar protocolo mschap v2

    [] Dotta :twisted:

  8. #8

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    aprendiz_ce,


    O LOCALIP eh um ip da sua rede interna... nao da internet... quanto a mundacao pso parametros do seu pptp e ppp eu acosenho pq estao incompletas e da forma q te passei funciona melhor. Lembrado q a cofn q te passei a unica coisa q eh criptografada e os passwards e nao se esqueca de adiooar os user no /etc/ppp/chap-sercrets na seguinte forma
    user * senha *

    use tabs...

    ahh no windows... vc deve usar opcoes de seguranca -> avancado -> criptografia opcional e habilitar protocolo mschap v2

    [] Dotta :twisted:
    fdotta,

    OK! Vou seguir a risca, o que você me passou. Mas, me surgiu outra dúvida: Qual o IP que vou utilizar para criar a conexão do cliente (Win XP)? O IP da internet (tipo 200.xxx.xxx.xxx)?



  9. #9

    Padrão .:Cliente VPN não conecta:.

    aprendiz_ce,


    Exatamente vc deve usar ip real!!!, a conf q te passei funciona legal... e a q eu uso... so uma coisa q esqueci de te falar... o parametro bcrelay eth3

    vc coloca a ethx da usa rede interna ok!!!

    [] Dotta

  10. #10

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    aprendiz_ce,


    Exatamente vc deve usar ip real!!!, a conf q te passei funciona legal... e a q eu uso... so uma coisa q esqueci de te falar... o parametro bcrelay eth3

    vc coloca a ethx da usa rede interna ok!!!

    [] Dotta

    Olá fdotta,

    Fiz todos os ajuste que você me recomendou. Mas o cliente ainda não conectou.
    Dei uma olha nos logs e tá dando as seguintes mensagens:

    Apr 25 20:39:12 server pptpd[1523]: MGR: No free connection slots or IPs - no more clients can connect!
    Apr 25 20:39:12 server pptpd[1612]: CTRL: Client 201.9.3.248 control connection started
    Apr 25 20:39:12 server pptpd[1612]: CTRL: Starting call (launching pppd, opening GRE)
    Apr 25 20:39:12 server pptpd[1612]: GRE: read(fd=5,buffer=804d9c0,len=8196) from PTY failed: status = -1 error = Input/output error
    Apr 25 20:39:12 server pptpd[1612]: CTRL: PTY read or GRE write failed (pty,gre) =(5,6)
    Apr 25 20:39:12 server pptpd[1612]: CTRL: Client 201.9.3.248 control connection finished

    O Que será que pode esta errado agora?

    Este log e de uma estação Win98 Se com Update para coneções VPN (DUN 1.4).

    Me diz uma coisa: As configurações do servidor mudam conforme o cliente VPN ou não?

    Grato.



  11. #11

    Padrão .:Cliente VPN não conecta:.

    Cara,


    Primeiro as conf nao mudam... mas nunca testei com 98, outra coisa posta o log do linux onde esta o pptpd...

    Mais um detalhe no client vc tem q setar criptografia opcional e protocolo mschap v2, vpn tipo ptp ou pptp e vc /etc/ppp/chap-secrets vc tem q adcionar a uma linha com o user e a senha na seguinte forma:

    Código :
    user   *    senha   *

    e use tab nao espacoes. Como te falei estas sao exetamente as conf q eu uso no meu servidor e funciona blz.

    [] Dotta :twisted:

  12. #12

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    Cara,


    Primeiro as conf nao mudam... mas nunca testei com 98, outra coisa posta o log do linux onde esta o pptpd...

    Mais um detalhe no client vc tem q setar criptografia opcional e protocolo mschap v2, vpn tipo ptp ou pptp e vc /etc/ppp/chap-secrets vc tem q adcionar a uma linha com o user e a senha na seguinte forma:

    Código :
    user   *    senha   *

    e use tab nao espacoes. Como te falei estas sao exetamente as conf q eu uso no meu servidor e funciona blz.

    [] Dotta :twisted:
    OK! Vou postar o LOG do PPTPD.
    O Usuário foi cadastrado utilizando a tecla TAB conforme você menciona logo acima. Eu teste como o usuário ROOT. Será que tem algum problema? O usuário criado em /etc/ppp/chap-secrets tem que está criado no sistema. Correto? Ou não necessariamente?

    Me desculpe, mas o log que você gostaria de ver, não esse que já postei? Ou então qual seria?

    Grato.



  13. #13

    Padrão .:Cliente VPN não conecta:.

    aprendiz_ce,

    O user q do pptp nao precisa existir no SO, eh ate melhor q nao exista, por razoes de seguranca. Vc so precisa do user no /etc/ppp/chap-secrets

    Quanto ao log posta o log do servidor linux. Os logs do pptpd devem estar no /var/log/messages ou /var/log/syslog, isso depende da distro.

    [] Dotta

  14. #14
    Visitante

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    aprendiz_ce,

    O user q do pptp nao precisa existir no SO, eh ate melhor q nao exista, por razoes de seguranca. Vc so precisa do user no /etc/ppp/chap-secrets

    Quanto ao log posta o log do servidor linux. Os logs do pptpd devem estar no /var/log/messages ou /var/log/syslog, isso depende da distro.

    [] Dotta
    fdotta,

    Achou que o log que você pediu deve ser esse:

    Apr 27 11:22:46 server pptpd[1630]: CTRL: Client 201.9.3.198 control connection started
    Apr 27 11:22:46 server pptpd[1630]: CTRL: Starting call (launching pppd, opening GRE)
    Apr 27 11:22:46 server pptpd[1630]: GRE: read fd=5,buffer=804d9c0,len=8196) from PTY failed: status = -1 error = Input/output error
    Apr 27 11:22:46 server pptpd[1630]: CTRL: PTY read or GRE write failed (pty,gre) =(5,6)
    Apr 27 11:22:46 server pptpd[1630]: CTRL: Client 201.9.3.198 control connection finished

    Já fiz de tudo mas não estou conseguindo conectar ainda.

    Grato.



  15. #15

    Padrão .:Cliente VPN não conecta:.

    aprendiz_ce,

    Ta dando errona autenticacao. 1 Como esta a configuracoa do client win???

    Faca um teste, tente conectar de uma win2000 ou xp. Estou desconfiado no 98. Eu nunca usei vpn no 98 pode ser isso.

    [] Dotta :twisted:

  16. #16
    Visitante

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    aprendiz_ce,

    Ta dando errona autenticacao. 1 Como esta a configuracoa do client win???

    Faca um teste, tente conectar de uma win2000 ou xp. Estou desconfiado no 98. Eu nunca usei vpn no 98 pode ser isso.

    [] Dotta :twisted:
    Olá fdotta,

    Já tentei com ambos... tanto com Win98se e WinXP Sp2 mas nenhum dos dois conectaram.
    Qual distribuição que você usa? Eu estou utilizando o Conectiva Linux 9. Eu estou achando que deve está faltando carregar algum modulo ou algo parecido. O que você acha?

    Obrigado mais um vezes pela sua valiosa ajuda e atenção para comigo.



  17. #17

    Padrão .:Cliente VPN não conecta:.

    aprendiz_ce,

    Eu uso o debian e RH Enterprise 3.0, em ambos esta configs funionam, faz mais uma coisa, tanto no pptpd.conf, pptpd-options adicione a linha debug e tente conectar e posta os erros reportados pelo log!!!

    Mas o q vc falou eh verdade, pode esta faltando algum modulo no seu kernel... vc esta com os sources do seu kernel ai??? Talvez vc tenha q recompila-lo!!!

    Qual Kernel vc esta usando???

    [] Dotta :twisted:

  18. #18
    Visitante

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    aprendiz_ce,

    Eu uso o debian e RH Enterprise 3.0, em ambos esta configs funionam, faz mais uma coisa, tanto no pptpd.conf, pptpd-options adicione a linha debug e tente conectar e posta os erros reportados pelo log!!!

    Mas o q vc falou eh verdade, pode esta faltando algum modulo no seu kernel... vc esta com os sources do seu kernel ai??? Talvez vc tenha q recompila-lo!!!

    Qual Kernel vc esta usando???

    [] Dotta :twisted:
    Estou utilizando o Kernel 2.4.21-28872cl. No seu caso você precisou recompilar o Kernel para alguma das suas distribuições? Já pesquisei muito com amigo e pela net, mas ainda estou perdido. Acho que esta faltando um modulo no Kernel chamado MPPE. O que você me diz?

    Um forte abraço.



  19. #19

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por Anonymous
    Citação Postado originalmente por fdotta
    aprendiz_ce,

    Eu uso o debian e RH Enterprise 3.0, em ambos esta configs funionam, faz mais uma coisa, tanto no pptpd.conf, pptpd-options adicione a linha debug e tente conectar e posta os erros reportados pelo log!!!

    Mas o q vc falou eh verdade, pode esta faltando algum modulo no seu kernel... vc esta com os sources do seu kernel ai??? Talvez vc tenha q recompila-lo!!!

    Qual Kernel vc esta usando???

    [] Dotta :twisted:
    Estou utilizando o Kernel 2.4.21-28872cl. No seu caso você precisou recompilar o Kernel para alguma das suas distribuições? Já pesquisei muito com amigo e pela net, mas ainda estou perdido. Acho que esta faltando um modulo no Kernel chamado MPPE. O que você me diz?

    Um forte abraço.
    Nao estou fanado do Modulo MPPE (criptografia), mas do outros Modulo de PPP (GRE, BSD, etc), tb tem que estar hibilitados no kernel, geralmente estao!!!

    [] Dotta :twisted:

  20. #20

    Padrão .:Cliente VPN não conecta:.

    Citação Postado originalmente por fdotta
    Citação Postado originalmente por Anonymous
    Citação Postado originalmente por fdotta
    aprendiz_ce,

    Eu uso o debian e RH Enterprise 3.0, em ambos esta configs funionam, faz mais uma coisa, tanto no pptpd.conf, pptpd-options adicione a linha debug e tente conectar e posta os erros reportados pelo log!!!

    Mas o q vc falou eh verdade, pode esta faltando algum modulo no seu kernel... vc esta com os sources do seu kernel ai??? Talvez vc tenha q recompila-lo!!!

    Qual Kernel vc esta usando???

    [] Dotta :twisted:
    Estou utilizando o Kernel 2.4.21-28872cl. No seu caso você precisou recompilar o Kernel para alguma das suas distribuições? Já pesquisei muito com amigo e pela net, mas ainda estou perdido. Acho que esta faltando um modulo no Kernel chamado MPPE. O que você me diz?

    Um forte abraço.
    Nao estou fanado do Modulo MPPE (criptografia), mas do outros Modulo de PPP (GRE, BSD, etc), tb tem que estar hibilitados no kernel, geralmente estao!!!

    [] Dotta :twisted:
    Olá fdotta,

    Segue logo abaixo os modulos que estou carregando:

    Module Size Used by Not tainted
    ppp_deflate 3960 0 (autoclean)
    zlib_deflate 19704 0 (autoclean) [ppp_deflate]
    bsd_comp 4856 0 (autoclean)
    ppp_synctty 6848 0 (unused)
    ppp_async 8416 1
    ppp_generic 22204 3 [ppp_deflate bsd_comp ppp_synctty ppp_async]
    slhc 6116 0 [ppp_generic]
    iptable_filter 2284 1 (autoclean)
    ipt_MASQUERADE 1976 1 (autoclean)
    iptable_nat 19160 1 [ipt_MASQUERADE]
    ip_conntrack 24704 1 [ipt_MASQUERADE iptable_nat]
    ip_tables 13176 5 [iptable_filter ipt_MASQUERADE iptable_nat]
    ip_gre 9376 0
    parport_pc 27912 1 (autoclean)
    lp 7876 0 (autoclean)
    parport 32512 1 (autoclean) [parport_pc lp]
    8139too 16424 2 (autoclean)
    mii 3464 0 (autoclean) [8139too]
    sb 9108 0
    sb_lib 39054 0 [sb]
    uart401 7908 0 [sb_lib]
    sound 65684 0 [sb_lib uart401]
    soundcore 5892 4 [sb_lib sound]
    keybdev 2624 0 (unused)
    mousedev 5012 0 (unused)
    usbmouse 2776 0 (unused)
    hid 19300 0 (unused)
    loop 10300 0 (autoclean)
    usbkbd 4248 0 (unused)
    input 5280 0 [keybdev mousedev usbmouse hid usbkbd]
    w9968cf 19488 0 (unused)
    videodev 7456 0 [w9968cf]
    lvm-mod 57568 0
    usb-ohci 18824 0 (unused)
    usbcore 67776 1 [usbmouse hid usbkbd w9968cf usb-ohci]
    rtc 7516 0 (autoclean)
    ext3 60608 1
    jbd 45428 1 [ext3]
    ide-disk 11204 2
    ide-probe-mod 9896 0
    ide-mod 176736 2 [ide-disk ide-probe-mod]

    Se possível me faça mais este favor. Compare com os seus modulos que estão carregados e olha se no meu falta algum.

    Assim que possível, te chamo no MSN. Pode ser?

    Grato.