+ Responder ao Tópico



  1. Estou com um problema em meu servidor qmail de produção
    Quando eu rodo o script /etc/init.d/qmail start
    aparentemente o qmail é iniciado, o qmail-send aparece na lista de processos mas os emails não são enviados da queue e nada é logado no arquivo /var/log/qmail/send/current

    Mas, se eu encerro o qmail e rodo manualmente o arquivo /var/qmail/rc e depois rodo o script /etc/init.d/qmail start o qmail-send passa a funcionar corretamente só que continua se logar no arquivo de log em /var/log/qmail

    O que pode estar ocorrendo? ?

    ###################################################################################

    Conteudo do diretório /service :

    drwxr-xr-x 2 root root 4096 Fev 28 2003 ./
    drwxr-xr-x 29 root root 4096 Abr 30 10:13 ../
    lrwxrwxrwx 1 root root 25 Fev 28 2003 pop3 -
    > /var/qmail/supervise/pop3/
    lrwxrwxrwx 1 root root 25 Fev 28 2003 send -
    > /var/qmail/supervise/send/
    lrwxrwxrwx 1 root root 25 Fev 28 2003 smtp -
    > /var/qmail/supervise/smtp/
    ####################################################################################

    Meus arquivos de inicalização:

    vi /etc/init.d/qmail
    #!/bin/sh
    PATH=/usr/local/bin:/usr/sbin:/usr/bin:/bin
    export PATH

    case "$1" in
    start)
    if [ ! -f /var/run/svscan.pid ]
    then
    echo -n "Starting services: svscan"
    cd /service
    env - PATH="$PATH" svscan &
    echo $! > /var/run/svscan.pid
    for dir in `ls /service`
    do
    echo -n " $dir"
    done
    echo "."
    else
    echo "It appears svscan is already running. NOT
    starting!"
    fi
    ;;
    stop)
    echo -n "Stopping services: svscan"
    if [ -f /var/run/svscan.pid ]
    then
    kill `cat /var/run/svscan.pid`
    rm /var/run/svscan.pid
    for dir in `ls /service`
    do
    echo -n " $dir"
    svc -dx /service/$dir
    svc -dx /service/$dir/log
    killall -9 rblsmtpd tcpserver \
    qmail-popup qmail-smtpd \
    qmail-send qmail-remote > /dev/null 2>&1
    done
    else
    echo "It appears svscan is already stopped."
    fi
    echo "."
    ;;
    esac

    #######################################

    vi /service/send/run

    #!/bin/sh
    exec /var/qmail/rc


    ######################################

    vi /var/qmail/rc
    #!/bin/sh

    # Using stdout for logging
    # Using control/defaultdelivery from qmail-local to deliver messages by
    default

    exec env - PATH="/var/qmail/bin:$PATH" \
    qmail-start "`cat /var/qmail/control/defaultdelivery`"

    #############################################

    vi /var/qmail/control/defaultdelivery

    ./Maildir/



    ######################################

    vi /service/send/log/run

    #!/bin/sh
    PATH=/var/qmail/bin:/usr/local/bin:/usr/bin:/bin
    export PATH
    exec setuidgid qmaill multilog t s1000000 n20 /var/log/qmail/send 2>&1

    ######################################################################

    Obrigado.

  2. Meu problema estava no programa setuigid
    Quando recompilei o deamontools o qmail voltou a funcionar corretamente.






Tópicos Similares

  1. Select com month() nao funciona(RESOLVIDO)
    Por cvr no fórum Servidores de Rede
    Respostas: 2
    Último Post: 14-11-2005, 09:15
  2. Qmail Extensions não funciona juntamente com VPopMail
    Por Avenger no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-10-2005, 12:20
  3. Qmail - pop3 não funciona
    Por ungisoft no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-07-2004, 07:06
  4. QMAIL nao funciona o SMTP
    Por redoctober no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-09-2003, 17:06
  5. qmail, não funciona.
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 28-03-2003, 11:30

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L