+ Responder ao Tópico



  1. #1
    jonathas
    Estou tendo problemas ao instalar a Biblioteca GD.
    Ela instala normal, mas quando tento rodar qualquer programa como por exemplo o gd2topng ele dá um erro relativo a link simbolico ou algo assim.

    Assim não dá... :toim: :toim:

  2. Ola,

    Coloque o erro que esta sendo apresentado pelo programa...

    Falow ! :good:



  3. #3
    jonathas
    gd2topng symbol lookup error: /usr//lib/libgd.so.2: undefined symbol: inflateInt_

    É esta a mensagem de erro...

    Obrigado

  4. como vc instalou a sua gd?

    []'s



  5. #5
    jonathas
    ./configure --prefix=/usr/
    make
    make install

    sendo que ele reconehceu o PNG o JPEG e o FreeType (que sao os pacotes q eu preciso junto ao GD--PHP

    Meu slack é o 10.1

  6. #6
    jonathas
    Eu acho que tinha um outro GD na minha maquina antes...
    E se fosse upgrade tem diferença???



  7. o duro eh q sim...

    kra... q tal vc instalar essa sua gd em ouro diretorio? dae, vc nao vai ter problemas d conflito com a antiga... se der, tenta desinstalar a antiga

    []'s

  8. #8
    jonathas
    eu chequei e não tinha nenhum gd instalado anteriormente, ou seja, não é upgrade.



  9. #9
    jonathas
    Resolvido, obrigado pela ajuda e atenção de todos...

  10. Citação Postado originalmente por jonathas
    Resolvido, obrigado pela ajuda e atenção de todos...
    Se puder postar como vc resolveu ia ser de grande ajuda.

    falows



  11. #11
    jonathas
    Bom, depois de muito analizar, observei que algo anterior poderia estar causando conflito. Mas também vi que não havia nenhuma instalação do GD antes de eu instalar.
    Bom, como eu já estava a quase 3 dias tentando, eu resolvi apagar tudo e instalar o Slack 10.1 de novo.
    Nessa nova instalação eu observei tudo com muito cuidado.
    Bom percebi que também tinha um problema no PNG.
    Esse eu nao consegui resolver... Aí infelizmente tive que desabilita-lo na hora de compilar o PHP.

    Tudo isto pra conseguir rodar o PHP.

    Agora... Meu PHP nao cria imagens com o header...

    outra vez.... :toim: Vamos a luta...

  12. aff

    e nao tem como colocar o png pra rodar legalz??

    []'s



  13. #13
    Acabei desistindo o FreeType nao funcionava direito, eu estava tentando usar frontes true type pra gerar imagens... mas acho q era algo do Head

  14. dependencias sao compliacadas.. eu mesmo tive q montar uma box com tdos esses modulos q usamos.. pra poder fazer implantacoes sem dor d cabeca...

    []'s

  15. A GD é foda, já me deu algumas dores de cabeça... Uma vez tinha que atualizar ela. Bom pra fazer isso tive que recompilar Apache, PHP, FreeType, libpng, libjpg.. É aquela história que pra instalar isso tem que ter aquilo...

    Mas a vida é assim, vivendo e aprendendo, se fosse tudo fácil não teria graça nenhuma. Tudo que é mais difícil de se conseguir é melhor.

  16. realmente, assim soluciona qquer coisa...

  17. #17
    jonathas
    Citação Postado originalmente por Anonymous
    Acabei desistindo o FreeType nao funcionava direito, eu estava tentando usar frontes true type pra gerar imagens... mas acho q era algo do Head
    Este lá em cima foi eu que criei o topico e postei me esquecendo de logar...
    Desculpem






Tópicos Similares

  1. instalar adsl (problemas)
    Por rwar no fórum Servidores de Rede
    Respostas: 12
    Último Post: 25-07-2004, 07:56
  2. Problemas para instalar o PPTP(.tar.gz)! Não compila nada!
    Por LinuxAthos no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-08-2003, 08:09
  3. Respostas: 22
    Último Post: 05-06-2003, 10:55
  4. Problemas instalar RH73 c/ SCSI
    Por mirror no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-12-2002, 10:15
  5. Problema para instalar o openssh
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 22-11-2002, 14:06

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L