Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Tava pesquisando no google sobre IDEs para Pascal e obtive as seguinte soluções:

    * Kylix
    * Lazarus

    O Kylix eu descartei. Soube que seu desenvolvimento foi interrompido e talz. E tbm não consigo encontrar a Crt para ele.

    O lazarus não consegui rodar no meu Debian SID. Tenho todos os pacotes do free pascal instalados, porém ao tentar instalar o Lazarus, ele dá esse erro:

    # apt-get install lazarus
    ...

    Os pacotes a seguir têm dependências desencontradas:
    lazarus: Depende: fp-compiler (= 1.9.4-5) mas 1.9.6-2 está para ser instalado
    Depende: fp-units-base (= 1.9.4-5) mas 1.9.6-2 está para ser instalado
    Depende: fp-units-rtl (= 1.9.4-5) mas 1.9.6-2 está para ser instalado
    Depende: fp-units-fcl (= 1.9.4-5) mas 1.9.6-2 está para ser instalado
    Depende: fp-units-gtk (= 1.9.4-5) mas 1.9.6-2 está para ser instalado
    E: Pacotes quebrados

    EU tenho todos os pacotes instalados na versão 1.9.6.2, mas não consigo encontrar todos na versão 1.9.4-5.


    Por enquanto eu estou usando a propria fp-ide já que está possui a Crt(que vou precisar mto). Porém está se tornando inviável devido ao tamanho do projeto.

    Daí estou atras de outra IDE. Alguma sugestão? Ou alguma sugestão de como concertar o erro do lazarus?

  2. Citação Postado originalmente por n0z3y
    EU tenho todos os pacotes instalados na versão 1.9.6.2, mas não consigo encontrar todos na versão 1.9.4-5.
    Parece ser o contrário cara... vc tem todos instalados na versão 1.9.4-5 e precisa ser 1.9.6-2...

    tenta dar um apt-get upgrade nos fp-units-*



  3. Não. Acabei de verificar. Os pacotes instalados estão na versão 1.9.6 .

    O problema talvez seja porque instalei os mesmo através do dpkg, já que não encontrei um mirror para usar no apt. Já procurei tanto no google qto no www.apt-get.org

    Alguem conhece algum?

  4. Emfim... achei os pacotes(na versão 1.9.4-5) necessários pelo lazarus no site:

    http://packages.debian.org/testing/devel/

    Agora dei um:

    # apt-get install lazarus

    e tá fazendo o download. Agora é só esperar para ver.



  5. Consegui aqui.

    Apenas tive um erro durante a inicialização. O erro fala que não foi possível encontrar o diretório do fpc-source(FPC Source Directory not set). Que eu deveria setar isso em Enviroment -> Enviroment Options e tal.

    Na verdade o que aconteceu foi que eu não possuia o pacote fpc-source instalado no meu Debian. E também não o encontrei em .deb .

    A solução foi converter um .rpm para um .deb e instalá-lo com dpkg -i pacote

    O pacote em .rpm eu encontrei aqui:

    http://rpm.pbone.net/index.php3/stat....i386.rpm.html

    Para converter de .rpm para .deb eu precisei do alien. para instalá-lo:

    # apt-get install alien

    Para converter para .deb:

    # alien -d arquivo.rpm

    Será criado um .deb do arquivo no mesmo diretório. Daí é so usar o dpkg para instalá-lo.

    Enfim .. fica aí a dica para quem também tiver esse problema.






Tópicos Similares

  1. IDE para Java
    Por WhiteTiger no fórum Linguagens de Programação
    Respostas: 4
    Último Post: 13-12-2005, 08:33
  2. Ide para mysql e Postgre - eclipse
    Por cvr no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 03-11-2005, 08:42
  3. Respostas: 4
    Último Post: 25-10-2005, 07:56
  4. IDE para QT
    Por 1c3m4n no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 03-02-2005, 08:21
  5. Uma IDE, para Javascript...
    Por agent_smith no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 20-12-2004, 07:59

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L