+ Responder ao Tópico



  1. #1
    gregorioenrico
    Bem, trabalho num laboratório de química na UFPB e nele estamos migrando todas as nossas aplicações, mais precisamente de cálculos quânticos, para Linux. A distro escolhida foi o Mandrake 10.1 Official pelo suporte à ReiserFS.
    Numa máquina tínhamos funcionando beleza o Mandrake e o Windows XP, mas semana passada, magicamente, o Windows reclamava que faltava NTLDR. Deduzi que fosse o boot dele que tava com problema e o reinstalamos. Também recuperamos o LILO.
    Mas o pior, como sempre, aconteceu. Ele deu uma "cagada" na tabela de partições que não tá muito simples montá-la e o instalador/reparador do Mandrake não encontra a partição "/" já existente, só funciona se for pra formatar, mas não é bem o que desejamos.
    Preciso saber se a única forma é reinstalar o sistema sobre uma nova tabela de partições reconfigurada, ou dá pra fazer uma mágica aí pra salvar os cálculos penosos que foram rodados.
    Essa máquina é um P4 3.0GHz numa placa Intel (não sei o modelo), 2 Gigas de RAM, 2 HDs SATA de 80 Gigas cada. A tabela de partições era mais ou menos assim: duas partições NTFS pro XP, duas ReiserFS (uma para / e uma para /home) e uma RAID, com um pedaço de um HD e outro pedaço do outro HD, compondo algo em torno de 100GB.
    Abraços!

  2. boota o micro com o cd do mandrake, depois monta o hd e edita o /etc/lilo.conf depois roda o lilo para gravar as alterações



  3. #3
    augusto_hp
    Pode acontecer de a partição que está como '/' perder a flag de 'bootável' ..... pra verificar isso, boota com um algum disquete de recuperação ou quelaquer outra oisa que permita você a ter o controle de um tty, e dá um #fdisk /dev/hd?

    esse hd? é o seguinte ... vc vai colocar hda se o hd estiver como primary master, hdb se estiver como primary slave, hdc se estiver como secondary master e hdd se ele estiver como secondary slave.
    Pronto, você estará vendo as partições que você tem .... tenha certeza de que o '*' esteja do lado da partição '/'. Se Não estiver, faça ele ficar e seu problema provavlemente estará resolvido.

    Como o amigo disse em cima, o problema pode estar também em alguma configuração do lilo ... ajudaria mais se vocÊ colasse aqui o esquema de partições do seu HD e a configuração do lilo.

    Espero podê-lo ter ajudado.

  4. #4
    gregorioenrico
    Essa do LILO já tinha recuperado, já tinha tentado dar o boot pelo CD do mandrake. Engraçado é que o cd do Mandrake não interpretou direito a tabela de particionamento, e disse "Ooops, no root partition".
    Dei o boot pelo cd do Slackware 10.1 e depois dei um cfdisk... Algo que eu nunca tinha visto: "Error! ..." Disse que não conseguia ler a tabela, e o fdisk também deu no mesmo... Acho que vamos ter que a pagar tudo lá... Tudo por causa do XP.
    Valeu galera!






Tópicos Similares

  1. Implementar segurança no Linux, preciso de ajuda.
    Por Tor no fórum Servidores de Rede
    Respostas: 4
    Último Post: 31-08-2005, 05:45
  2. Rotas no Linux, preciso de ajuda!
    Por LUiZiNH0 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-02-2005, 12:05
  3. Preciso de ajuda para instalar Kopete 0.82 no mandrake 9.1
    Por fabioi2 no fórum Servidores de Rede
    Respostas: 7
    Último Post: 24-06-2004, 10:26
  4. MIL DESCULPAS... Mas preciso de ajuda no WINXP
    Por kaka1983 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 08-05-2004, 20:26
  5. Preciso de ajuda para configurar meu ADSL no linux!
    Por bruno_velox no fórum Servidores de Rede
    Respostas: 2
    Último Post: 13-04-2004, 21:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L