+ Responder ao Tópico



  1. #1
    Bili
    Visitante

    Padrão Error Ao compilar plugin-nagios

    Seguinte erro quando dou o make all
    apos dar o ./configure

    then mv -f ".deps/check_radius.Tpo" ".deps/check_radius.Po"; else rm -f ".deps/c
    heck_radius.Tpo"; exit 1; fi
    check_radius.c: In function `main':
    check_radius.c:126: error: too few arguments to function `rc_avpair_add'
    check_radius.c:127: error: too few arguments to function `rc_avpair_add'
    check_radius.c:128: error: too few arguments to function `rc_avpair_add'
    check_radius.c:129: error: too few arguments to function `rc_avpair_add'
    check_radius.c:139: error: too few arguments to function `rc_avpair_add'
    check_radius.c:145: error: too few arguments to function `rc_send_server'
    make[2]: *** [check_radius.o] Error 1
    make[2]: Leaving directory `/root/nagios-plugins-1.4/plugins'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/nagios-plugins-1.4'
    make: *** [all] Error 2

    o que pode ser??

    Grato

  2. #2
    z3r00
    Visitante

    Padrão cara to com o mesmo problema

    caso vc consiga resolver posta ai no forum

    e o mesmo farei eu!


    Valew!
    de resto so batendo cabecas no google hehehe :toim:



  3. #3
    Fabio_Laé
    Visitante

    Padrão Error Ao compilar plugin-nagios

    Pessoal,

    Vocês conseguiram resolver esse problema? No vol tem um comentário referencindo-se a inexistência da biblioteca /usr/include/radiusclient.h, mas ao contrário do colega que postou esse comentário. Eu já tenho essa biblioteca instalada.

    Se puderem ajudar, agradeço,

    Fabio Laé

  4. #4
    Sandman777
    Visitante

    Padrão Error Ao compilar plugin-nagios

    Estou aqui com o mesmo problema, e ainda nao encontrei a solucao.
    Se alguem tiver...



  5. #5
    Fabio_Laé
    Visitante

    Padrão Error Ao compilar plugin-nagios

    Essa dica vai pra galera do Slackware.

    O problema apresentado no Slackware 10 referente ao make do nagios-plugin ocorre em função do pacote radiusclient que esta desatualizado no Slackware(bem no include radiusclient.h). A versão do Slackware 10 está no 1.1 e precisamos da 1.4

    Infelimente não está muito fácil encontrar o source deste pacote(mesmo nos ftp dos criadores) e também não encontrei nenhum tgz pra ele no linuxpackages.net

    Bom, a solução foi a seguinte arrumei uma máquina com Debian e fiz o apt-get source radiusclient1 --download-only do unstable. :-)

    Copiei o source baixado pro Slackware e .... (bom o restante vocês já sabem né).

    Outra dica é que pra versão 10.1 do Slackware já existem os tgz do nagios e nagios-plugin

    Espero ter contribuído com a nossa comunidade.

    Abraços,
    Fabio Laé

  6. #6
    Sandman777
    Visitante

    Padrão Error Ao compilar plugin-nagios

    Cara! nao acredito!! Compilou! Compilou!
    Its Alive!... Its Alive!...

    Muitissimo obrigado Mr. Flavio!

    Eh uma pena que o slackpkg nao encontra o lib...
    Uns amigos ja brincaram falando sobre o merito do debian nesta solucao
    hehehhe

    Mas eh isso ae... uniao faz acucar..ops.. a Forca..

    []'s



  7. #7
    Sandman777
    Visitante

    Padrão Error Ao compilar plugin-nagios

    Queira me desculpar pelo equivoco na citacao de seu nome...

    Muito obrigado Mr. Fabio !!!

    Foi a Emocao...

    []'s

  8. #8
    Rudiberto Pisetta
    Visitante

    Padrão Remova o ppp

    Tente desinstalar o ppp...
    removepkg ppp-xxxxxxxx

    E tente compilar de novo..


    [email protected]
    Rudiberto Pisetta Junior