+ Responder ao Tópico



  1. #1
    guardian_metal
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    Estou tentando configurar Suse 9.3 + LDAP e quando vou dar um:

    smbldap-populate me aparece o seguinte:

    linux:~ # smbldap-populate
    Using workgroup name from sambaUnixIdPooldn (smbldap.conf): sambaDomainName=lteste
    Using builtin directory structure
    entry dc=lteste,dc=intranet already exist.
    adding new entry: ou=Usuarios,dc=lteste,dc=intranet
    adding new entry: ou=Grupos,dc=lteste,dc=intranet
    adding new entry: ou=Computadores,dc=lteste,dc=intranet
    adding new entry: ou=Idmap,dc=lteste,dc=intranet
    adding new entry: sambaDomainName=lteste,dc=lteste,dc=intranet
    adding new entry: uid=Administrator,ou=Usuarios,dc=lteste,dc=intranet
    adding new entry: uid=nobody,ou=Usuarios,dc=lteste,dc=intranet
    adding new entry: cn=Domain Admins,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 10.
    adding new entry: cn=Domain Users,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 11.
    adding new entry: cn=Domain Guests,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 12.
    adding new entry: cn=Domain Computers,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 13.
    adding new entry: cn=Administrators,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 19.
    adding new entry: cn=Print Operators,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 20.
    adding new entry: cn=Backup Operators,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 21.
    adding new entry: cn=Replicators,ou=Grupos,dc=lteste,dc=intranet
    failed to add entry: no structural object class provided at /usr/local/sbin/smbldap-populate line 460, <GEN1> line 21.

    O que fazer?

  2. #2
    Luzumba
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    Ola amigo,

    Tive o mesmo problema configurando o meu Samba com LDAP
    obteve alguma resposta ?
    um grande abraço



  3. #3
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    Até agora não obtive nehuma resposta e não achei nada também mas coloquei a opção schemacheck no /etc/openldap/slapd.conf como off e foi sem problemas mas me acorreu outro problema agora. Nenhuma estação Windows enxerga o dominio.

  4. #4
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    Até agora não obtive nehuma resposta e não achei nada também mas coloquei a opção schemacheck no /etc/openldap/slapd.conf como off e foi sem problemas mas me acorreu outro problema agora. Nenhuma estação Windows enxerga o dominio.



  5. #5
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    Até agora não obtive nehuma resposta e não achei nada também mas coloquei a opção schemacheck no /etc/openldap/slapd.conf como off e foi sem problemas mas me acorreu outro problema agora. Nenhuma estação Windows enxerga o dominio.

  6. #6
    Luzumba
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    vc. usou aquele manual SQUID + LDAP + SAMBA ?
    Eu procurei o Autor e ele ainda nao me respondeu se é algum erro no proprio manual ou se ele ja passou por isso



  7. #7
    Luzumba
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    Oi amigao,

    Olha só esse erro sumiu do meu hoje.
    Eu refiz todo o processo de configurar o LDAP
    Eu resiz todo o processo de configurar o Samba
    Ai funcionou o meu problema era o sufixo que nao tinha colocado só estava Pool, ai usei dc=pool,dc=intranet

    Se isto puder lhe ajudar

    Tem uns tutoriais legais em http://www.ldap.org.br

    Um grande abraço

  8. #8
    guardian_metal
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    em que parte só estava Pool?

    Ja refiz o Samba+LDAP no Suse 9.3 umas 6 vezes e o problema é o mesmo. No Conectiva 10, demorei 30 minutos pra montar tudo e funcionar mas tenho que fazer funcionar no suse.



  9. #9
    Luzumba
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    os arquivos que tinham somente dc=pool e alterei para dc=pool,dc=intranet

    slapd.conf
    ldap.conf
    smb.conf

    o que esta acontecendo é que ele nao esta gerando os objetos... ou seja num esta mesclando ldap com o samba

    no tutorial que peguei funcionou belezinha...

    Blz ?
    Eu sei que nao manjo muito de linux mas no que eu puder ajudar...

  10. #10
    guardian_metal
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    Se você puder me passar o tutorial que você usou, ficaria agradecido. Vou ficar louco daqui a poko.. rs

    guardian_metal arroba yahoo.com.br



  11. #11

    Padrão Forum gente.. no Forum...

    Aew,

    Posta o link do tutorial que tu usou no Forum.

    Assim todos tem acesso a ele.


    Flws,

  12. #12
    Luzumba
    Visitante

    Padrão Suse 9.3 + Ldap + Samba

    oi amigos bom dia !

    Eu peguei o tutorial em http://www.ldap.org.br, alias tem alguns outros tbm. muito bons

    um grande abraço a todos