+ Responder ao Tópico



  1. #1
    whinston
    Visitante

    Padrão erros muito doidos no apt-get

    apt-get install htop
    Reading Package Lists... Done
    Building Dependency Tree... Done
    W: There are multiple versions of "lilo" in your system.

    This package won't be cleanly updated, unless you leave
    only one version. To leave multiple versions installed,
    you may remove that warning by setting the following
    option in your configuration file:

    RPM::Allow-Duplicated { "^lilo$"; };

    To disable these warnings completely set:

    RPM::Allow-Duplicated-Warning "false";

    W: There are multiple versions of "perl-Compress-Zlib" in your system.

    This package won't be cleanly updated, unless you leave
    only one version. To leave multiple versions installed,
    you may remove that warning by setting the following
    option in your configuration file:

    RPM::Allow-Duplicated { "^perl-Compress-Zlib$"; };

    To disable these warnings completely set:

    RPM::Allow-Duplicated-Warning "fal
    W: There are multiple versions of "perl-Text-Iconv" in your system.

    This package won't be cleanly updated, unless you leave
    only one version. To leave multiple versions installed,
    you may remove that warning by setting the following
    option in your configuration file:

    RPM::Allow-Duplicated { "^perl-Text-Iconv$"; };

    To disable these warnings completely set:

    RPM::Allow-Duplicated-Warning "false";

    W: You may want to run apt-get update to correct these problems
    E: Couldn't find package htop

  2. #2

    Padrão erros muito doidos no apt-get

    Cara ou provavelmente vc instalou versoes desses pacotes sem ser por APT ou nao usando rpm -Uvh e deu problema ae tem um comando de apt que na lembro que concerta isso.

    falows



  3. #3
    jedi
    Visitante

    Padrão erros muito doidos no apt-get

    Uma vez eu instalei duas versões diferentes do mesmo programa e deu este mesmo problema, o que tive que fazer foi apagar as duas versões e instalar somente uma, escolhi a mais antiga por estar a mais tempo com ela.
    Mas este erro é como o ruyneto falou, É que vc instalou duas versões. Enquanto vc ñ resolver isso ele ñ vai deixar vc instalar nada pelo apt-get.