+ Responder ao Tópico



  1. #1

    Padrão Squid muito lento...

    Senhores
    Servidor rodando RH 9. Alterei o IP usado.
    Editei ifcfg-eth0, ifcft-eth1, network, resolv.conf(os dns são outros) e tambem o httpd.conf do apache. Nesse, só alterei o ip pelo console.
    O problema é que, usando o SQUID, fica muito lento.
    Antes da alteração, tava normal.
    Quando eu configuro um dns, sem proxy, o acesso fica legal.
    Esqueci de configurar algo? Revirei o guia squid 1.5 e não achei nada
    que pudesse ser alterado.

    Obs. Se algum de vcs ver um cara com a cara amarrada, com um crachá da Prefeitura de Tibagi -Pr, em Porto Alegre, não se assustem.
    Sou eu...
    Valeu pela força.

  2. #2
    redeprotegida
    Visitante

    Padrão Squid muito lento...

    da uma configurada no teu named e no seu /etc/resolv.conf voce aponta a propria maquina como servidora de dns dela mesma.

    tambem de um rotate no seus logs
    se eles estiverem mt grandes tbm compromete o squid
    squid -k rotate


    Abração



  3. #3

    Padrão Squid muito lento...

    Cara, o acess.log ta com 1,6 giga. O comando #squid -k rotate não executa nenhuma função.
    Se eu não configurar dns externo nem navega.
    O named não tem nenhuma configuração que eu alterar.
    Continua igual, pelo squid fica uma carroça.
    Sem proxy, 1 mega.
    Malguma dica?
    Obrigado pela atenção.

  4. #4

    Padrão Squid muito lento...

    vc tem o bind instalado na maquina?



  5. #5

    Padrão Squid muito lento...

    Tenho, mas não achei nada reconfiguravel nos named.
    Antes de mudar o ip funcionava lega... :toim: :toim:

  6. #6
    redeprotegida
    Visitante

    Padrão Squid muito lento...

    eu ja vi no fedora 3 o rotate do squid não funcionar
    neste caso, vai na gambi mesmo

    echo > /var/log/squid/access.log
    echo > /var/log/squid/store.log
    echo > /var/log/squid/cache.log

    vi /etc/resolv.conf

    search seudominio.com.br
    nameserver 127.0.0.1

    service squid stop
    service named stop

    service named start
    service squid start

    para conferir se seu named está funcionando digite:
    nslookup www.terra.com.br

    exemplo:
    [[email protected] /root]# nslookup www.uol.com.br
    Note: nslookup is deprecated and may be removed from future releases.
    Consider using the `dig' or `host' programs instead. Run nslookup with
    the `-sil[ent]' option to prevent this message from appearing.
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    Non-authoritative answer:
    Name: www.uol.com.br
    Address: 200.221.2.45

    [[email protected] /root]#

    a linha "Server:" comprova que a consulta foi feita internamente...

    Não se deve usar squid+dns externo, fica MUITO lento mesmo!!



  7. #7

    Padrão Squid muito lento...

    Blz, to postando essa antes de tentar. Só pra dizer que funcuonava assim.
    Eu simplesmente troquei o ip da maquina e os 2 dns que haviam no resolv.conf
    Mas vou tentar isso aí. Valeu pela força.

  8. #8

    Padrão Squid muito lento...

    Citação Postado originalmente por jadirorza
    Cara, o acess.log ta com 1,6 giga. O comando #squid -k rotate não executa nenhuma função.
    Se eu não configurar dns externo nem navega.
    O named não tem nenhuma configuração que eu alterar.
    Continua igual, pelo squid fica uma carroça.
    Sem proxy, 1 mega.
    Malguma dica?
    Obrigado pela atenção.
    1.6giga? caracas!!!!
    já que o #squid -k rotate não tá executando nada, executa esse comando então, para zerar o seu access.log
    #echo > access.log

    access.log com 1.6 giga fica monstruozo! mata tudo...



  9. #9

    Padrão Squid muito lento...

    Citação Postado originalmente por redeprotegida
    eu ja vi no fedora 3 o rotate do squid não funcionar
    neste caso, vai na gambi mesmo

    echo > /var/log/squid/access.log
    echo > /var/log/squid/store.log
    echo > /var/log/squid/cache.log

    vi /etc/resolv.conf

    search seudominio.com.br
    nameserver 127.0.0.1

    service squid stop
    service named stop

    service named start
    service squid start

    para conferir se seu named está funcionando digite:
    nslookup www.terra.com.br

    exemplo:
    [[email protected] /root]# nslookup www.uol.com.br
    Note: nslookup is deprecated and may be removed from future releases.
    Consider using the `dig' or `host' programs instead. Run nslookup with
    the `-sil[ent]' option to prevent this message from appearing.
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    Non-authoritative answer:
    Name: www.uol.com.br
    Address: 200.221.2.45

    [[email protected] /root]#

    a linha "Server:" comprova que a consulta foi feita internamente...

    Não se deve usar squid+dns externo, fica MUITO lento mesmo!!
    Cara... quer dizer que tenho que configurar o BIND, pra resolver essa questão de lentidão no squid ?