Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    vandemberg
    Colegas,
    Estou aplicando o Patch-o-matic aqui no meu firewall pra bloquear de vez esse kazaa. Toda a instalação de certo, peguei o iptables-1.2.11 compilei, usei o pacote patch-o-matic-20030107 e compilei normal com suporte ao psd e string, recompilei meu kernel 2.4.20 ativando o suporte ao psd e strig e por ultimo compilei e instalei o ipp2p.06. Toda a instalação deu blza, consigo colocar as regras e tudo mais.
    O problema aparece quando eu vou ativar o MASQUERADE e o REDIRECT pra fazer meu proxy transparente. ele informa o seguinte:
    #iptables -t nat -A PREROUTING -s minha_lan -p tcp --dport 80 -j REDIRECT --to-port 3128
    iptables: Invalid argument
    E quando dou um boot pelo kernel sem compilação e utilizando o iptables nativo da instalação que é o 1.2.7 (red hat 9.0) os comandos são inseridos normalmente.
    Alguma dica?
    Grato a todos.

  2. troca --to-port pra soh --to



  3. #3
    vandemberg
    Mesmo erro amigo.

  4. vc compilo o novo iptables na mao neh... jah sei oq deve ser... vc esta com as 2 versoes do iptables na maquina, provavelmente uma esta em /usr/sbin e a outra em /usr/local/sbin, e qdo vc roda soh iptables ele pega a primeira...

    veja se eh isso mesmo

    find / -name iptables



  5. #5
    vandemberg
    Isso mesmo amigo.. tem as duas versões do iptables instalado na maquina.. ambos mostra o erro veja:
    (compilado na mão)# /usr/src/iptables/iptables -t nat -A POSTROUTING -s 10.20.30.0/24 -o eth0 -j MASQUERADE
    iptables: Invalid argument

    (instalado junto com o RH9)# /usr/local/sbin/iptables -t nat -A POSTROUTING -s 10.20.30.0/24 -o eth0 -j MASQUERADE
    iptables: Invalid argument

    Tipo como se o suporte ao mascaramento e ao redirect nao estivesse ativo na minha compilação, mas os modulos estão todos levantados. Realmente nao tenho idéia.






Tópicos Similares

  1. O que mudou na sua rede após a implantação do N!MOC Power
    Por m4d3 no fórum Servidores de Rede
    Respostas: 50
    Último Post: 31-07-2012, 22:10
  2. Respostas: 6
    Último Post: 23-02-2011, 16:41
  3. dev/hdc invalid argument mount
    Por sony no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-06-2005, 07:42
  4. Iptables: SNAT Invalid Argument?
    Por Hacinn no fórum Servidores de Rede
    Respostas: 6
    Último Post: 04-05-2004, 10:28
  5. Mensagem pedindo para trocar senha apos logon do XP no Samba
    Por Hacinn no fórum Servidores de Rede
    Respostas: 5
    Último Post: 20-06-2003, 08:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L