Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    jvdebian
    Ei Pessoal, to me sentindo um idiota, mas como eu sei que vcs nao se importam com as nossas idiotices eu vou ter que postar uma duvida!!!
    Seguinte!!!
    Instalei o squid no meu Debian Server que ja estava rodando como firewall, entao configurei o proxy no browser e funcionou, consegui acessar a net com o proxy on o browser. ai acrescentei as regras da seguinte maneira.
    * criei um arquivo /etc/squid/block.txt
    * criei tb um arquivo unblock.txt no mesmo diretorio.
    --> olha o squid.conf
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    acl internal_net src 10.0.0.0/24
    #regras de bloqueio
    acl blockedsites url_regex -i "/etc/squid/block/block.txt"
    acl unblockedsites url_regex -i "/etc/squid/block/unblock.txt"

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow internal_net
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost

    # ativando o bloqueio
    http_access deny blockedsites !unblockedsites


    http_access deny all
    icp_access allow all

    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    ----------------------------------------------------------------------------------------------------
    entao configurei o IPTABLES
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128.

    mas mesmo assim o proxy transparente nao funciona e mesmo sem a configuracao no browser ele acessa a net, e pior qdo coloco o proxy on no browser, ele nao esta bloqueando os sites do arquivo block.txt ???

    que sera que ta acontecendo, nao era pra ser tao complicado!!!

  2. acl blockedsites dstdomain "/etc/squid/block.txt"
    acl unblockedsites dstdomain "/etc/squid/unblock.txt"

    url_regex e pra bloquear palavras, para bloquear sites use dstdomain, e procure manter os seus arquivos de bloqueio dentro de /etc/squid/
    nao tem por que criar um caminho mais comprido !!!
    E nao se esqueça de dar permissao pra esses dois arquivos !!!

    Valeu velho espero ter ajudado



  3. #3
    jvdebian
    Po!! isso nao resolveu mto nao, eu troquei a Sintaxe do comando e mesmo assim nao ta rolando!!! q q pode ser hein?

  4. #4
    jvdebian
    e pq q a minha regra de Iptables nao ta funcionando??? eu ja configurei mas mesmo assim qdo eu retiro as config do proxi no browser, ele ainda consegue acessar a net so com o NAT..!!



  5. Amigo da uma olhada nesse artigo que eu escrevi, que vai te ajudar,
    so onde diz http_access deny permitir_rede vc coloca allow, pois deve ter sido erro de digitaçao da minha parte ou de quem publicou !!!

    http://www.linuxit.com.br/section-viewarticle-708.html

    Valeu !!!






Tópicos Similares

  1. Squid inicia mas não navega!!
    Por zamberlan no fórum Servidores de Rede
    Respostas: 4
    Último Post: 25-09-2006, 15:49
  2. ETH0 funciona mas nao funciona. hhee
    Por terra_jr no fórum Servidores de Rede
    Respostas: 7
    Último Post: 02-11-2005, 21:59
  3. squid instalado mas nao autentica
    Por icefox no fórum Servidores de Rede
    Respostas: 3
    Último Post: 06-08-2005, 19:18
  4. vpn/pptp funciona, mas nao como deveria.
    Por ajsmit no fórum Servidores de Rede
    Respostas: 2
    Último Post: 19-10-2004, 23:19
  5. SQUID funciona mas não RESTART
    Por Visitante no fórum Servidores de Rede
    Respostas: 2
    Último Post: 20-08-2004, 07:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L