Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    -thiago-
    Pessoal, um cliente está reclamando q está sem internet, o servidor Proxy Linux foi desligado devido a uma falta de energia, dps ñ conseguiram mais acessar a Web (detalhe: só ñ navegam, o resto está OK), pensei então em verificar o Squid, e me deparei com as seguintes msgs:

    fw-mtoys:/etc/init.d # ./squid start
    Starting WWW-proxy squid done
    fw-mtoys:/etc/init.d # ./squid status
    Checking for WWW-proxy squid checkproc: Empty pid file /var/run/squid.pid for /usr/sbin/squid
    running
    fw-mtoys:/etc/init.d # ./squid stop
    Shutting down WWW-proxy squid checkproc: Empty pid file /var/run/squid.pid for /usr/sbin/squid
    squid: ERROR: No running copy
    - wait a minute ...................
    .........................................checkproc: Empty pid file /var/run/squid.pid for /usr/sbin/squid
    killproc: Empty pid file /var/run/squid.pid for /usr/sbin/squid
    Warning: squid killed ! done
    fw-mtoys:/etc/init.d # ./squid start
    Starting WWW-proxy squid done
    fw-mtoys:/etc/init.d # ./squid status
    Checking for WWW-proxy squid checkproc: Empty pid file /var/run/squid.pid for /usr/sbin/squid
    running
    fw-mtoys:/etc/init.d # cat /var/run/squid.pid
    fw-mtoys:/etc/init.d #


    Acredito que este seja um dos motivos deles não estarem navegando, vcs podem me ajudar a resolver este prob. ?

    Tks,
    Thiago

  2. #2
    -thiago-
    Ah...acabei de notar que dps de alguns minutos o serviço do squid cai!
    fw-mtoys:/etc/init.d # ./squid status
    Checking for WWW-proxy squid checkproc: Empty pid file /var/run/squid.pid for /usr/sbin/squid
    unused


    Socorro ! Preciso resolver isto o mais rápido possível, não estou conseguindo achar nenhuma solução :cry:

    Thiago



  3. #3
    rm -rf /var/spool/squid && rm -rf /var/cache/squid* && squid -z && service squid start

  4. #4
    Citação Postado originalmente por Anonymous
    rm -rf /var/spool/squid && rm -rf /var/cache/squid* && squid -z && service squid start
    opa é /var/run/squid.pid e não /var/spool/squid.

    ficaria assim:
    rm -rf /var/run/squid.pid && rm -rf /var/cache/squid* && squid -z && service squid start



  5. #5
    apague o pid, mata o cache cria novamente o cache e reinicia o serviçi...






Tópicos Similares

  1. Erro no Squid. /etc/init.d/squid: line 162: 3597 Abortado
    Por odbc no fórum Servidores de Rede
    Respostas: 5
    Último Post: 13-05-2004, 08:52
  2. Erro no Squid
    Por FabioDaniel no fórum Servidores de Rede
    Respostas: 1
    Último Post: 31-12-2003, 16:47
  3. erro no squid
    Por rlucatto no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-06-2003, 17:38
  4. Erro no squid (No running copy)
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 08-06-2003, 11:15
  5. Erro no Squid
    Por Aquini no fórum Servidores de Rede
    Respostas: 5
    Último Post: 25-11-2002, 15:14

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L