+ Responder ao Tópico



  1. #1
    ranhoca
    Olá Pessoal!
    Bem, vinha aki para ver se alguem me safava desta grande merda.. Já são quase duas da manha em portugal e tenho um trabalho LDAP+APACHE para entregar as 9h da manha... Se alguem souber, ou alguma coisa para me ajudar seria mesmo muito bom...

    O problema é o seguinte: Apache não se liga ao servidor LDAP.

    Versões utilizadas:
    [root@aioros logs]# /usr/sbin/httpd -v
    Server version: Apache/2.0.54

    [root@aioros logs]# uname -a
    Linux aioros 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 i686 i386 GNU/Linux

    [root@aioros logs]# /usr/sbin/slapd -V
    @(#) $OpenLDAP: slapd 2.2.23 (May 19 2005 17:53:54) $


    Pedaço do httpd.conf - parte relacionada com o LDAP:
    Código :
    <Directory /var/www/html/ldap> 
     AllowOverride None 
     Order allow,deny 
     Allow from all 
     AuthName "Sistema de login via LDAP"
     AuthType Basic 
     AuthLDAPEnabled on 
     AuthLDAPURL ldap://localhost/dc=omeusite,dc=com?uid
     require valid-user 
     AuthLDAPAuthoritative on 
    </Directory>


    LDIF do utilizador inserido no LDAP:
    Código :
    ## Entrada LDIF para Ranho em Lata
    dn: uid=lata, ou=login,dc=omeusite,dc=com
    uid: lata
    cn: Ranho em lata
    objectclass: account
    objectclass: posixAccount
    userPassword: latinha
    loginShell: /bin/bash
    uidNumber: 781
    gidNumber: 100
    HomeDirectory: /home/lata

    E finalmente SLAPD.CONF
    Código :
    include		/usr/local/etc/openldap/schema/core.schema
    include   	/usr/local/etc/openldap/schema/cosine.schema
    include   	/usr/local/etc/openldap/schema/inetorgperson.schema
    include   	/usr/local/etc/openldap/schema/nis.schema
     
    pidfile		/usr/local/var/run/slapd.pid
    argsfile	/usr/local/var/run/slapd.args
    loglevel 8
     
    database	bdb
    suffix		"dc=omeusite,dc=com"
    rootdn		"cn=Manager,dc=omeusite,dc=com"
    rootpw		secret
     
    directory	/usr/local/var/openldap-data/omeusite.com
    mode 0600
    cachesize 500
     
    index	objectClass	eq
    index   cn,sn,mail,uid  pres,eq
    index   uidnumber       eq
    index   gidnumber       eq
     
    access to * by * read

    Aqui vai o erro que encontro no error.log (apache)
    Código :
    [Sat Jul 02 01:21:51 2005] [warn] [client 127.0.0.1] [5902] auth_ldap authenticate: user lata authentication failed; URI /ldap/ [LDAP: ldap_simple_bind_s() failed][Can't contact LDAP server]

    é isso pessoal... Se alguem souber de alguma coisa seria mesmo MUITO grato!
    Muito obrigado para quem leu este tópico até ao fim.

    cumprimentos

  2. #2
    karfax
    Cerifique-se de que voce tem isto em seu servidor Apache:
    LoadModule auth_ldap_module modules/auth_ldap.so
    Está disponivel para download em http://www.rudedog.org/auth_ldap/

    Uma outra variante de entrada para autenticação seria:
    AuthLDAPURL ldap://localhost/dc=omeusite,dc=com?uid?sub?(objectClass=*)


    O que pode complicar é sua entrada ldap se referindo à uma base localhost onde não há espaço para sufixos .com e esta está incluida no rootdn.

    Boa sorte,






Tópicos Similares

  1. Problema ao tentar acessar pagina no apache
    Por riva no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-05-2005, 14:07
  2. Problemas com Cache no Apache 2.0.40
    Por demiurgo no fórum Servidores de Rede
    Respostas: 13
    Último Post: 01-04-2005, 12:40
  3. Problema no Apache/mod_proxy
    Por SDM no fórum Servidores de Rede
    Respostas: 6
    Último Post: 24-12-2004, 13:44
  4. Problemas com o asp rodando no apache
    Por noir no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-09-2003, 09:32
  5. Problemas com diretório virtual no apache
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 17-12-2002, 23:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L