+ Responder ao Tópico



  1. #1
    kallunga
    Visitante

    Padrão Removi o glibc do meu slack e agora n'ao funciona nada!!!

    Falae galera,

    Estava com problema de dependencia no apache e ent'ao resolvi desisntalar o glibc para poder reinstala-lo e ver se resolveria o problema. Mas agora nao tenho mais shell...t[a dando erro

    Código :
    [email protected]:~# service httpd start
    -bash: /usr/sbin/service: /bin/sh: bad interpreter: No such file or directory

    E quando tento reinstalar o glibc tenho o seguinte erro

    Código :
    [email protected]:/programas# slackpkg install glibc
    -bash: /usr/sbin/slackpkg: /bin/sh: bad interpreter: No such file or directory

    Agora nao sei como poderei reinstala-lo... Se alguem tiver alguma sugestao, sera bem vinda!

  2. #2
    Luzumba
    Visitante

    Padrão Removi o glibc do meu slack e agora n'ao funciona nada!!!

    localize o nome correto do pacote e instale via rpm
    Se ele pedir as dependencias, instale elas tbm.



  3. #3
    kallunga
    Visitante

    Padrão Removi o glibc do meu slack e agora n'ao funciona nada!!!

    Ae,

    O problema é que eu não consigo entrar no Konsole... só os q já estão abertos pelo KDE.

    Nenhum comando é reconhecido. Nem o ls aceita mais.

    Não sei o q pode acontecer qdo eu reiniciar e entrar em modo texto.

    Só funciona o comando cd. O resto nada. Eu até tenho os a pacotes tgz no hd mas o comando não é reconhecido.

    Também não consiguo entrar via ssh pela rede. Pede login e senha e depois fecha o putty.

    Tá sinistro...

  4. #4
    Luzumba
    Visitante

    Padrão Removi o glibc do meu slack e agora n'ao funciona nada!!!

    nao inicia via lilo ou grub ?



  5. #5

    Padrão Removi o glibc do meu slack e agora n'ao funciona nada!!!

    *reinstala*.

    na boa apague kernel32.dll no windows e veja o q vc consegue fazer.


    outra maneira e montar o disco em outro linux e copiar a glibc identica a qual voce tinha e ver se voce consegue sobreviver, pq na hora q voce reniciar esse linux ele nao vai mais voltar.

    so uma dica.. cuidado com as coisas que voce apaga, upgrade de biblioteca e coisa seria... e dar upgrade nao eh apagar e copiar uma nova, ainda mais se tratando de uma biblioteca `seria` como essa.

  6. #6

    Padrão Removi o glibc do meu slack e agora n'ao funciona nada!!!

    assino em baixo do q o myst disse:

    reinstale...

    taum importante quanto a glibc.. soh o kernel mesmo hehehe



  7. #7
    whinston
    Visitante

    Padrão já sei oq não fazer

    rsrs, já sei oq não posso fz !

  8. #8
    Visitante

    Padrão menos pessoal!

    Simplismente dê boot pelo cd e reinstale a glibc!

    Monte o diretorio onde está instalado o seu sistema em /mnt/aqui
    Agora: chroot /mnt/aqui /bin/bash
    vá do diretório onde está o pacote da glibc no cdrom de instalação.
    A seguir dê um (/sbin/)installpkg glibc...

    Isso deve resolver!



  9. #9
    kallunga
    Visitante

    Padrão Removi o glibc do meu slack e agora n'ao funciona nada!!!

    Agradecendo todas as idéias,

    A sugestão acima é legal!!! Eu pensei nisso enquanto eu estava instalando novamente...

    Sorte q eu só tinha o BIND, HTTP intranet instalado e então eu enviei os arquivos de configuração para meu e-mail e fiz a restauração... Só perdi as configurações anteriores do sistema mas tá tranquilo...

    Vlw galera... Abraço!