+ Responder ao Tópico



  1. Pessoal, tinha configurado um dhcp-server e estava funfando redondinho, de repente parou de funfar e naum levanta mais. ele informa que naum tem uma subnet declarada, o que naum é verdade. Vejam a mensagem de erro abaixo, logo depois está postado o dhcpd.conf:

    Jul 13 14:34:27 redeagle dhcpd: Internet Systems Consortium DHCP Server V3.0.1
    Jul 13 14:34:27 redeagle dhcpd: Copyright 2004 Internet Systems Consortium.
    Jul 13 14:34:27 redeagle dhcpd: All rights reserved.
    Jul 13 14:34:27 redeagle dhcpd: For info, please visit http://www.isc.org/sw/dhcp/
    Jul 13 14:34:27 redeagle dhcpd: Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not specified in the config file
    Jul 13 14:34:27 redeagle dhcpd: Wrote 0 leases to leases file.
    Jul 13 14:34:27 redeagle dhcpd:
    Jul 13 14:34:27 redeagle dhcpd: No subnet declaration for eth0 (0.0.0.0).
    Jul 13 14:34:27 redeagle dhcpd: ** Ignoring requests on eth0. If this is not what
    Jul 13 14:34:27 redeagle dhcpd: you want, please write a subnet declaration
    Jul 13 14:34:27 redeagle dhcpd: in your dhcpd.conf file for the network segment
    Jul 13 14:34:27 redeagle dhcpd: to which interface eth0 is attached. **
    Jul 13 14:34:27 redeagle dhcpd:
    Jul 13 14:34:27 redeagle dhcpd:
    Jul 13 14:34:27 redeagle dhcpd: Not configured to listen on any interfaces!
    Jul 13 14:34:27 redeagle dhcpd:
    Jul 13 14:34:27 redeagle dhcpd: If you did not get this software from ftp.isc.org, please
    Jul 13 14:34:27 redeagle dhcpd: get the latest from ftp.isc.org and install that before
    Jul 13 14:34:27 redeagle dhcpd: requesting help.
    Jul 13 14:34:27 redeagle dhcpd:
    Jul 13 14:34:27 redeagle dhcpd: If you did get this software from ftp.isc.org and have not
    Jul 13 14:34:27 redeagle dhcpd: yet read the README, please read it before requesting help.
    Jul 13 14:34:27 redeagle dhcpd: If you intend to request help from the dhcp-server@isc.org
    Jul 13 14:34:27 redeagle dhcpd: mailing list, please read the section on the README about
    Jul 13 14:34:27 redeagle dhcpd: submitting bug reports and requests for help.
    Jul 13 14:34:27 redeagle dhcpd:
    Jul 13 14:34:27 redeagle dhcpd: Please do not under any circumstances send requests for
    Jul 13 14:34:27 redeagle dhcpd: help directly to the authors of this software - please
    Jul 13 14:34:27 redeagle dhcpd: send them to the appropriate mailing list as described in
    Jul 13 14:34:27 redeagle dhcpd: the README file.
    Jul 13 14:34:27 redeagle dhcpd:
    Jul 13 14:34:27 redeagle dhcpd: exiting.

    === dhcpd.conf começa agora=====
    ddns-update-style none;
    subnet 192.168.0.0 netmask 255.255.0.0 {
    # default gateway
    option routers 192.168.0.1;
    option subnet-mask 255.255.255.0;

    option domain-name "domain.org";

    # Seting up an ip address is better here
    option domain-name-servers ns.domain.org;
    option nis-domain "domain.org";

    range dynamic-bootp 192.168.0.128 192.168.0.254;
    default-lease-time 21600;
    max-lease-time 43200;

    # we want the nameserver to appear at a fixed address
    #host ns {
    # next-server fixed.mandrakesoft.com;
    # hardware ethernet 12:34:56:78:AB:CD;
    # fixed-address 192.168.0.10;
    #}
    }

    Agradeço qq. ajuda.

    []s.

  2. #2
    maverick_cba
    Amigo, tenho aqui configurado da seguinte forma:

    Código :
    # Rede Principal
    subnet 192.168.0.0 netmask 255.255.255.0 {
            option domain-name-servers 192.168.0.1;
            option routers 192.168.0.1;
            range 192.168.0.100 192.168.0.199;
            }
    E tá funcionando legal...

    Experimenta usar assim

    Outra coisa a se analizar, e se o seu servidor DHCP está buscando o arquivo de configuração no local certo. Para ter certeza de que ele irá carregar o arquivo correto, dê o comando abaixo:
    Código :
    dhcpd -cf [local do arquivo de configuração]

    Abraços,



  3. vc tem mais de uma interface de rede configurada? inclusive ppp0? qdo o adsl levanta vc zera o ip da placa?
    é isso que ele está reconhecendo e dando erro!






Tópicos Similares

  1. MInha RB433Ah Naum trafega mais de 2 Megas
    Por AdilsonMonteiro no fórum Redes
    Respostas: 3
    Último Post: 24-03-2011, 18:13
  2. Servidor X parou de funfar
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 21-09-2005, 13:12
  3. Servidor de POP3 naum aguento mais
    Por c4f0f0 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 30-10-2003, 08:30
  4. phpnuke parou de vez
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-03-2003, 09:10
  5. Socorro - Squid parou de autenticar após atualização de paco
    Por Ganymede no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-02-2003, 13:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L