Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    centralservice
    Essa é a decima vez q posto isso no forum e ninguem m responde, das duas uma, ou ninguem nunca teve esse problema ou sei la nào estão afim de ajudar, o galera esse meu problema pode vir a ser de outra pessoa no futuro.


    bom a parada e o seguinte, eu comecei a adicionar ao cups as impressoras q estão nas maquinas xps, até ai tudo bem, bom tudo bem"", pq penei muito, mais chegei la, agora acontece o seguinte eu consigo mandar uma impressão de teste do cups sem problema. mais o problema começa quando eu vou tentar adicionar estas impressoras q estão estaldas no cups/samba, em uma das maquinas xps q nào tem impressoras estalada, eu estou tendo um problema.

    os meus passos são o seguinte

    eu logo na maquina xp dentro do dominio
    ai vou adiconar impresoras
    tem as opçoes de local e de rede
    vou na de rede
    ai a maquina localiza os grupos e acha o linux
    no linux aparece a impressora q no momento foi estalda no cups, q por sinal essa mesma impressora c encontra em uma outra maquina XP.
    bom quando mando avançar me da esse maldido erro:

    "Há uma diretiva em vigor no computador que impede que você se conecte a esta fila de impressão. Contate o administrador do sistema."

    galera eu ja fiz tudo o q vcs possam imaginar, pensei em recorrer as vcs, sei q aqui vou encontrar a solução

    estou ficando louco

    segue a meu smb.conf

    [global]
    workgroup = sulcat
    server string = Servidor SMB
    announce as = NT Server
    hosts allow = 192.168.1.0/255.255.255.0
    interfaces = eth0
    log file = /var/log/samba/%m.log
    max log size = 50
    log level = 1
    name resolve order = wins lmhost bcast hosts
    smb passwd file = /etc/samba/smbpasswd
    netbios name = Linux
    unix charset = iso-8859-1
    security = user
    passdb backend = smbpasswd
    username map = /etc/samba/smbusers
    printing = cups
    printcap name = cups
    admin users = root
    load printers = yes
    domain logons = yes
    domain master = yes
    preferred master = yes
    os level = 80
    logon drive = H:
    #logon path = \\%L\profiles\%U
    logon script = %U.bat
    #logon script = logon.cmd
    wins support = yes
    time server = yes
    add machine script = /usr/sbin/adduser -n -r -g machines -c "Samba machine" -d /dev/null -s /bin/false %u
    #========================Compartilhamento===========

    [Relatórios]
    comment = Relatórios dos setores da empresa
    path = /dados
    guest ok = yes
    browseable = yes
    writeable = yes
    [custos]
    comment = custos
    path = /home/custos
    guest ok = yes
    browseable = yes
    writeable = yes
    [Homes]
    comment = Diretório home
    writable = yes
    browseable = no
    valid users = %S
    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    # Defina 'public = yes' para permitir que o usuário 'convidado' a imprimir
    guest ok = no
    writable = no
    printable = yes
    printer admin = root
    [netlogon]
    path = /var/lib/samba/netlogon
    read only = yes
    write list = root
    [profiles]
    path = /var/lib/samba/profiles
    read only = no
    create mask = 0600
    directory mask = 0700


    na tag [printers] eu ja fiz d tudo, mais eu tenho certeza q tem algo errado, mais ainda nào consegui encontrar.

    ficarei grato c alguem puder m ajudar

    um grande abraço

  2. #2
    felco
    eu acredito que o problema seja o driver... ja que no seu samba nao tem um compartilhamento que eu nao me lembro o nome que fornece os drivers, vc ja tentou adicionar manualmente a impressora?




  3. #4
    centralservice
    Galera

    eu ja fiz o q tem nesse tópico q vcs m endicaram

    vou descrever a minha situação:

    imaginem

    MAQUINA XP 1 COM PRINTER HP680C
    MAQUINA XP 2
    MAQUINA 3 linux SERVIDOR SAMBA/CUPS

    essa impressora q esta na maquina xp esta compartilhda e estalda no cups do servidor, bom do servidor eu consigo imprimir na maquina 1, bom isso foi depois de muito custo, mudando os parametro de acordo com o topico asima endicado pr vcs, o problema começa quando eu tento na maquina XP 2, adicionar a Printer q esta estalda no cups/samba, q por fim esta estalada localmente na maquina 1.

    eu faço todos os processos normais de estlar impressora por rede, ai aprece a minha rede e a linux, nessa linux aparece essa printer, mais quando clico nela e mando avançar para proceguir a estalação me da esse maldito erro:

    "Há uma diretiva em vigor no computador que impede que você se conecte a esta fila de impressão. Contate o administrador do sistema."


    pessoal o q pode estar acontecendo, a minha tag [printers] é essa, q teoricamente estaria disponibilizando todas as impressoras sem restrições de instalação, ok, ou estou falando beseira.

    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    # Defina 'public = yes' para permitir que o usuário 'convidado' a imprimir
    guest ok = no
    writable = no
    printable = yes
    printer admin = root



    bom eu estou quase :toim: por favor m

    valeu a força



  4. #5
    silmar
    Só tira a minha duvida ops: 8)
    Por que vocÊ esta querendo ter mais dores de cabeça fazendo isso. ?
    Se as impressoras estão nos computadores XPs então deixe o proprio XP instalar elas .. pois ele tem esse padrão de instalar a impressora sózinho, sendo elas no SO do windows.

    Agora instalando elas no servidor Linux e depois nas outras maquinas ... meu é pedir muito pra cabeça, uma os usuarios não ligao a maquina e mandao imprimir aee chegam na impressora não tem relarório aee vai de novo ..
    E depois da terceira vez ele ja vai te chamar e sabe dores de cabeça ... aee até vc descobrir que a merda do cara da impressora nao veio e ou que nao ligou o micro. ah meu vai longe ...

    Tudo porque voce quer reiventar a roda

    Essa é minha ideia de Adm de Rede
    Espero que não fique furioso .. isso o que te passo é uma autocritica ...






Tópicos Similares

  1. Alguem Ja Teve esse Problema com Rocket M5???
    Por zanettemt no fórum Redes
    Respostas: 12
    Último Post: 02-06-2012, 21:50
  2. Alguem já teve esse problema ??????
    Por Elo no fórum Redes
    Respostas: 1
    Último Post: 07-03-2008, 07:38
  3. Será que mais ninguem teve esse problema com o SAMBA?
    Por centralservice no fórum Servidores de Rede
    Respostas: 9
    Último Post: 19-07-2005, 10:57
  4. Respostas: 9
    Último Post: 23-01-2003, 18:07
  5. Respostas: 10
    Último Post: 23-01-2003, 04:34

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L