+ Responder ao Tópico



  1. #1
    Visitante

    Padrão prob com a lmlib2

    pessoal estou tentando instalar o Eterm no meu micro e baxei e instalei as dependencia numa boa soh essa imlib2 q tah me dando dor de kbça tipo eu baxei dei o configure ai na hr do make ele me das essas msgs

    # make
    make all-recursive
    make[1]: Entering directory `/tmp/imlib2-1.1.2'
    Making all in src
    make[2]: Entering directory `/tmp/imlib2-1.1.2/src'
    /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I.. -I../src -I../src -I../loaders -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/local/include -I/usr/local/include -g -O2 -c scale.c
    gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I.. -I../src -I../src -I../loaders -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/local/include -I/usr/local/include -g -O2 -c scale.c -fPIC -DPIC -o .libs/scale.o
    In file included from colormod.h:12,
    from scale.c:2:
    image.h:9:65: ltdl.h: No such file or directory
    In file included from colormod.h:12,
    from scale.c:2:
    image.h:117: error: parse error before "lt_dlhandle"
    image.h:117: warning: no semicolon at end of struct or union
    image.h:125: error: parse error before '}' token
    make[2]: ** [scale.lo] Erro 1
    make[2]: Leaving directory `/home/noturno/imlib2-1.1.2/src'
    make[1]: ** [all-recursive] Erro 1
    make[1]: Leaving directory `/home/noturno/imlib2-1.1.2'
    make: ** [all-recursive-am] Erro 2



    mas como naum tem um erro especifico eu naum faço a menor ideia do q seja ja olhei os logs tb naum me mostram nada eu to usando o slack 10.1 com kernel 2.4.29

  2. #2

    Padrão prob com a lmlib2

    opa desculpa eskeci de logar ops: ops: ops:



  3. #3

  4. #4

    Padrão prob com a lmlib2

    glr consegui resolver....

    naum fiz nd soh reinstalei meu slack do memso geito da anterior tentei recompilar e foi d boa



  5. #5

    Padrão prob com a lmlib2

    O Eterm precisa do imlib2 e da libast para funcionar.
    Eu tenho os pacotes tgz deles aqui.

  6. #6

    Padrão prob com a lmlib2

    Citação Postado originalmente por Skorpyon
    O Eterm precisa do imlib2 e da libast para funcionar.
    Eu tenho os pacotes tgz deles aqui.

    putz cara eu resolvi e tb ja guardei um bkp dos tgz deles...o negocinho q me enxeu a paciencia... mas se vc tiver o tgz do apollon (o resto dos pcts eu ja consegui compilar) eu agradeceria mto mesmo



  7. #7

    Padrão prob com a lmlib2

    Eu nao uso o apollon, uso o giFTCurs.
    Prefiro programas em modo texto.

    De uma olhada no artigo que escrevi sobre o giFT
    https://under-linux.org/noticia4873.html

    Da uma olhada no linuxpackages.net para ver se acha os pacotes.
    Tem também o gifToxic, que é também grafico.

    Qualquer duvida, posta ae novamente.

  8. #8

    Padrão prob com a lmlib2

    Citação Postado originalmente por Skorpyon
    Eu nao uso o apollon, uso o giFTCurs.
    Prefiro programas em modo texto.

    De uma olhada no artigo que escrevi sobre o giFT
    https://under-linux.org/noticia4873.html

    Da uma olhada no linuxpackages.net para ver se acha os pacotes.
    Tem também o gifToxic, que é também grafico.

    Qualquer duvida, posta ae novamente.
    nossa manu jah foi moh confusao para usar o apollon eu tive q tirar o icone e colocar o do kazza p minha mae aprender a mexer...ai eu preferia o apollon mesmo...vo continuar tentando axo q eh pau no compilador isso...vamu v no dah dps eu posto ai o resultado



  9. #9

    Padrão prob com a lmlib2

    Achei uns rpms do apollon
    http://www.rpmfind.net/linux/rpm2htm...submit=Search+...

    Depois converte ele pra tgz e instala normal ae.

    Fazendo umas buscas achei um tal de giFTui, ele tem uma interface bastante amigavel pelo que vi nos screenshots. Testa ae se o apollon não der certo.
    http://giftui.sourceforge.net/

  10. #10
    Spyderlinux_adm
    Visitante

    Padrão Essa lib tem no site para baixar.

    www.linuxpackages.net/packages.php


    somente insira o nome imlib2 o link para baixar ta aqui ó

    http://www.linuxpackages.net/search_...me=imlib2&ver=

    Abraço

    Não precisa recompilar nada. Somente loga como root e faça

    installpkg imlib2.x.x.x.x.x.
    após instalar updatedb para atualizar as bibliotecas. Só

    Abraço

    Spyderlinux



  11. #11

    Padrão prob com a lmlib2

    glr desculpa a ausencia eu voltei esse topico soh p agradecer aos envolvidos e passar a solução....
    o prob foi q na instalação do meu slack eu naum instalei uma lib a expat ai tds deram erro o .run o tar.gz o rpm tds davam o mesmo erro ei fui fuçar n so memso e descobri q naum tinha instalado essa lib.... :toim: :toim: :toim:

    valeu mesmo glr t+