+ Responder ao Tópico



  1. #1
    whinston
    Galera, penei pra por o openswan no ar:
    https://under-linux.org/modules.php?...wtopic&t=32744

    Ativei o modo debug e vi que agora está conectando, mas não está pingando do outro lado. Sempre trabalhei com VPNs de uma forma que se criava uma interface virtual (tapx) e um ip virtual para VPN (192.168.254.x), de forma que era mais fácil fazer as rotas e tal.

    No IpSEC o conceito é um pouco diferente e não estou sabendo como fz pra um lado enxergar o outro. Que gateway devo colocar?

    Supondo que eu tenha:

    LEFT
    IP real: 200.1.1.100
    IP lan: 192.168.0.1
    LAN: 192.168.0.0
    Gateway (modem): 200.1.1.1

    RIGHT
    IP real: 200.2.2.100
    IP lan: 192.168.1.1
    LAN: 192.168.1.0
    Gateway (modem): 200.2.2.1

    O nexthope seria o modem ? Pelo que eu li na NET, sim, mas não está pingando.

    Meus firewall tem política drop, mas limpei as regras para testar, deixando apenas um FORWARD e Postrouting e nada.

    Alguém tem alguma dica ?

  2. bem.. que me lembre vc pinga apenas de Lan para Lan e não (DENTRO DO TÚNEL) para o modem. Os gateway vão pingar-se, mas ñão estarão no túnel. U'a máquina, a partir da Lan, pode pingar qualquer coisa, mas será pelo NAT e por fora do túnel.

    Resumo: o ping é de LAN para LAN, se por dentro do túnel.

    BTW (risos).. sugiro ir logo pro FreeBSD, onde o IPSec é nativo, MUITO mais antigo e já bem consolidado. Pra ver: até eu faço VPN's com êle.. ah - não conheço, mas ouço falar bem - vc pode experimentar também o OpenVPN que, salvo engano, é baseado em SSL.
    :twisted:



  3. #3
    whinston
    mas não é apenas o ping cara..
    tipo..

    192.168.0.1 (LAN) - 10.0.0.1 --- INTERNET --- 10.0.0.2 - (LAN) 192.168.1.1

    as máquinas do lado esquerdo (192.168.0.0) tem que acessar as máquinas do lado direito (192.168.1.0) passando por dentro do túnel.

  4. mano.. isso é EXATAMENTE o que se espera de uma VPN, portanto vc não está dizendo nada de novo. O seu túnel (possívelmente) não exista, ou não está trocando as chaves de cripto ou.. enfim: a sua VPN não tá funcionando. Ethereal pode auxiliar.






Tópicos Similares

  1. Conecta mas não pinga
    Por diegofeller no fórum Redes
    Respostas: 2
    Último Post: 21-12-2009, 11:24
  2. Conecta mas não pinga
    Por lfernandosg no fórum Redes
    Respostas: 2
    Último Post: 05-03-2009, 08:16
  3. Velox conecta, mas não pinga nem abre sites
    Por ScarSource no fórum Servidores de Rede
    Respostas: 8
    Último Post: 08-08-2006, 12:45
  4. conecta mas nao navega conectiva8???
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-09-2003, 23:42
  5. conecta ma nao navega??
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-09-2003, 09:47

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L