Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola pessoal estou com um problema que esta me causando um transtorno imenso ....

    Fiz a migração da Versão 2.0 do samba para a 3.0 feito isso o samba esta funcionando normalmente se nao fosse por um detalhe...

    Quando tenho um compartilhamento que apenas um determinado usuario tem acesso e outro usuario tenta acessar, o arquivo smbpasswd fica da seguinte forma:

    admin:501:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU ]:LCT-00000000:Administrador do Sistema

    Li na documentação do Samba que quando um usuario nao tem senha ele seta estes caracteres no smbpasswd.

    Quando entro via console e digito:
    smbpasswd -e admin

    O usuario volta ao normal, se tento fazer um acesso a uma pasta que ele não tem permissão os caracteres "X" voltam....

    Ja estou ficando louco por isso !!! Alguém teria alguma luz para me ajudar !!!

    Agradeço desde já !!!!! :toim:

  2. #2
    X-LOGAN
    Vc ja tentou reinstalar o samba, as vezes é algum bug dessa versão, pq isso é meio anormal acontecer!!!



  3. Cara eu fiz por validação de usuários tipo valid user = test, teste, teste1
    tenta ai derepente da certo la no seu smb.conf

  4. Cara então ja reinstalei .... mas o erro continua !!!!!

    Galera segue meu smb.conf para ser analisado... COMO EU DISSE ESTA FUNCIONANDO DIREITINHO APENAS QUANDO UM USUARIO TENTA ACESSAR UM COMPARTILHAMENTO QUE ELE NAO POSSUI ACESSO .. ELE E DESABILITADO

    :toim: TO FICANDO DOIDO !!!


    [global]

    time server = yes
    workgroup = WORKGROUP
    null passwords = no
    server string = Servidor de arquivos
    interfaces = eth0
    bind interfaces only = Yes
    wins support = yes
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 0
    panic action = /usr/share/samba/panic-action %d
    security = user
    encrypt passwords = true
    smb passwd file = /etc/samba/smbpasswd
    guest account = nobody
    invalid users = root
    map to guest = Bad user
    unix charset = iso8859-1
    display charset = cp850
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    local master = yes
    domain master = yes
    preferred master = yes
    os level = 65
    #============================ Share Definitions ==============================
    [web]
    comment = Area de compartilhamento WEB
    path = /shares/disc0/web
    browseable = yes
    printable = no
    public = no
    create mask = 0664
    directory mask = 0775
    valid users = +webmaster
    write list = +webmaster
    [suporte]
    comment = Aberium
    path = /shares/disc0/suporte
    browseable = yes
    printable = no
    public = no
    create mask = 0664
    directory mask = 0775
    valid users = +suporte
    write list = +suporte


    AJUDEM-ME!!!!



  5. #5
    X-LOGAN
    Vc falou que quando um usuário não cadastrado para aquele compartilhamento acha que pode e tenta entrar na pasta ai ele e desconfigurado do samba?
    Sera que não é uma "proteção" do novo samba, que eu ainda não mexi muito nessa nova versão.
    Todas as estações são WIn XP?






Tópicos Similares

  1. problema com Samba PDC ao adicionar usuario
    Por Grejao no fórum Servidores de Rede
    Respostas: 2
    Último Post: 21-12-2004, 16:25
  2. Problemas com Samba que fica com "pid´s em aberto
    Por GSEngelmann no fórum Servidores de Rede
    Respostas: 3
    Último Post: 11-03-2003, 10:47
  3. Problemas com Samba que fica com "pid´s em aberto
    Por GSEngelmann no fórum Servidores de Rede
    Respostas: 0
    Último Post: 10-03-2003, 19:21
  4. Problemas com Samba que fica com "pid´s em aberto
    Por GSEngelmann no fórum Servidores de Rede
    Respostas: 0
    Último Post: 10-03-2003, 19:19
  5. problema com Samba
    Por no fórum Servidores de Rede
    Respostas: 8
    Último Post: 25-12-2002, 10:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L