+ Responder ao Tópico



  1. #1
    estudante
    Senhores

    A minha situação hoje é a seguinte:

    Tenho um site hospedado num provedor.
    Tenho uma conexão com a internet via cabo banda larga através de NAT sendo meu ip 200.142.xxx.yyy Fixo e administrado por mim.

    Montei internamente um servidor web/apache
    Este servidor terá a única função de armazenar fotos e vídeos disponibilizando para o meu site.

    Na prática é o seguinte:

    Acessarei o meu site www.meusite.com.br que está no porvedor pórém na página onde estiver fotos e vídeos apontarei para o meu servidor web/apache que montei e que tem o IP 200.142.xxx.yyy

    Qual é o meu problema?

    Bem, como todos os meus micros da rede acessam a internet por NAT usando o mesmo IP do meu web/apache 200.142.xxx.yyy não consigo então acessar as fotos e os vídeos que estão no site apontando para o meu web/apache por se tratar do mesmo ip que estou utilizando para acessá-lo.

    É claro que se eu quiser acessar as imagens estando na empresa eu não preciso ir ao meu site nasta eu acessá-lo pelo ip interno só que o meu site é utilizado tanto para os de fora quanto para os de dentro da empresa portanto preciso achar alguma solução que permita que tanto fora da empresa com dentro dela eu possa acessar o meu site da mesma forma em ambos os casos.

    Por favor alguém tem alguma solução/idéia?

  2. Cara da rede externa acessa normal as fotos e videos?? se sim ta ok pq da rede interna vc nao vai conseguir pois a maioria dos provedores ou modem ae depende da sua conexão impede a volta do trefego, pois eh uma brecha de segurança, eh meio complicado a ideia mas se vc tem um nat quando tenta acessar o mesmo ip da erro nao consegue, o que voce teria de ter eh outro ip para o nat e um ip pra essas fotos.

    falows



  3. #3
    estudante
    ruyneto

    primeiramente obrigado.

    De fato, eu já estava sabendo desta situação porém como o mundo da informática tem sempre os seus macetes e ou ferramentas e o universo linux não fica atras então resolvi colocar na comunidade tal problema na espectativa de surgir algo que manobre esta situação.

    Vou aguardar mais um pouco para ver se surge alguma luz senão terei realmente que partir para outro IP.

    Obrigado novamente.






Tópicos Similares

  1. Sites param de abrir no provedor mas nao é DNS
    Por ricardoav5 no fórum Redes
    Respostas: 1
    Último Post: 02-08-2011, 20:23
  2. Provedor com precos de VARPHONEX mas com servidor no Brasil
    Por FabricioViana no fórum Servidores de Rede
    Respostas: 4
    Último Post: 17-06-2007, 17:33
  3. Palm sincroniza no kpilot mas não sincroniza no pilot
    Por vonlinkerstain no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 07-10-2005, 06:05
  4. ter autenticação no squid, mas não num determinado site
    Por quecosuix no fórum Servidores de Rede
    Respostas: 1
    Último Post: 25-03-2005, 21:08
  5. DWL-810+ funciona no AP1000 mas não funciona no AP2000
    Por denilson_rocha no fórum Redes
    Respostas: 4
    Último Post: 12-11-2004, 16:52

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L