Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal tudo bem?
    Compilei o postgres do 0 e ele está apresentando o seguinte erro
    postgres@fernando:/etc/init.d$ createdb dirceu
    createdb: não pôde conectar ao banco de dados template1: não pôde conectar ao servidor: lÔ)@(÷%@
    O servidor está rodando localmente e aceitando
    conexões no conector (socket) de domínio Unix "/var/run/postgresql/.s.PGSQL.5432"?

    Procurei isto do google e dizem que ou é por queo usuário em questão não é o owner do banco de dados (que não é o meu caso), ou é que o server não foi inicializado corretamente, iniciei-o com as instruções do arquivo INSTALL do diretório postgres, ou poder ser regras de firewall, já derrubei todas elas nesta máquina...

    O que mais pode ser?

    Abraços
    Dirceu

  2. voce tem q dar o initdb...

    exemplo

    initdb -D /usr/local/pgsql

    6)



  3. Então, eu já fiz isto...
    Como consta no arquivo INSTALL do diretório do postgres...
    Código :
    postgres@fernando:/etc/postgresql$ /usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
    The files belonging to this database system will be owned by user "postgres".
    This user must also own the server process.
     
    The database cluster will be initialized with locale pt_BR.
    The default database encoding has accordingly been set to LATIN1.
     
    creating directory /usr/local/pgsql/data ... ok
    creating directory /usr/local/pgsql/data/global ... ok
    creating directory /usr/local/pgsql/data/pg_xlog ... ok
    creating directory /usr/local/pgsql/data/pg_xlog/archive_status ... ok
    creating directory /usr/local/pgsql/data/pg_clog ... ok
    creating directory /usr/local/pgsql/data/pg_subtrans ... ok
    creating directory /usr/local/pgsql/data/base ... ok
    creating directory /usr/local/pgsql/data/base/1 ... ok
    creating directory /usr/local/pgsql/data/pg_tblspc ... ok
    selecting default max_connections ... 100
    selecting default shared_buffers ... 1000
    creating configuration files ... ok
    creating template1 database in /usr/local/pgsql/data/base/1 ... ok
    initializing pg_shadow ... ok
    enabling unlimited row size for system tables ... ok
    initializing pg_depend ... ok
    creating system views ... ok
    loading pg_description ... ok
    creating conversions ... ok
    setting privileges on built-in objects ... ok
    creating information schema ... ok
    vacuuming database template1 ... ok
    copying template1 to template0 ... ok
     
    WARNING: enabling "trust" authentication for local connections
    You can change this by editing pg_hba.conf or using the -A option the
    next time you run initdb.
     
    Success. You can now start the database server using:
     
        /usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data
    or
        /usr/local/pgsql/bin/pg_ctl -D /usr/local/pgsql/data -l logfile start

  4. #4
    Kablu
    Pode ser que vc não tenha essa base template1...

    Vc tem que ter uma base válida para conectar o postgres... ele copia a template1 para sua base que vc quer criar...

    Abraço :good:



  5. E como eu crio esta base template1?


    Só achei estranho isto daqui:
    Código :
    vacuuming database template1 ... ok
    copying template1 to template0 ... ok






Tópicos Similares

  1. erro ao criar banco no PostrgeSQL
    Por Wronieri no fórum Servidores de Rede
    Respostas: 8
    Último Post: 17-11-2004, 17:55
  2. erro ao conectar banco de ddos no firebird
    Por Wronieri no fórum Servidores de Rede
    Respostas: 4
    Último Post: 25-10-2004, 06:53
  3. Erro ao criar disco de Boot com o Gerenciador GRUB
    Por ricardodru no fórum Servidores de Rede
    Respostas: 3
    Último Post: 16-12-2003, 10:27
  4. Erro ao criar disco de Boot com o Gerenciador GRUB
    Por ricardodru no fórum Servidores de Rede
    Respostas: 0
    Último Post: 15-12-2003, 19:45
  5. criar banco de dados
    Por ediguedes no fórum Servidores de Rede
    Respostas: 3
    Último Post: 28-11-2002, 19:40

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L