Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Putz, estou tendo problemas com o apche e o qmail, assim
    tenho o qmailadmin e vqadmin (.cgi)

    criando no apache apenas o diretorio da certo, eu acesso http://192.168.1.1/cgi-bin/vqadmin/vqadmin.cgi e da tudo ok

    tenho que digitar /vqadmin.cgi no final, ja adicionei vqadmin.cgi la na lista de index e tal, mas nao adianta, tenho que digitar o nome do arquivo de qualquer forma.

    e outro problemas é que quando crio um virtual host pra ele, ai nao abre mais, quando acesso pelo browser ele quer fazer download do arquivo!

    e mais, só de eu criar um virtual host, que como ja disse nao funciona ai quando eu acesso ele (http://192.168.1.1/cgi-bin/vqadmin/vqadmin.cgi) ja nao aparece mais as figuras, abre o site, eu trabalho normal, mas as figuras nao aparecem mais.

    que será??

    desde ja agradeço, obrigado a todos.
    Fernando.

  2. bom, o maior problema pra mim é o fato de ao invés do nagegador abrir o arquivo (vqadmin.cgi e qmailadmin) ele quer fazer download.
    por favor me ajudem a resolver isso...
    lembrando que eu ja coloquei os arquivos na lista de DirectoryIndex e nao adianta....

    por favor, me ajudem...
    Fernando.



  3. #3
    CLEOCIR
    Pelo que me parece o apache não está executando os teus arquivos .CGI por algum erro na configuração do diretório e alias do "CGI".

    Dá uma revisada no arquivo de configuração do apache (httpd.conf) nas linhas que falam do cgi e verifique se o Alias e o Diretório está correto.

    No meu caso, tenho assim:

    -----------

    # ScriptAlias: This controls which directories contain server scripts.
    # ScriptAliases are essentially the same as Aliases, except that
    # documents in the realname directory are treated as applications and
    # run by the server when requested rather than as documents sent to
    # The same rules about trailing "/" apply to ScriptAlias directives as to
    # Alias.
    #
    ScriptAlias /cgi-bin/ "/home/www/cgi-bin/"

    #
    # "/var/www/cgi-bin" should be changed to whatever your ScriptAliased
    # CGI directory exists, if you have that configured.
    #
    <Directory "/home/www/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    ---------------

    No meu caso, todos os meus arquivos .CGI ficam no diretório "/home/www/cgi-bin". Adapte as linhas conforme o seu caso.

    Cleocir.

  4. obrigado pela atenção, mas estas configurações estão corretas,
    no httpd.conf eu descomentei essa linha:
    AddHandler cgi-script .cgi
    ai o vqadmin deu certo, mas o qmailadmin continua querendo fazer o download do arquivo...

    obrigado.
    Fernando



  5. #5
    CLEOCIR
    E ambos os arquivos (qmailadmin e vqadmin) estão no mesmo diretório ?






Tópicos Similares

  1. Qmail
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-08-2002, 22:39
  2. Redirecionamento com apache
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 04-08-2002, 15:24
  3. Qmail - So recebe mensagems - usuario@host.dominio.com.br
    Por ebortolin no fórum Servidores de Rede
    Respostas: 0
    Último Post: 31-05-2002, 16:57
  4. qmail
    Por edlazaro no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-04-2002, 23:50
  5. Mod_SSL No apache 2.0.36
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-04-2002, 01:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L