+ Responder ao Tópico



  1. #1

    Padrão Estacao nao Navega

    Ae Galera Seguinte,
    Minha rede ta estranha nao ta navegando se nao tiver o squid.. Email, Msn, etc.. nao funciona.

    Minhas Chain no Iptables ta Tudo ACCEPT
    Ta sem nenhuma protecao so com nat

    Chain POSTROUTING (policy ACCEPT)
    target prot opt source destination
    MASQUERADE all -- 10.0.0.0/24 anywhere

    /proc/sys/net/ipv4/ip_forward ta = 1

    Alguem sabe o q posso fazer
    no Servidor Funciona tudo bunitinhu... so nao pinga a propria placa de rede mais o router pinga.. mesma coisa as estacoes nao tao pingando o servidor e nem paginas de fora..

    Agradeco
    Vlw

  2. #2
    felco
    Visitante

    Padrão Estacao nao Navega

    Deve se o cabo de rede... ou sua placa de rede mesmo... mas estranho voce nao consegue pingar o proprio IP?



  3. #3

    Padrão Estacao nao Navega

    Ae Consigo Pingar o Ip externo sim!
    A rede funciona Normal so a internet sem SQUID que nao funciona!

    to achando estranho essa msg no syslog

    Aug 15 17:44:08 kernel: MASQUERADE: No route: Rusty's brain broke!

  4. #4

    Padrão Re: Estacao nao Navega

    Parece que a sua regra de MASQUERADE ta meio estranha, bota essas regras abaixo e posta o resultado, lembrando que vc deve fazer o nat em cima da interface ligada a internet !!!

    iptables -t nat -A POSTROUTING -o ethx -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward


    Valeu !!!



  5. #5

    Padrão Estacao nao Navega

    No Começo da msg ja coloquei q o
    /proc/sys/net/ipv4/ip_forward ta = 1
    foi primeira coisa q verifiquei
    e o codigo q eu uso eh
    $IPT -A POSTROUTING -t nat -d 0/0 -s 10.0.0.0/24 -j MASQUERADE
    Sempre funciono!!
    Queria saber o q significa
    MASQUERADE: No route: Rusty's brain broke!
    pq antes aparecia
    MASQUERADE: Route sent us somewhere else.

    Vlw

  6. #6
    drginfo
    Visitante

    Padrão Estacao nao Navega

    Geralmente a regra é:

    iptables -t nat -A POSTROUTING -s 10.0.0.0/24 - j MASQUERADE

    e não:
    iptables -A POSTROUTING -t nat -d 0/0 -s 10.0.0.0/24 - j MASQUERADE

    ou seja vc deve especificar primeiro a tabela depois a chain, por isso que está dando erro no masquerade.



  7. #7
    Visitante

    Padrão Estacao nao Navega

    Ih Mesma coisa cara...
    antes funcionava..
    Mais coloquei pra ve e nao deu
    seguinte eu recompilei o kernel sera q eskeci de alguma coisa por issu q nao ta funcionando?
    Se sim o q vcs acham q podem ter faltado...

    Flw

  8. #8
    drginfo
    Visitante

    Padrão Estacao nao Navega

    qual versão do kernel?
    qual sua distribuição?
    qual a versão do iptables?
    posta isto aí, pois algum tempo atrás tive problemas no masquerade do iptables que não funcionava, aí voltei para a versão anterior e tudo voltou ao normal....

    verifica se é o teu caso.