+ Responder ao Tópico



  1. O meu proxy estava funcionando 100% inclusive barrando o MSN , ai mudei o script do firewall para aumentar a segurança. Consigo navegar na web mas o encaminhamento para o proxy parou , sei disso pois tail -f access.log nao mostra mais nada e sites que antes estavam bloqueados passam direto, dei uma vacilada e sobrescrevi o script que funcionava por esse, vc poderia ver o que esta de errado , ja li e reli e nao vejo nada, tirei esse script aqui do site

    #!/bin/sh

    echo "Ativando o firewall..."

    # variaveis onde IFINT é o IP da rede interna
    IFINT='10.0.10.0/24'
    ETH_LOCAL='eth1'
    ETH_SAIDA='eth0'

    # mesmo estando ativado o encaminhamento confirma
    #echo 1 > /proc/sys/net/ipv4/ip_forward

    # carrega o modulo nat
    modprobe iptable_nat

    # limpa
    iptables -F
    iptables -t nat -F
    iptables -t nat -P POSTROUTING DROP

    # Ativando o proxy transparente
    iptables -t nat -A PREROUTING -i $ETH_LOCAL -s $IFINT -p tcp --dport 80 -j REDIRECT --to-port 3128

    # Ativando mascaramento para determinadas portas
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p icmp -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 110 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 110 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 25 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 25 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 80 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 80 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 3128 -j ACCEPT
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 53 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 53 -j ACCEPT
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 53 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 53 -j ACCEPT
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport https -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport https -j MASQUERADE

    echo "Firewall carregado."

  2. #2
    pilantrox
    vc verificou se o seu squid esta com processo ativo???

    ps -ax |grep squid


    Citação Postado originalmente por alimasilva
    O meu proxy estava funcionando 100% inclusive barrando o MSN , ai mudei o script do firewall para aumentar a segurança. Consigo navegar na web mas o encaminhamento para o proxy parou , sei disso pois tail -f access.log nao mostra mais nada e sites que antes estavam bloqueados passam direto, dei uma vacilada e sobrescrevi o script que funcionava por esse, vc poderia ver o que esta de errado , ja li e reli e nao vejo nada, tirei esse script aqui do site

    #!/bin/sh

    echo "Ativando o firewall..."

    # variaveis onde IFINT é o IP da rede interna
    IFINT='10.0.10.0/24'
    ETH_LOCAL='eth1'
    ETH_SAIDA='eth0'

    # mesmo estando ativado o encaminhamento confirma
    #echo 1 > /proc/sys/net/ipv4/ip_forward

    # carrega o modulo nat
    modprobe iptable_nat

    # limpa
    iptables -F
    iptables -t nat -F
    iptables -t nat -P POSTROUTING DROP

    # Ativando o proxy transparente
    iptables -t nat -A PREROUTING -i $ETH_LOCAL -s $IFINT -p tcp --dport 80 -j REDIRECT --to-port 3128

    # Ativando mascaramento para determinadas portas
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p icmp -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 110 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 110 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 25 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 25 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 80 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 80 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 3128 -j ACCEPT
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 53 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport 53 -j ACCEPT
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 53 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport 53 -j ACCEPT
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p tcp --dport https -j MASQUERADE
    iptables -t nat -A POSTROUTING -s $IFINT -d 0/0 -p udp --dport https -j MASQUERADE

    echo "Firewall carregado."



  3. resolvi o problema :toim: , o ps mostrava o squid rodando, o problema estava mesmo no script de firewall, substitui por outro das organizaçoes Tabajara e MEUS PROBLEMAS ACABARAM :P






Tópicos Similares

  1. Respostas: 24
    Último Post: 12-10-2015, 19:05
  2. Como fazer esquema de horarios para web-proxy
    Por igornunes no fórum Redes
    Respostas: 3
    Último Post: 19-05-2010, 18:55
  3. QMail parou de enviar para Terra e UOL
    Por Edilmar no fórum Servidores de Rede
    Respostas: 2
    Último Post: 27-04-2007, 08:23
  4. Respostas: 0
    Último Post: 31-07-2006, 12:56
  5. Por Favor estou a ponto de surtar !!!
    Por Germano_Silva no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-10-2003, 21:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L