+ Responder ao Tópico



  1. #1

    Padrão user acessar partição reiserfs...

    Oi pessoal, meu problema é o seguinte: adicionei um novo HD e fiz várias partições, uma delas em reiserfs para guardar meus arquivos. No /etc/fstab ela está listada assim:

    /dev/hdb2 /mnt/hdb2 reiserfs noauto,users,exec 0 0

    Dei também esse comando no ponto de montagem com ela montada:

    chmod -R 766 /mnt/hdb2 (como root)

    Só que ela só quer ser lida e escrita pelo root (consigo montá-la como user). O que devo fazer para que outros users tenham este privilégio?

    Obrigado!

  2. #2

    Padrão user acessar partição reiserfs...

    Tive o mesmo problema a um tempo atraz e nao consegui resolver



  3. #3

    Padrão user acessar partição reiserfs...

    Agora vc me desanimou...

    hehehe

    Poxa cara, isso não é possível. Tem algo estranho em alguma configuração do sistema. O problema é saber onde.

    Bom, vou esperar mais um pouco pra ver se alguém aparece com uma solução.

  4. #4

    Padrão user acessar partição reiserfs...

    Eu tenho um segundo HD e uso ele apenas para guardar arquivos.
    Ele estava com sistema de arquivos fat, quando passei ele para reiserfs, eu nao conseguia mais escrever nele como usuario, apenas como root.
    Testei varias opções no fstab mas nao consegui de modo algum escrever nele como usuario normal.
    Depois disso desisti e voltei ele para fat.



  5. #5

    Padrão user acessar partição reiserfs...

    não pode ter haver com o owner e group da pasta onde foi montada a partição ?? ou ao invés de usar 766 usar 776 ? (embora acredite que ja tenham tentado utilizar até chmod 777 hehehe)

  6. #6
    sambaloco40
    Visitante

    Padrão umask

    ja tive problemas semelhantes com fat32, mas com reiserfs nunca ouvi falar... mudando as permissoes dos arquivos vc consegue acessar? se naum funcionar tente setar no fstab um umask (importante: isto pode permitir que todo mundo mexa nos arquivos, escolha uma mascara correta)



  7. #7

    Padrão user acessar partição reiserfs...

    Achei a solução:

    Quando está em fat funciona pq em fat a partição e os arquivos contidos nela não levam permissões, pois esse sistema de arquivos não tem suporte a isso. Já em reiserfs há suporte a permissões e a permissão padrão deixa o diretório de montagem com permissões de acesso apenas ao root. Tentei mudar isso para 776, mas o diretório precisa do "x" para ser acessado e não só do "r", como eu pensava.

    Para resolver é só deixar as permissões em 777 ou mudar o dono e/ou grupo do diretório.

    Dando permissão:

    chmod 777 /mnt/ponto_de_montagem

    Mudanto grupo e dono:

    chown dono.grupo /mnt/ponto_de_montagem

    Quanto a setar o umask em /etc/fstab, não dá certo comigo. Volta o erro abaixo:

    mount: wrong fs type, bad option, bad superblock on /dev/hdb2, or too many mounted file systems

    Não sei se isso tem a ver com a versão do mount, mas comigo não dá.