Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Estou precisando alterar as minhas placas de rede, ou seja, gostaria que o módulo e as configurações da eth0 fossem para eth1 e vice-versa.

    Alguém pode dar um help? Há muot tempo atrás já fiz isso bem facinho, mas não me recordo. Era algum arquivo com alias... mas naum lembro.

    Desde já agradeço qq. ajuda,

    Abraços.

  2. #2
    Celso_Suzuki
    Se as placas forem diferentes, mude o alias em /etc/modules.conf ou /etc/conf.modules.
    Se as placas forem iguais aí complica. Se não me engano voce pode fixar o MAC no ipcfg-etX no /etc/sysconfig/network-scripts.



  3. Bem... eu não sei quanto as outras distros, ha muito eu uso o Debian e acabei me esquecendo como é (péssimo habito).

    Mas acredito que se não for igual é muito parecido.

    é só você trocar as informações em /etc/network/interfaces (isto no debian!)
    Código :
    iface eth0 inet static
            address 192.168.1.2
            netmask 255.255.255.0
            broadcast 192.168.1.255
            dns-nameservers 127.0.0.1
            dns-search DOMINIO
            # dns-* options are implemented by the resolvconf package, if installed
     
    iface eth1 inet static
            address 10.10.1.3
            netmask 255.255.255.0
            broadcast 10.10.1.255
            dns-nameservers 127.0.0.1
            dns-search DOMINIO
            gateway 192.168.1.1

    É só você trocar as informações, por o gateway em qual iface você quer.

    ATENÇÃO!

    Talvez você precise fazer alterações em seu firewal!


    ai é só
    Código :
    $ ifdown eth0
    $ ifup eth0
    $ ifdown eth1
    $ ifup eth1

    Mais uma vez, isto é no Debian.

    Se não me engano ele já ajeita as rotas, mas não custa nada verificar
    Código :
    netstat -nr

    Talvez seja mais fácil você inverter os cabos... :P

    Qualquer coisa posta ai.

    []'s

  4. Qual distro ???



  5. Pessoal, na nossa rede temos o servidor para internet usando o Conectiva 8.
    No arquivo modules.conf está assim :
    alias eth0 3c59x
    alias eth1 3c59x
    alias eth2 3c59x

    Ou seja, as 3 placas são 3Com e funcionam perfeitas a 3 anos.
    Hoje estou terminando de instalar um novo servidor para internet usando o Slackware 10.1 e no arquivo rc.modules descomentei a linha onde carrega as placas 3com e fui no arquivo modules.conf e fiz a mesma coisa. Coloquei uma placa primeiro e dava boot no Slackware. Olhava a carga do sistema. Via como estava carregado a placa de rede. Configurei a dita cuja e Ok. Coloquei a segunda placa, fazia o mesmo procedimento. Carreguei a terceira e perfeito.
    Está funcionando perfeito. E outra coisa : Fiz por experiência e insistência de um colega que usa o SuSE 9.3 e também funcionou ok.
    Não sei se é isso o tópico.
    Inté + ........ :good:






Tópicos Similares

  1. Coisa de outro planeta (eth0 e eth1)
    Por jiraya no fórum Servidores de Rede
    Respostas: 7
    Último Post: 05-05-2005, 17:09
  2. NS da placa eth0 ou eth1
    Por mbtec no fórum Servidores de Rede
    Respostas: 2
    Último Post: 10-01-2005, 17:37
  3. identificando fisicamente qual placa eh ETH0 e ETH1
    Por danillorios no fórum Servidores de Rede
    Respostas: 8
    Último Post: 15-12-2004, 08:49
  4. Roteador simples eth0 e eth1 sem internet
    Por WebMic no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-03-2004, 13:47
  5. eth0 e eth1, ambas Realtek. A configurada como Dhcp falha, a
    Por LinuxAthos no fórum Servidores de Rede
    Respostas: 8
    Último Post: 18-08-2003, 15:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L