Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    tombs
    Bom, minha maquina tem 2 hd's, e precisei instalar o xp no hdb, mas aconteceu alguma coisa com o mbr, ja me deu muito trabalho para recuperar o grub. Ja tentei algumas coisas mas nada fez o xp bootar. Li alguns tutoriais tbem, mas nao encontro nada que diga sobre dual-boot com 2 hd's sendo que o xp esta no slave.(inclusive ja tentei mudar o jumper). O problema é que me parece que tem que ser feito alguma coisa para fazer o xp pensar que esta no hd master.Meu menu.lst esta assim:
    title Debian GNU/Linux, kernel 2.6.8-2-k7
    root (hd0,0)
    kernel /vmlinuz-2.6.8-2-k7 root=/dev/hda6 ro
    initrd /initrd.img-2.6.8-2-k7
    savedefault
    boot

    title Debian GNU/Linux, kernel 2.6.8-2-k7 (recovery mode)
    root (hd0,0)
    kernel /vmlinuz-2.6.8-2-k7 root=/dev/hda6 ro single
    initrd /initrd.img-2.6.8-2-k7
    savedefault
    boot

    title Windows XP
    unhide (hd1,0)
    hide (hd0,0)
    rootnoverify (hd1,0)
    chainloader +1
    makeactive
    boot
    -----------------------------------------------------------------
    Se alguem puder me ajudar, agradeco muito

  2. #2
    lhpm
    E ai cara.. blz..
    Cria um disco de inicialização para o Debian e depois com um disco com fdisk, inicia por ele e digita fdisk/mbr ... tenta isso, mas provavelmente seu Debian não vai inicializar, ae vc conserta isto com o disco de inicialização do debian..

    Mas se fosse eu ... EU... 6) tiraria o ruindows.... e ficaria somente com o Debian... (rs)



  3. #3
    n0P
    8) Faltou "mapear" os hds para que o WXP carregue:

    title Windows XP
    rootnoverify (hd0,0)
    makeactive
    map (hd0) (hd1)
    map (hd1) (hd0)

    chainloader +1

  4. #4
    tombs
    Fiz como vc falou (nOP), mas ainda nao foi dessa vez.

    Error 13 : Invalid or unsupported executable format. :toim:
    Pelo menos dessa vez nao perdi o grub.
    Sera que tenho que mexer no jumper?

    Para ter uma ideia, ai vai meu fdisk:
    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 2 16033+ 83 Linux
    /dev/hda2 3 1218 9767520 c W95 FAT32 (LBA)
    /dev/hda3 1219 9729 68364607+ 5 Extended
    /dev/hda5 1219 1279 489951 82 Linux swap / Solaris
    /dev/hda6 1280 3103 14651248+ 83 Linux
    /dev/hda7 3104 9729 53223313+ 83 Linux

    Disk /dev/hdb: 8622 MB, 8622931968 bytes
    255 heads, 63 sectors/track, 1048 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hdb1 * 1 1048 8418028+ 7 HPFS/NTFS

    Trata-se do hdb1. O hda2 nao esta sendo utilizado.



  5. #5
    n0P
    Posta o menu.lst que vc tah usando pra ver se a genmte pode te ajudar melhor...






Tópicos Similares

  1. Dual Boot ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 22-07-2003, 06:45
  2. Perda do dual boot...
    Por Danilo_Montagna no fórum Servidores de Rede
    Respostas: 5
    Último Post: 19-02-2003, 19:13
  3. DUAL BOOT
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-01-2003, 12:45
  4. Dual Boot
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 03-01-2003, 13:50
  5. -- DUAL BOOT -- Ugente !
    Por thiagog no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-09-2002, 11:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L