+ Responder ao Tópico



  1. #1
    hiden
    Visitante

    Padrão squid- não iniciando

    Iai pessoal blz!?

    caras, ja dei uma olhada em umas dez paginas desse forum,(pra num fik colocando topico repetido, neh) mais num axei nda q resolvesse meu problema então resolvi postar...

    configurei o squid desse jeito:

    http_port 3128
    icp_port 3130

    cache_mem 8 MB
    cache_dir ufs /var/spool/squid 100 16 256
    cache_access_log /var/log/squid/access.log

    visible_hostname squid.teste.com.br

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70
    acl Safe_ports port 210
    acl Safe_ports port 1025-65535
    acl Safe_ports port 280
    acl Safe_ports port 488
    acl Safe_ports port 591
    acl Safe_ports port 777
    acl Safe_ports port 901 #SWAT

    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow all
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost

    ai na hora de inicia-lo

    [[email protected]]# /etc/init.d/squid start -z
    init_cache_dir /var/spool/squid... Iniciando squid: .......[FALHOU].....

    alguem sabe o q pode ser???

    desde ja valeu!!!

  2. #2

    Padrão Limpar cache

    Cara, eu não vou lembrar qual era a mensagem de erro que eu tinha, mas eu tive um problema parecido, para resolver eu zerei o cache do squid.



  3. #3

    Padrão squid- não iniciando

    tenta esse tópico

    https://under-linux.org/modules.php?...wtopic&t=34493

    Tive um problema desses. veja se te ajuda a minha solução.

  4. #4

    Padrão squid- não iniciando

    Amigo,
    Olhe também em /var/log/squid/cache.log e /var/log/messages
    Já descobri muitos erros no início porque o nosso squid não carregava.
    Inté ..........



  5. #5
    Super_Diaulas
    Visitante

    Padrão squid- não iniciando

    procure nos logs, lá vai ter mais detalhes que a mensagem FALHOU
    posta aí que o pessoal te ajuda!

  6. #6
    fpmazzi
    Visitante

    Padrão squid- não iniciando

    Eh a primeira vez ke vc ta instalano o squid, pq se for tenta da um squid -z antes de qualquer coisa ....



  7. #7

    Padrão squid- não iniciando

    Galera, aproveitando a deixa , me expliquem por favor esse parâmetro :

    cache_dir ufs /var/spool/squid 100 16 256

    Na empresa onde trabalho, o firewall / squid foi instalado por terceiros a cerca de 3 anos e nesse parametro está assim :

    cache_dir ufs /var/spool/squid 3000 16 256

    Esse 3000 no lugar de 100 (que é o padrão que vem no squid), ajuda, atrapalha ??? Em que isso influencia o desempenho do squid ???

    Desde já fico grato por qualquer explicação .... :good:

  8. #8
    isnard
    Visitante

    Padrão squid- não iniciando

    pssgyn,

    este parâmetro é o tamanho do teu cache em mega bytes, mas acho que isso tu já sabes. Tu tens 3gb de espaço em disco para cache. Se ajuda ou atrapalha? A teoria diz que quanto mais espaço melhor (mais acesso local, menos acesso à Internet), mas claro que depende do teu tamanho de disco e a velocidade de acesso à ele, bem como teu esquema de particionamento e os hábitos dos teus usuáros.
    O que de fato importa é a média de hits que teu cache tem, pois é isso que vai te trazer economia de banda de acesso à Internet.



  9. #9

    Padrão squid- não iniciando

    Obrigado amigo, pelas explicações ........ :clap: :clap: :clap:

  10. #10
    hiden
    Visitante

    Padrão squid- não iniciando

    iae pessoal, valeu pela atençao de todos ai!!

    demorei um pokinho pra posta pq sempre ia para uma outra pag, + blz

    depois de verificar linha por linha pegar manuais, guias, ver em foruns, etc, vi q o squid.conf
    tva configura do certinho e naum sabia pq num tva rodando... (num m lembro direito o erro, mais axu q era q tva sem copia rodando, sei la) resolvi entao copiar o arquivo squid.conf e remover o squid completamente. depois d removido instalei novamente, substitui o arquivo original squid.conf pelo meu e rodou perfeitamente!
    sei q essa não a melhor solução mais no fim das contas foi a mais rapida.

    obs: naum testei mais axu q a dica do nosso amigo fpmazzi (squid -z) talvez resolveria, mais ai eu ja tinha reinstalado td

    valeu!!!



  11. #11
    fpmazzi
    Visitante

    Padrão squid- não iniciando

    oK brother, ficamos contente em ter conseguido resolver o problema com o squid, qualquer coisa post ae ...

  12. #12
    Super_Diaulas
    Visitante

    Padrão squid- não iniciando

    squid -z é para construir/reconstruir o diretório do cache???

    Eu não me lembro,,,acho q era para isso



  13. #13
    fpmazzi
    Visitante

    Padrão squid- não iniciando

    EXATAMENTE zuper...rsrs... o SQUID -Z serve para recontruir e construir os diretorios de cache do squid .....

  14. #14
    Super_Diaulas
    Visitante

    Padrão squid- não iniciando

    YEAHzzzz

    Ponto pra eu!!!!

    uahuahuaa
    akekaekaekae



  15. #15
    fpmazzi
    Visitante

    Padrão squid- não iniciando

    eh isso ae .. kkkkkkkk