+ Responder ao Tópico



  1. #1
    furazoio
    Fala aew manos,

    Tenho um servidor RH enterprise v3, com php 4.3.2, apache 2.0.46 e postgresql v7.3.10, tudo instalado pelo hosting.

    Preciso que o php tenha suporte ao postgresql, para isso será preciso recompilar o php, mas não encontrei
    os fontes do php(4.3.2) que está instalado no servidor, então eu fiz o download da ultima versão do php 4.4.0, descompactei,
    e iniciei o processo de compilação. Utilizei as mesmas flags do php que está instalado no servidor,
    apenas alterando a flag "--with-pgsql", assim seria gerada a SO "pgsql.so" em /usr/lib/php4. Então minhas
    opções de configuração do php foram:

    [root@plesk php-4.4.0]# ./configure --host=i386-redhat-linux --build=i386-redhat-linux --target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../config.cache --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d --enable-force-cgi-redirect --disable-debug --enable-pic --disable-rpath --enable-inline-optimization --with-bz2 --with-db4=/usr --with-curl --with-dom=/usr --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr --with-gd --enable-gd-native-ttf --with-ttf --with-gettext --with-ncurses --with-gmp --with-iconv --with-jpeg-dir=/usr --with-openssl --with-png --with-pspell --with-regex=system --with-xml --with-expat-dir=/usr --with-pcre-regex=/usr --with-zlib --with-layout=GNU --enable-bcmath --enable-exif --enable-ftp --enable-magic-quotes --enable-safe-mode --enable-sockets --enable-sysvsem --enable-sysvshm --enable-discard-path --enable-track-vars --enable-trans-sid --enable-yp --enable-wddx --enable-mbstring --enable-mbstr-enc-trans --enable-mbregex --with-pear=/usr/share/pear --with-imap=shared --with-imap-ssl --with-kerberos=/usr/kerberos --with-ldap=shared --with-mysql=shared,/usr --with-pgsql=/usr/lib/pgsql --with-unixODBC=shared --enable-memory-limit --enable-bcmath --enable-shmop --enable-versioning --enable-calendar --enable-dbx --enable-dio --enable-mcal --with-apxs2filter=/usr/sbin/apxs

    Mas gera o seguinte erro:

    Configuring SAPI modules
    checking for AOLserver support... no
    checking for Apache 1.x module support via DSO through APXS... no
    checking for Apache 1.x module support... no
    checking for mod_charset compatibility option... no
    checking for Apache 2.0 filter-module support via DSO through APXS...

    Sorry, I cannot run apxs. Possible reasons follow:

    1. Perl is not installed
    2. apxs was not found. Try to pass the path using --with-apxs2filter=/path/to/apxs
    3. Apache was not built using --enable-so (the apxs usage page is displayed)

    The output of /usr/sbin/apxs follows:
    ./configure: line 4553: /usr/sbin/apxs: No such file or directory
    configure: error: Aborting


    E a pergunta é, Porque está gerando este erro se é a mesma flag utilizada no php que está instalado no servidor???
    (--with-apxs2filter=/usr/sbin/apxs)

    Procurei por apxs:

    [root@plesk php-4.4.0]# cd /
    [root@plesk php-4.4.0]# find -name apxs

    Mas não foi encontrado, o mais provável é que depois da instalação do php, excluíram o arquivo /usr/sbin/apxs. Porque??? eu também não sei.


    Oque devo fazer????


    Obrigado por qualquer ajuda.

  2. Oi!!

    Tb ja tive este problema, encontrei ele no /usr/local/apache/sbin/apxs.

    No meu caso meu apache estava em /usr/local, possa ser que o seu esteja em outro diretorio, mas procure no /sbin de seu apache.

    Valeu



  3. #3
    cag
    instale o pacote apache-devel.






Tópicos Similares

  1. Problema na compilaçao do kernel 2.6.7!
    Por nozey no fórum Servidores de Rede
    Respostas: 7
    Último Post: 03-08-2004, 19:28
  2. Erro com ncurses na compilação do kernel
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 10-03-2004, 09:28
  3. Erro na compilacao do qmail
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-10-2003, 09:37
  4. erro na compilacao do ipnat do OpenBsd
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-09-2003, 16:41
  5. VPN-Erro na compilação do Kernel
    Por marram no fórum Servidores de Rede
    Respostas: 4
    Último Post: 15-09-2003, 22:26

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L