+ Responder ao Tópico



  1. #1

    Padrão apt-get remove --purge nao consigo remover pacote

    Seguinte já tentei de varias maneiras remover o php do meu servidor pra atualizar por um pacote mais novo sempre quando olho no info.php ele me retorna a versao antiga do php já tentei instalar o a nova e nada sempre me da a versao antiga e nao consigo remover de jeito algum a versao antiga.

    erros:

    host:/var/cache/apt/archives# apt-get remove --purge php4-common
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    O pacote php4-common não está instalado, então não será removido
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 124 não atualizados.
    host:/var/cache/apt/archives#

    host:/var/cache/apt/archives# apt-get remove --purge php4
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    O pacote php4-common não está instalado, então não será removido
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 124 não atualizados.
    host:/var/cache/apt/archives#

    host:/var/cache/apt/archives# apt-get remove --purge php
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    E: Impossível achar pacote php
    host:/var/cache/apt/archives#

    host:/var/cache/apt/archives# ls php
    php3_3%3a3.0.18-28_i386.deb php4-cli_4%3a4.3.10-2_i386.deb php4-imap_4%3a4.3.10-2_i386.deb
    php4_4%3a4.3.10-2_all.deb php4-common_4%3a4.3.10-16_i386.deb
    php4-cgi_4%3a4.3.10-2_i386.deb php4-common_4%3a4.3.10-2_i386.deb
    host:/var/cache/apt/archives# dpkg -r php

    quando vou remover qualquer um desse pacotes retorna o seguinte erro:

    host:/var/cache/apt/archives# dpkg -r php4-cgi_4%3a4.3.10-2_i386.deb
    dpkg: você precisa especificar pacotes com seus próprios nomes, não citando os nomes dos arquivos em que eles vêm

    Digite dpkg --help para ajuda sobre instalação e desinstalação de pacotes[*];
    Use dselect para gerenciamento amigável de pacotes;
    Digite dpkg -Dhelp para uma lista de valores de marcas de debug do dpkg;
    Digite dpkg --force-help para uma lista de opções para forçar certas operações;
    Digite dpkg-deb --help para ajuda sobre manipulação de arquivos *.deb;
    Digite dpkg --licence para licença de direitos autorais e falta de garantia (GNU GPL)[*].

    Opções marcadas com[*] produzem muita saída de texto - passe-a por `less' ou `more' !
    host:/var/cache/apt/archives#


    Já tentei tb com comando "dpkg --purge pacote" retorna o mesmo erro descrito acima.


  2. #2
    mcm
    Visitante

    Padrão apt-get remove --purge nao consigo remover pacote

    Cara, poste aqui o resultado de:

    dpkg -l | grep -i php

    Inté!



  3. #3
    onMhowTo
    Visitante

    Padrão lista de pacotes

    Seguinte,

    Você precisa saber qual são os pacotes php instalados, faça
    # dpkg -l | gre -i php
    com a lista em mão use o dpkg para remover um por um com o comando
    # dpkg --purge <nome do pacote que esta na lista acima>
    Seria bom verificar com o apt-get se houve algum problema de dependencia com o comando
    # apt-get install -f
    Cuidado, se alguma dependencia do php estiver zuada ele pode reinstalar o php denovo!
    Não deixe, ao invéz tente remover o pacote que depende dele.
    Isto acontece porque as vezes, mesmo que um pacote não tenho o nome de php, ele dependa dele (fazer oque, acontece!
    Depois instale o php que voce deseja.

    Dica, se for instalar apartir do fonte, procure pela ferramenta checkinstall, ele pode gerar um pacote do fonte pra você, assim fica fácil desinstalar um pacote que veio do fonte. []'s
    8)

  4. #4

    Padrão apt-get remove --purge nao consigo remover pacote

    tente:

    Código :
    # dpkg -r php4-cgi_4%3a4.3.10-2_i386

    Talvez você fique surpreso



  5. #5

    Padrão apt-get remove --purge nao consigo remover pacote

    Aee mcm o resultado foi o seguinte:

    host:/home/user# dpkg -l | grep -i php
    rc php3 3.0.18-28 PHP3 scripting language - apache module
    rc php4-cgi 4.3.10-2 server-side, HTML-embedded scripting languag
    rc php4-cli 4.3.10-2 command-line interpreter for the php4 script
    rc php4-imap 4.3.10-2 IMAP module for php4
    host:/home/user#


    como remove eles?????????????

  6. #6

    Padrão apt-get remove --purge nao consigo remover pacote

    Ae onMhowTo consegui remover do jeito q vc disse ae mas quando entro no meu site http://localhost/info.php, ele me retorna a versao antiga do php a versao: PHP Version 4.3.10-2, como resolvo esse problema pois quero atualizar pra uma versao mais recente de php.


    :good:



  7. #7
    mcm
    Visitante

    Padrão apt-get remove --purge nao consigo remover pacote

    Você removeu todos os pacotes de PHP antes de instalar o novo?

  8. #8
    D4rk_Sl4ck
    Visitante

    Padrão apt-get remove --purge nao consigo remover pacote

    Citação Postado originalmente por ifc0nfig
    Ae onMhowTo consegui remover do jeito q vc disse ae mas quando entro no meu site http://localhost/info.php, ele me retorna a versao antiga do php a versao: PHP Version 4.3.10-2, como resolvo esse problema pois quero atualizar pra uma versao mais recente de php.


    :good:

    Essa num é a versão padrão do Debian naum??? agora se vc quer php 5, ai é outra coisa .... vc terá que usar algum backport, etc.



  9. #9

    Padrão Re: apt-get remove --purge nao consigo remover pacote

    dpkg -r php
    dpkg --purge php

  10. #10

    Padrão Re: apt-get remove --purge nao consigo remover pacote

    Citação Postado originalmente por gatoseco
    dpkg -r php
    dpkg --purge php

    Jean Carlos

    Seguinte quando executo esse comando olha o erro que dá:

    host:/home/user# dpkg -r php
    dpkg - aviso: ignorando pedido para remover php que não está instalado.
    host:/home/user#

    host:/home/user# dpkg --purge php
    dpkg - aviso: ignorando pedido para remover php que não está instalado.
    host:/home/user#


    Ele diz que nao está instalado só q quando eu vou no browser e digito http://localhost/info.php

    Ele me retorna a versao antiga q ele diz q nao está instalada.