+ Responder ao Tópico



  1. #1
    winter_man
    Visitante

    Padrão Montar partião com permissão para usuários

    Olá Pessoal Boa Noite!!

    Estou montando uma partição (vfat) em um ponto de montagem em /mnt (como root), acesso normalmente, porém quando tento acessar como usuário comum ele não permite, dá como acesso negado.

    Existe algum parametro em especial no comando mount?? Talves uma informação interessante é que: O diretório tem permissão 777, quando monto a partição e dou um ls -l a permissão do diretório muda. Por quê isso ocorre??

    Grato à todos

  2. #2
    wrochal
    Visitante

    Padrão Montar partião com permissão para usuários

    Caro,

    Basta colocar no /etc/fstab, da seguinte forma:

    /dev/hda1 /win vfat umask=0222 0 0

    E depois execute:

    mount -a

    Falou,



  3. #3

    Padrão Montar partião com permissão para usuários

    estou com o mesmo problema..
    tentei essa config no meu e não mudou nada!
    []'s

  4. #4
    wrochal
    Visitante

    Padrão Montar partião com permissão para usuários

    No meu funciona.

    Basta fazer isso.



  5. #5
    fpmazzi
    Visitante

    Padrão Montar partião com permissão para usuários

    amigo ve se tem algo no seu arquivo, um ponto que não esteja percebendo ou algo assim, pois eu tbm desde coloquei outro HD e inseri o codigo acima no fstab, nao tive problemas ...

  6. #6
    winter_man
    Visitante

    Padrão Montar partião com permissão para usuários

    Citação Postado originalmente por wrochal
    Caro,

    Basta colocar no /etc/fstab, da seguinte forma:

    /dev/hda1 /win vfat umask=0222 0 0

    E depois execute:

    mount -a

    Falou,
    Cara fiz isso porém não adiantou. Teria outras alternativas??



  7. #7

    Padrão Montar partião com permissão para usuários

    1 - Cria um grupo de usuário que têm direito a ler e escrever:
    Código :
    # groupadd vfat

    2 - Adicione/crie os usuários dentro deste grupo:
    Código :
    # useradd $USER -g vfat
    ou
    # adduser $USER vfat
    ou edite o /etc/group

    3 - Edite o /etc/fstab e coloque algo do tipo:
    Código :
    /dev/hdd1       /mnt/hdd1       vfat    rw,user,defaults,gid=1000       0       0

    Onde gid é o group ID do grupo vfat.

    4 - Desmonte:
    Código :
    # umount -a

    5 - Monte:
    Código :
    # mount -a

    6 - Seja feliz:
    Código :
    # echo "Eba eba eba, consegui!"


    Falow.

  8. #8
    winter_man
    Visitante

    Padrão Montar partião com permissão para usuários

    Citação Postado originalmente por xstefanox
    1 - Cria um grupo de usuário que têm direito a ler e escrever:
    Código :
    # groupadd vfat

    2 - Adicione/crie os usuários dentro deste grupo:
    Código :
    # useradd $USER -g vfat
    ou
    # adduser $USER vfat
    ou edite o /etc/group

    3 - Edite o /etc/fstab e coloque algo do tipo:
    Código :
    /dev/hdd1       /mnt/hdd1       vfat    rw,user,defaults,gid=1000       0       0

    Onde gid é o group ID do grupo vfat.


    4 - Desmonte:
    Código :
    # umount -a

    5 - Monte:
    Código :
    # mount -a

    6 - Seja feliz:
    Código :
    # echo "Eba eba eba, consegui!"


    Falow.
    Grato pelo post xstefanox, porém não rolou naum. O estranho é: Eu tenho três partições montadas, uma ext3 e duas fat32, com a ext3 naum tenho problemas pois quando quero dar/tirar permissões para usuários apenas altero as permissões do ponto de montagem, porém no fat32 (em ambas) usuário nenhum consegue acessar, algo interessante que eu pude notar é que quando eu monto a partição as permissões do ponto de montagem são alteradas tbm não dando nem pra root efetuar alterações. Com relação a criação de grupo. criei o grupo vfat (com apenas um membro) o mesmo com GID 501 editei o arquivo fstab e adcionei a seguinte entrada ao mesmo:

    /dev/hda8 /mnt/teste vfat rw,defaults,gid=501 0 0

    em seguida executei umount -a / mount -a, tentei acessar e....

    echo "Permissão Negada"

    abraço

    flw



  9. #9

    Padrão Montar partião com permissão para usuários

    falae povo!!
    consegui encontrar uma solućão!

    o artigo se encontra em: http://my.opera.com/lounge/forums/to...d=83440&page=1

    o comando em que eu consegui ler/escrever é com as općões defaults e umask=000

    abraćos!

  10. #10
    winter_man
    Visitante

    Padrão Montar partião com permissão para usuários

    Citação Postado originalmente por _N3o_
    falae povo!!
    consegui encontrar uma solućão!

    o artigo se encontra em: http://my.opera.com/lounge/forums/to...d=83440&page=1

    o comando em que eu consegui ler/escrever é com as općões defaults e umask=000

    abraćos!
    Aê N3o brigadão rapaz naum eh que deu certo msm!! Meu já tinha tentado de tudo... com essa simples alteração no fstab resolvemos nossa dificuldade.

    Porém acredito q isso naum eh normal... e se eu quiser montar a partição em linha de comando não haverá opção de usuário acessar???

    Grande abraço n3o... flw



  11. #11

    Padrão Montar partião com permissão para usuários

    tem sim!
    quando vc quiser montar no console é só digitar a općão "-o" de options.. todas as općões que vc configura no fstab podem ser colocadas na linha de comando!
    mount -t x -o x,x,x /origem /destino
    abraćos..