+ Responder ao Tópico



  1. #1
    Kzar
    Visitante

    Padrão O squid Parou !

    bom dia pessoal !

    Estou tento um problema com o squid, por algum motivo ele não esta startando, entrei em \var\log e dei uma olhada em messages e lá tinha as seguites mensqagens:

    Sep 20 10:38:14 ServLinux squid[2713]: Squid Parent: child process 2736 exited d ue to signal 25
    Sep 20 10:38:15 ServLinux kernel: Connection attempt: IN=ppp0 OUT= MAC= SRC=216. 73.87.121 DST=201.29.20.247 LEN=72 TOS=0x08 PREC=0x00 TTL=51 ID=0 DF PROTO=UDP S PT=40744 DPT=53 LEN=52
    Sep 20 10:38:17 ServLinux squid[2713]: Squid Parent: child process 2756 started
    Sep 20 10:38:17 ServLinux squid[2713]: Squid Parent: child process 2756 exited d ue to signal 25
    Sep 20 10:38:20 ServLinux squid[2713]: Squid Parent: child process 2776 started
    Sep 20 10:38:21 ServLinux squid[2713]: Squid Parent: child process 2776 exited d ue to signal 25
    Sep 20 10:38:24 ServLinux squid[2713]: Squid Parent: child process 2796 started
    Sep 20 10:38:24 ServLinux squid[2713]: Squid Parent: child process 2796 exited d ue to signal 25
    Sep 20 10:38:24 ServLinux squid[2713]: Exiting due to repeated, frequent failure s
    Sep 20 10:38:25 ServLinux kernel: Connection attempt: IN=ppp0 OUT= MAC= SRC=216. 73.87.121 DST=201.29.20.247 LEN=72 TOS=0x08 PREC=0x00 TTL=51 ID=0 DF PROTO=UDP S PT=40744 DPT=53 LEN=52
    Sep 20 10:40:03 ServLinux kernel: Connection attempt: IN=ppp0 OUT= MAC= SRC=61.235.154.106 DST=201.29.20.247 LEN=357 TOS=0x00 PREC=0x00 TTL=36 ID=0 DF PROTO=UDP SPT=41807 DPT=1027 LEN=337

    pensei em log cheio mas aparentemente tá tudo tranquilo.
    Se alguém souber como desatar este nó agradeço.

    Desde já agradeço a atenção dispensada neste assunto !

  2. #2
    Visitante

    Padrão O squid Parou !

    Você consegue pingar outras maquinas de fora? seu acesso é discado ou banda larga?



  3. #3
    Visitante

    Padrão O squid Parou !

    quais menssagens de erro aparecem quando vc inicia o squid?
    tente refazer o diretorio de cache do squid...(squid -Z)

  4. #4
    Kzar
    Visitante

    Padrão Squid

    já refiz o diretório de cache do squid e mesmo assim não funcionou. Quando reinicio a máquina vejo que o squid startou normalmente, entretanto o ppoe não inicia, mas aí vou lá e starto ele manualmente. Não consegui achar nenhuma mensagem de erro na inicialização do squid, mas se eu der o comando "squid -k reconfigure" aparece a seguinte mensagem:

    squid: ERROR: Could not send signal 1 to process 2796: (3) No such process.

    Cheguei a conclusão então, que o squid não está com algum proplema ao ser iniciado, pois se for na máquina do usuário e desabilitar o proxy, o mesmo navega normalmente na net !

    P.S: Uso Banda Larga para navegar ( VELOX, 256 )

    Para ficar mais estranho ainda é que pela parte da manhã estava funcionando e do nada de tarde parou de funcionar.



  5. #5
    Visitante

    Padrão O squid Parou !

    renomei o squid.conf e utilize o squid.conf.default é claro renomeando para squid.conf e restart o squid p/vê se dar certo

  6. #6

    Padrão O squid Parou !

    O problema é no squid mesmo, os childs estão finalizando logo q são inicializados...

    Tente verificar o seguinte, permisão da pasta onde está o access.log e a permissão do proprio arquivo, e verifique tb o tamanho do arquivo do log, caso o mesmo seja maios q 2 GB , renomeio o proprio e crie outro com o mesmo owner e permissões do anterior



  7. #7

    Padrão O squid Parou !

    Você usa o squid autenticado ?? Qual tipo de autenticação ??

  8. #8
    Kzar
    Visitante

    Padrão O squid Parou !

    Cara valeu, salvou a minha pele ! Muito obrigado mesmo !

    Se um dia precisar de algo é só falar .... Só não tenho dinheiro (RSRS)