Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Oi pessoal,

    Depois do último update nas listas do apt venho enfrentando um probleminha pra instalar os programas.

    Já tentei instalar 3 programas diferentes e é retornada a mensagem abaixo:

    root@dragon:/mnt/hdb2# apt-get -s install nrg2iso
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Os pacotes extra a seguir serão instalados:
    coreutils e2fslibs e2fsprogs initscripts libacl1 libblkid1 libc6 libc6-dev libss2 libuuid1 sysvinit
    Suggested packages:
    gpart e2fsck-static locales glibc-doc
    Os pacotes a seguir serão REMOVIDOS:
    initrd-tools
    Os NOVOS pacotes a seguir serão instalados:
    e2fslibs initscripts libacl1 libss2 libuuid1 nrg2iso
    6 pacotes atualizados, 6 novos instalados, 1 a serem removidos e 449 não atualizados.
    Remv initrd-tools (0.1.82 Debian:testing)
    E: Esta execução de instalação irá requerer remover temporariamente o pacote essencial e2fsprogs devido a um loop de Conflitos/Pré-Dependências. Isso geralmente é ruim, mas se você realmente quer fazer isso, ative a opção APT::Force-LoopBreak.
    E: Internal Error, Could not early remove e2fsprogs
    Todos os 3 programas citavam a remoção temporária do mesmo pacote (e2fsprogs). Estou com medo de fazer a instalação e ter problemas e também não tenho como fazer backup agora. O que devo fazer? Alguém já passou por isso?

  2. #2
    Citação Postado originalmente por Lipse
    Oi pessoal,

    Depois do último update nas listas do apt venho enfrentando um probleminha pra instalar os programas.

    Já tentei instalar 3 programas diferentes e é retornada a mensagem abaixo:

    root@dragon:/mnt/hdb2# apt-get -s install nrg2iso
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Os pacotes extra a seguir serão instalados:
    coreutils e2fslibs e2fsprogs initscripts libacl1 libblkid1 libc6 libc6-dev libss2 libuuid1 sysvinit
    Suggested packages:
    gpart e2fsck-static locales glibc-doc
    Os pacotes a seguir serão REMOVIDOS:
    initrd-tools
    Os NOVOS pacotes a seguir serão instalados:
    e2fslibs initscripts libacl1 libss2 libuuid1 nrg2iso
    6 pacotes atualizados, 6 novos instalados, 1 a serem removidos e 449 não atualizados.
    Remv initrd-tools (0.1.82 Debian:testing)
    E: Esta execução de instalação irá requerer remover temporariamente o pacote essencial e2fsprogs devido a um loop de Conflitos/Pré-Dependências. Isso geralmente é ruim, mas se você realmente quer fazer isso, ative a opção APT::Force-LoopBreak.
    E: Internal Error, Could not early remove e2fsprogs
    Todos os 3 programas citavam a remoção temporária do mesmo pacote (e2fsprogs). Estou com medo de fazer a instalação e ter problemas e também não tenho como fazer backup agora. O que devo fazer? Alguém já passou por isso?
    Problemas com apt vixi nem sei muito mas tente remover os pacotes atualizados e depois instale-os novamente



  3. Olá! Eu já tive uns problemas com o APT, não me recordo se me retornavam esse erro, mas quando os tinha acabava resolvendo com o seguinte comando:

    apt-get -f install

    Ele resolvia as dependências que estavam com problema!

    Se isso não resolver, você pode tentar remover as entradas que foram recentemente adicionadas no sources.list e executar:

    apt-get clean
    apt-get update

    E ai você pode tentar instalar esse programa que você quer novamente!

    Caso continue tendo problemas, ai eu recomendo ir para o source do programa e compilar ele na mão!

    Bom, qualquer coisa poste ai!

    Falows... :good: :good:

    André

  4. Dei o apt-get -s install, aliás, já tinha dado esse comando antes, mas não há problemas pra corrigir.

    O negócio é o seguinte, pra instalar alguns pacotes, é preciso remover temporariamente um outro por questões de conflito. Só que esse pacote a ser removido, é essencial para o funcionamento do sistema, de acordo com o apt.

    O que eu quero saber é se esse tal pacote (e2fsprogs) é realmente tão essencial que não pode ser removido por alguns minutos e depois reinstalado?

    Bom, fico no aguardo.

    Mesmo assim, valeu pessoal.



  5. Mensagem repetida.






Tópicos Similares

  1. Problemas com apt-get
    Por gianrubio no fórum Sistemas Operacionais
    Respostas: 4
    Último Post: 14-12-2006, 15:09
  2. Problemas com APT-GET
    Por wagner.brasileiro no fórum Sistemas Operacionais
    Respostas: 5
    Último Post: 27-09-2006, 22:00
  3. Problemas com apt-get dos pacotes do samba
    Por centralservice no fórum Servidores de Rede
    Respostas: 0
    Último Post: 19-12-2005, 09:31
  4. problemas com apt-get no cl8
    Por augustocss no fórum Servidores de Rede
    Respostas: 4
    Último Post: 15-09-2004, 07:31
  5. Problemas com APT-GET no Conectiva 8
    Por lucianosds no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-06-2004, 07:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L