+ Responder ao Tópico



  1. #1
    cbfs
    Visitante

    Padrão tty nao funciona

    sou iniciante e tou fuçando em tudo. eu fiz alguma coisa q fez com q os tty sumice, ou seja, qnd faço Ctrl+Alt+F1...F6 ele num funciona. O q devo fz p resolver isso???

  2. #2
    pre-feit0
    Visitante

    Padrão New é assim mesmo....

    Acontece...

    Se for só isso, dá uma olhada no seu arquivo /etc/inittab e verifica se ele esta assim....

    # Run gettys in standard runlevels
    1:2345:respawn:/sbin/mingetty tty1
    2:2345:respawn:/sbin/mingetty tty2
    3:2345:respawn:/sbin/mingetty tty3
    4:2345:respawn:/sbin/mingetty tty4
    5:2345:respawn:/sbin/mingetty tty5
    6:2345:respawn:/sbin/mingetty tty6


    Assim tá moleza, não acostuma naum..... 8)



  3. #3

    Padrão tty nao funciona

    isso ja aconteceu tb comigo qdo eu habilitei o login direto no X...ele ja startava no modo grafico mas naum dx eu usar nenhum console...
    diz ai nas coisas q vc tava fuçando pelo menos as ultimas :good:

  4. #4
    cbfs
    Visitante

    Padrão tty nao funciona

    mexi no arquivo /etc/X11/XF86Config-4 para colocar a resolucao vga=794 (1280 x 1024);

    BISHOP, e oke tu fez p ajeitar???



  5. #5
    cbfs
    Visitante

    Padrão tty nao funciona

    arquivo /etc/inittab
    Código :
    #  <id>:<runlevels>:<action>:<process>
    1:12345:respawn:/sbin/getty 38400 tty1
    2:2345:respawn:/sbin/getty 38400 tty2
    #3:2345:respawn:/sbin/getty 38400 tty3
    #4:2345:respawn:/sbin/getty 38400 tty4
    #5:2345:respawn:/sbin/getty 38400 tty5
    #6:2345:respawn:/sbin/getty 38400 tty6

  6. #6

    Padrão tty nao funciona

    foi simples rs* eu desfiz o q havia feito rs*....
    e se seu inittab tah comentado vc tem tem o console 1 e 2 liberado vc tah dando boot em modo grafico?


    Citação Postado originalmente por cbfs
    mexi no arquivo /etc/X11/XF86Config-4 para colocar a resolucao vga=794 (1280 x 1024);

    BISHOP, e oke tu fez p ajeitar???



  7. #7
    cbfs
    Visitante

    Padrão tty nao funciona

    tou dando boot em modo grafico. e vc fez oke p desfazer???

  8. #8

    Padrão tty nao funciona

    entao o q eu fiz foi desfazer o q havia feito p estudar o pq naum libera o console se vc inicia em modo grafico...mas ainda naum tive tempo ou seja desabilite o logino no modo grafico ou entaum coloca o kdm p inicializar no rc.local

    Citação Postado originalmente por cbfs
    tou dando boot em modo grafico. e vc fez oke p desfazer???



  9. #9
    cbfs
    Visitante

    Padrão tty nao funciona

    entaum coloca o kdm p inicializar no rc.local
    como disse sou iniciante, tenhaum calma. dei um updatedb e depois um locate kdm. vi o kdm em varios diretorios ql kdm eu coloco num rc.local, e pode ser em qlq rc

  10. #10

    Padrão tty nao funciona

    ops sry rs*
    assim qdo kiser axar um programa executavel vc pode usar o
    whereis comando
    o caminho completodo kdm eh aki eh:

    /opt/kde/bin/kdm

    e o rc.local q eu me referia eh o /etc/rc.d/rc.local

    mas esse camunho eh no slackware qual a distro q vc tah usando?
    Citação Postado originalmente por cbfs
    como disse sou iniciante, tenhaum calma. dei um updatedb e depois um locate kdm. vi o kdm em varios diretorios ql kdm eu coloco num rc.local, e pode ser em qlq rc



  11. #11
    cbfs
    Visitante

    Padrão tty nao funciona

    descobri o erro no arquivo /etc/X11/XF86Config-4
    Código :
    Section "InputDevice"
     Identifier "Keyboard0"
     Driver "keyboard"
     Option "CoreKeyboard"
     Option "XkbRules" "xfree86"
     Option "XkbModel" "abnt2"
     Option "XkbLayout" "abnt2"
    EndSection

    o problema era q o layout n tava configurado estando assim:
    Código :
     Option "XkbLayout" ""

  12. #12

    Padrão tty nao funciona

    naum entendi ele tava assim:

    Citação Postado originalmente por cbfs
    descobri o erro no arquivo /etc/X11/XF86Config-4
    Código :
     Option "XkbLayout" "abnt2"
    EndSection
    e vc deixou assim?

    Citação Postado originalmente por cbfs
    Código :
     Option "XkbLayout" ""
    tava com abnt2 e vc colocou em branco foi isso?



  13. #13
    cbfs
    Visitante

    Padrão tty nao funciona

    tava assim:
    Código :
    Código:
     
    Section "InputDevice"
     Identifier "Keyboard0"
     Driver "keyboard"
     Option "CoreKeyboard"
     Option "XkbRules" "xfree86"
     Option "XkbModel" "abnt2"
     Option "XkbLayout" ""
    EndSection

    e coloquei assim, ai funcionou.
    Código :
    Código:
     
    Section "InputDevice"
     Identifier "Keyboard0"
     Driver "keyboard"
     Option "CoreKeyboard"
     Option "XkbRules" "xfree86"
     Option "XkbModel" "abnt2"
     Option "XkbLayout" "abnt2"
    EndSection

  14. #14
    pre-feit0
    Visitante

    Padrão modo gráfico vs modo texto

    Se você estiver no modo gráfico, para ir para o modo texto nos terminais 1,2,3,4... você deve utilizar ctrl+alt+F1, ctrl+alt+F2 e etc.
    No modo texto só alt+F1... alt+F7 já basta.
    Se você não quiser mais entrar diretamente em modo gráfico, você edita o inittab também, mas na parte do "initdefault".
    Altere o initdefault de 4 ou 5 (depende da sua distro) para 2 ou 3.

    Outro detalhe:

    # <id>:<runlevels>:<action>:<process>
    1:12345:respawn:/sbin/getty 38400 tty1
    2:2345:respawn:/sbin/getty 38400 tty2
    #3:2345:respawn:/sbin/getty 38400 tty3
    #4:2345:respawn:/sbin/getty 38400 tty4
    #5:2345:respawn:/sbin/getty 38400 tty5
    #6:2345:respawn:/sbin/getty 38400 tty6
    depois do primeiro : temos 12345 e 2345, poderíamos ter também 345 ou 23, o que isto quer dizer?
    Quer dizer o runlevel que o terminal estará habilitado.
    Se você tirar o comentário das linhas 3,4,5 e 6 e mudar para 23, significa que quando em modo gráfico os terminais 3,4,5 e 6 não estarão habilitados.

    Mais um detalhe. Como só o 1 e 2 estão habilitados, é provavel que o seu ambiente gráfico seja o tty3!

    Boa sorte! 8)