+ Responder ao Tópico



  1. #1
    Scarin.San
    Amigos,

    Estou com um problema bem chato .... instalei o linux Conectiva 10 .... e estou tentando compartilhar a internet .... bom, fiz o dhcp na placa certa ... os micros da rede estão recebendo ip .... e executeis os seguintes comando para compartilhar a internet ....

    service dhcpd start
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    iptables -A INPUT -p tcp --syn -s 192.168.0.0/255.255.255.0 -j ACCEPT
    echo 1 > /proc/sys/net/ipv4/ip_forward

    o problema é que alguns sites eu consigo ver, como o www.google.com.br, www.uol.com.br mas outros não como o www.terra.com.br

    não faço ideia do por que disso, muitos sites eu vejo e outros muitos eu não vejo ....

    bom, espero q alguem possa me ajudar,

    vl'z !!!!

    Scarin.San

  2. Bem colega.. verifique se esses sites que vc consegue "ver" n se encontram na cache dos navegadores..
    se não for disso.. a unica coisa que tou a ver que possa dar errado é os DNS..
    verifique se os dados do DNS fornecidos pelo DHCP aos clientes , estão correctos..
    um abraço



  3. Citação Postado originalmente por Scarin.San
    Amigos,

    service dhcpd start
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    iptables -A INPUT -p tcp --syn -s 192.168.0.0/255.255.255.0 -j ACCEPT
    echo 1 > /proc/sys/net/ipv4/ip_forward
    Experimente trocar o -o eth0 por -i iface_de_entrada

    Até onde eu entendo esta regra funciona do seguinte jeito:

    faça um mascaramento de tudo que vier de tal iface.

  4. acho q o problema nao eh no mascaramento, pois essa parte estah correta... provavelmnete o problema estah mesmo no DNS, como disse o colega The-shadow.

    feito.



  5. #5
    sambaloco40
    De fato, os mascaramento está correto. Também faço isso nos meus server e funciona dessa forma.
    Bom, por um acaso a sua conecção com a internet não é virtua, é? Porque tive uns problemas como, esses de entrar em uns sites e não entrar em outros, quando tentei compartilhar uma conecção virtua. Depois de suar muito, resolví colocar um proxy no servidor que compartilhava a internet (virtua) e resolveu o problema.
    Caso contrário, fiscalize o server DNS para ver se está tudo bem.

    []'s ! :clap:






Tópicos Similares

  1. Respostas: 0
    Último Post: 01-04-2006, 19:30
  2. Tô com problema em compartilhar a conexão
    Por jailsonlopes no fórum Redes
    Respostas: 2
    Último Post: 07-03-2005, 16:14
  3. Problemas em compartilhar a internet
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 04-11-2003, 08:56
  4. Problemas em compartilhar a internet
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-10-2003, 19:00
  5. Problemas em compartilhar a internet
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-10-2003, 18:59

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L