+ Responder ao Tópico



  1. #1
    salsa
    Visitante

    Padrão nao consigo acesso de um ip externo ao meu server!

    Olá galera, to com o seguinte problema, tenho um servidor na empresa com 2 placas de rede... e quando tento acessar o servidor com um ip externo, ou seja, fora da empresa, eu nao consigo.. eu nao consigo nem pingar o ip da empresa daqui de casa... qq esta acontecendo?

    meu modem eh um speedtouch q tah como roteador.. e a internet eh pra empresas.

    vale lembrar que quando ligo o link no hub e o servidor e os outros pcs da rede no hub... sem usar iptables ou outra coisa, como esta configurado agora... eu consigo acesso externo sem problemas.


    no servidor, configurei assim:

    Código :
    eth0 = recebe o link de internet do modem

    Código :
    eth1 = passa o link de internet recebido pro hub, para que ele distribua a conexao pela rede.


    configurei o meu DHCPD desse jeito..
    Código :
    option domain-name "Empresa";
    option domain-name-servers 200.204.0.10;
    option domain-name-servers 200.204.0.138;
    option subnet-mask 255.255.255.0;
    default-lease-time 600;
    max-lease-time 7200;
     
    subnet 192.168.0.0 netmask 255.255.255.0 {
            range 192.168.0.1 192.168.0.100;
            option broadcast-address 192.168.0.255;
            option routers 192.168.0.1;
            }


    setei o ip da minha placa de rede
    Código :
    ifconfig eth1 192.168.0.1 up

    depois coloquei as regras do iptable e tal..
    Código :
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    e entao ativei o meu dhcpd ...
    Código :
    dhcpd eth1 -q


    meu squid esta configurado pra bloquear paginas, nao sei se isso é importante, mas tb coloquei uma outra regra no iptables pra fazer com que ele funcione como quero.
    Código :
    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128



    resumindo, esta tudo funcionando do jeito que quero por enquanto, o meu problema esta sendo efetuar acesso do servidor externamente, ex..

    tento abrir alguma pagina do servidor e nao consigo, tento acessa-lo por ssh e nao consigo, ftp nada etc etc...
    e internamente, na rede local eu consigo sem problemas....

    o que fazer?


    *** outra coisa que esqueci de citar, eh que todos os computadores que estao na rede, quando navegam na internet, meio que tem problemas, ex.. to la navegando e do nada, da pagina nao encontrada, ae eu tenho que reparar a conexao no windows xp, ou fechar e abrir o browser pra funcionar...
    meio que fica caindo a conexao de internet toda hora.

    :toim:

    valeuz ae e abraço pra todos

  2. #2
    elimar
    Visitante

    Padrão SOLUÇÂO

    O problema é o modem q tem configuração internat de porta tive este tipo de problema na minha rede.

    www.abusar.org



  3. #3
    Avenger
    Visitante

    Padrão nao consigo acesso de um ip externo ao meu server!

    Você nem falou que ip que fica na eth0, estou assumindo que seja um IP falso, tipo 192.168.254.1.

    Desativa aquele internat, deixa só nat normal, e procura algo de DMZ, aponta o DMZ de forma definitiva pro 192.168.254.1.
    A partir daí você consegue acessar de fora o seu servidor linux (desativa alguns firewalls e IDSes do modem/router também, se tiver).

    Nota idiota: prá acessar seu servidor linux de fora, você tem que entrar com o IP REAL do seu Router/modem DSL, e NUNCA 192.168.254.1. :P

    Se o IP configurado na sua eth0 é real mesmo, esquece o DMZ, e desativa TUDO que tiver de port forward, firewall, IDS, NAT interNAT. Já que você tá fazendo o NAT na sua máquina Linux...

    Nota besta retrógrada: vc não precisa da regra masquerade no linux, se sua eth0 tem ip falso, uma vez que seu modem neste caso vai fazer o NAT das conexões. Por outro lado, você vai ter que adicionar uma rota estática no router prá 192.168.0.0/24 via gateway 192.168.254.1.

    Espero que as informações aí ajudem (e que minha suspeita esteja errada. suspeita: de que os moderadores excluem qualquer mensagem que contenha qualquer palavra tipo 'bosta', 'cocô', 'idiota' ou 'besta', por mais que as informações lá sejam direcionadas a responder a pergunta, e que os 'palavrões' não ofendam a quem fez a pergunta -- ex.: chamei a NOTA de besta, não a pessoa que estou respondendo!
    Essa revoltinha de final-de-post é porque respondi direitinho um post de um cara com dúvida sobre fazer um telnet e executar um comando, e o 'telnet' não pedir senha, mas no início da resposta eu reclamei um pouco porque tinha perdido uns envios de posts devido a problema no site/IE. Hoje entrei num tópico e vi uma pergunta igualzinha à que tinha respondido -- sem minha resposta! Fikei com essa pulga atrás da orelha!

    Já falei 'espero que ajude'? Bem, pelo menos a parte que respondi sobre seu problema!