+ Responder ao Tópico



  1. #1
    Bartware
    Visitante

    Padrão Problema com DansGuardian

    Olá...


    Me aventurei na instalação / configuração do DansGuardian em um Debian... o squid está configurado e funcionando perfeito. O DansGuardian também foi instalado corretamente.

    Quando eu fui testar de uma maquina cliente da rede o bloqueio do DansGuardian, entrei no google e digitei "sex" na pesquisa. O DansGuardian corretamente bloqueou o acesso.

    Porém ele, aparentemente, bloqueou o ip da máquina cliente para acesso a qualquer página, pois se o browser do cliente usa a porta 8080, nada é acessado. Caso eu mude a porta para 3128 na configuração do browser da máquina cliente, ela passa a acessar normalmente.

    Como faço para desbloquear esse cliente e evitar que essa situação se repita?


    Abraços,

    Bruno Nunesmaia

  2. #2
    Visitante

    Padrão Re: Problema com DansGuardian

    Citação Postado originalmente por Bartware
    Olá...


    Me aventurei na instalação / configuração do DansGuardian em um Debian... o squid está configurado e funcionando perfeito. O DansGuardian também foi instalado corretamente.

    Quando eu fui testar de uma maquina cliente da rede o bloqueio do DansGuardian, entrei no google e digitei "sex" na pesquisa. O DansGuardian corretamente bloqueou o acesso.

    Porém ele, aparentemente, bloqueou o ip da máquina cliente para acesso a qualquer página, pois se o browser do cliente usa a porta 8080, nada é acessado. Caso eu mude a porta para 3128 na configuração do browser da máquina cliente, ela passa a acessar normalmente.

    Como faço para desbloquear esse cliente e evitar que essa situação se repita?


    Abraços,

    Bruno Nunesmaia



  3. #3
    Bartware
    Visitante

    Padrão Problema resolvido...

    Pessoal,


    O problema foi resolvido. O que estava acontecendo é que o Squid não estava dando as devidas permissões para o DansGuardian fazer seu trabalho. Resolvi o problema incluindo a seguinte linha no squid.conf:

    acl src localhost 127.0.0.1/255.255.255.255
    http_access allow localhost

    Pronto. Problema resolvido.


    Abraços,

    Bart Nunesmaia