+ Responder ao Tópico



  1. #1

    Padrão Problemas com o PHP

    Ae galera,

    To usando o gentoo ja faz um tempo, tenho um server de e-mail instalado seguindo o Tutorial do site oficial , com postfix+mysql. Rodando blza. Uso o Squirellmail, tranquilo!

    Agora é o seguinte, instalei um openldap, e coloquei os contatos para consulta do Outlook e Thunderbird, está funcionando redondo !!!! Agora quero colocar esse suporte no Squirellmail, mas não ta rolando... não consigo habilitar de modo algum o ldap no php desse server...

    Assim, a base ldap esta na minha maquina por enquanto, está pra teste ainda apenas, na minha estação eu ja instalei tudo com o suporte ldap ativado. E o php com ldap está funcionando, uso o phpldapadmin até. No meu server, eu estou tentando habilitar agora o suporte ldap no php, e não está indo. Ele consta que está habilitado, mas nada, eu ate coloquei o phpldapadmin lá e me da a menssagem falando q não há suporte. Eu recompilei o php assim:

    USE"ldap" emerge dev-php/php

    Ele compila sem erro e tal... o php funciona(Squirell ainda abre). Mas não há o suporte ainda.

    Já conferi o php.ini das duas maquinas, e estão identicos. As flgas em /etc/conf.d/apache2 estão assim: -D SSL -D PHP4 .

    Estou pensando em remover o pacote e habilitar e instalar de novo, mas qria tentar alguma solução sem ter q fazer isso... algume consegue dar um help ??

  2. #2
    felco
    Visitante

    Padrão Problemas com o PHP

    faz um # emerge dev-php/php -pv e manda aqui



  3. #3

    Padrão Problemas com o PHP

    Oi desculpe a demora para postar aqui. Na verdade eu que viajei, não basta apenas o php, precisoei tb do mod_php, pois ele que é usado pelo apache

    Já está tudo certo, obrigado!